13 Replies Latest reply: Jan 7, 2016 3:04 AM by claireyb75
marilee smith Level 1 (0 points)

How do you turn your outgoing mail server to online vs offline

  • VikingOSX Level 6 (15,818 points)

    Mail Preferences > Accounts: Select the Account you want to take offline. Under the Account Information tab, uncheck or check, “Enable this account,” to toggle offline .vs. online for that specific account.


    Screen Shot 2013-01-07 at 6.42.59 PM.png

  • Linc Davis Level 10 (192,624 points)

    It's offline because the settings are wrong or the server itself is unreachable.


    Troubleshooting sending & receiving email messages

  • Joseph_DC Level 1 (0 points)

    This is not necessarily the case. I just reviewed all of my settings (multiple accounts) in detail with our web host's tech support team and sent test messages. There were no inquiries or attempted sends on the server side.


    He said they've seen this problem in Mac Mail and their only solution is to delete all of the accounts and recreate them -- this is not much different than the plist file deletion I've seen recommended in other posts here on this issue. (These are all POP accounts so we have a real concern about losing messages or at least the connection between message content and their related accounts -- which is virtually the same thing.)


    So, to be clear, this is a problem that's happening entirely on the Mac itself -- spontaneously taking all SMTP (send mail) servers offline, where they are then stuck. Turning all mail accounts offline and back online does not fix it. Quitting mail and relaunching the app does not fix it. All other Internet connections, etc. are functioning properly and inbound mail is getting received, but all mail sending has failed.


    I've seen multiple posts over the last 5-6 years and other than the plist deletion OR the assumption that the settings must be wrong, I've not found an Apple expert posting a non-destructive (i.e. account deletion) solution to this (obviously) well-established and recurring problem.


    If anyone knows of one please link to it in a reply. Thanks very much!

  • Penykat Level 1 (10 points)

    I had this problem too but I fixed it today. I have been unable to send emails with two of my 4 accounts.


    Go to the mail menu preferences.

    Click on account in question.

    Select the outgoing SMTP mail server (the one offline), this has a drop down list, click on the edit server list.

    Click on the advanced button.

    Make sure use default port is checked.

    Make sure SSL is unchecked (unless your provider requires it, mine does not work with it checked).

    Have authentication set to password.

    User name should be your email address for that account.

    Make sure correct password is entered (for some strange reason my password box was blank on this account).

    Push the ok button.


    For me the SSL box was checked and the password was missing. This is strange to me considering I have unchecked the SSL Box on the mail preference advance page. Also, I went through the complete set up account when I first created the account, why was my outgoing server password box empty?

    I hope this helps.

    Here is a link to some visual aids with the steps from my ISP


  • hkimagery Level 1 (0 points)

    I am having this problem, now, and checking or unchecking the SSL box is not working, etc. I've searched for the answer to this problem so many times. Often it will resolve itself after a few days. But not so, this time.


    So Joseph_DC, are you saying the only fix is to delete the accounts?  What about all the emails that are sitting in the inbox?  Will they be deleted, too?  Is there a way to save/archive all the emails before deleting the accounts?


    Thanks for your help. This is very aggravating!

  • Joseph_DC Level 1 (0 points)

    hkimagery, I'm very sympathetic. I spent several hours over two weeks with a senior apple support specialist and he in turn elevated this issue to an engineering team, and in the end the only resolution was a less-than-stellar workaround. NO we did not delete and reinstall our accounts as they are POP accounts and we might have potentially lost the bulk of our messages or at least the Mail app's database that connects to them...


    Our problem is that Comcast (our cable and Internet provider) has permanently closed Port 25. This is the first of three 'default' ports that most providers recommend. The obvious solution is to select the edit server list (as Penykat mentioned above), click on the custom port setting and enter an alternate port. Our email and web host recommends the second default -- Port 465.


    That would be a great solution except that the current version of Mail defaults the custom port setting back to Port 25... We cannot get it to save alternate numbers in the custom port field. The engineering team spent two weeks analyzing the problem and came back with a self-contradictory assessment that ignored the primary problem of the Port 25 default. The specialist I was working with agreed that it made no sense, but said that when the engineers come back with a 'no further action required' finding on a case, that's it.


    I have a couple of active Gmail accounts that are set-up in Mail. They are easy to install and create a simple "Gmail" server in the SMTP list. As a last resort we changed all of my accounts' SMTP server settings to Gmail and my outgoing mail would once again send. THE PROBLEM: Certain recipients' email clients see the mail as coming from my Gmail account and their replies are sent to the Gmail account vs my private corporate account. A bit odd in professional communication.


    If I could find a reliable third-party mail app (oh for the days of Eudora!) that could interact with the address book (or even one that couldn't) and function well in OS 10.8.3 I would dump Mac Mail. Otherwise our only option is to work exclusively via webmail portals, with their limitations. I may go back to Apple Support and see if I can fight the good fight to have this problem fixed in a future update, but for now my business requires all my time.


    Good luck finding a solution and I'll repost here if we find a better one.

  • hkimagery Level 1 (0 points)

    Are you sure that the ports are the issue? I've had the same problem, regardless of whether I was using Comcast or AT&T. I've changed ports, and it didn't help. I think its just some very odd Mac generated issue.  Right now, my outgoing mails are sending again.  As I mentioned, it sometimes fixes itself. But you never know when it might happen again. If you ever find a solution, please let me know. I feel your pain, too!

  • lkomori Level 1 (0 points)

    Penykat, thanks for the tip about editing the server list. I finally solved a frustrating unable-to-send problem through changing the outgoing smtp port - something I couldn't figure out how to do before reading your post. Why that setting is hidden in the "edit smtp list" rather than right beside the setting for incoming port in Preferences/Accounts is beyond me!

  • Di4007 Level 1 (0 points)

    This problem is happening to me now. Beyond frustrating. I've tried a number of possible fixes - including these https://discussions.apple.com/message/24914084?ac_cid=op123456#24914084  - but no luck so far. Is the issue limited to POP or does it affect IMAP accounts also? I'm seriously considering switching email hosting company, but first want to know if changing from a POP to a IMAP account may resolve problem??

  • maaranda Level 1 (0 points)

    OK so I have had this problem for over a month.  Receiving email was not an issue.  It was sending.  I could not send out emails.  Thank you to Joseph!  I did just as he recommended.  I went into preferences, went to outgoing mail server, selected the correct server, went to the drop down and selected edit SMTP server list, went to advanced tab selected Use Custom Port.  Typed in 465, made sure SSL was checked and authentification was password, typed in user name and correct password then pushed OK.  Got completely out of my email and then back in and problem was resolved.  THANK YOU JESUS.....I mean Joseph!

  • My Grin Level 1 (0 points)

    I too am having this issue. What is odd, is that we have 2 iMacs and are having the issue with one and not the other. Communication is really important and APPLE needs to get this fixed asap.  I will try Joseph's suggestion. We have suddenlink.

  • kathleenfromcanon city Level 1 (0 points)

    I thought I was going not-so-slowly nuts. I'd send an email from what I thought was the right account, only to see it went out under a different account... because it had used a different outgoing server, I guess.

  • claireyb75 Level 1 (0 points)

    Thank you so much! I realise this is an old post but yours was the simplest answer but it worked. My headaches can now stop!!!!