2 Replies Latest reply: Jan 8, 2013 6:14 AM by EZ Jim
pwrg4 Level 1 Level 1 (0 points)

I had another discussion going about some firewire issues I was having. I figured I would start a new on with just the iSight issue and tracking down the problem.

 

I bought a new Macbook Pro 13 with OSX 10.8.2 installed. I checked for updates and found there was 10.8.2 Update 2. Installed that and Garage Band, iMovie, iPhoto and updates for Safari and iTunes.

 

Eventually, I got around to trying my external iSight camera. Plugged it in, started up Photo Booth, got the spinning ball of death, and then the app crashed. Every Apple app with video input that I tried crashed.

 

System Information listed the camera under firewire, so the cable was good.

 

I decided to reinstall OSX on a separate partition and go step my step to see what was killing the iSight.

 

Got the the base system installed as it came from the Apple store and tried the iSight. By the way, the iSight is connected via a FW400>FW800. Worked.

 

Next was to download the 10.8.2. Update 2. Installed the update and connected up the iSight. Worked.

 

Next I updated Safari to 6.0.2. Connected the iSight. Worked.

 

Next I updated iTunes to 11.0.1. Connected the iSight. Worked

 

Next I installed iPhoto 11 ver 9.4.2. Connected the iSight. Spinning ball of death. Crashed app.

 

Appearently there is a conflict with iPhoto and the iSight.

 

I might try another reinstall of OSX and install the apps without doing the 10.8.2 Update 2 and see what happens.


MacBook Pro, Firewire Issues
  • pwrg4 Level 1 Level 1 (0 points)

    Ok, I did a couple more fresh installs of 10.8.2.

     

    I did a new install, but forgot to erase the drive before doing so. I'm not sure what all it installed, but iPhoto and iMovie were already there. It did show that the 10.8.2. Update 2 was needed, so I ignored that and tried the iSight camera with Quicktime. It did not work. Crashed the app. So I erased the partition and and did a proper fresh install.

     

    When the install finished, I didn't not update or install anything. I tested the iSight with Quicktime and it worked. Ok, so I installed iMovie. Tested iSight and it worked. Now I installed iPhoto, which caused problems as mention in previous post. Tested iSight and it worked. Great. I just installed Garage Band and all is still working. I have not installed the 10.8.2. Update 2 yet.

     

    So, I'm not sure what is going on. Does iMovie need to install before iPhoto? Do I have to reinstall everything 2-3 times before it works? I guess I'll try the OS update and see if it still works after that.

  • EZ Jim Level 7 Level 7 (21,655 points)

    pwrg4 wrote: ... Does iMovie need to install before iPhoto? ...

     

    No.

     

     

    pwrg4 wrote: ... Do I have to reinstall everything 2-3 times before it works? ...

     

    No.  The following method works first time for me every time:

     

    I ALWAYS use the Combo version of updates.

     

    • Use your Mac's Disk Utility to repair permissions and then

       download and apply the latest Combo Update, for ML Mac OS,

       the current one is at: http://support.apple.com/kb/DL1581

     

    • Repair permissions again immediately following the system restart

       that completes the Combo update.

     

     

     

     

    Message was edited by: EZ Jim

     

     

    Mac OSX 10.8.2