5 Replies Latest reply: Jun 30, 2006 6:03 PM by brandon0104
Mark Jenkinson Level 2 (285 points)
Personal Web sharing wont start. When I click the "Start" button in the Preference Pane, it just says "Web Sharing starting up..." for infinity. If I quit System Preferences, and then reopen it...Personal Web Sharing is "Off"...when I open Console, I get this message:

Processing config directory: /private/etc/httpd/users/*.conf
Processing config file: /private/etc/httpd/users/admin.conf
fopen: No such file or directory
httpd: could not open error log file /private/var/log/httpd/error_log.
/usr/sbin/apachectl start: httpd could not be started

How do I remedy this problem? Thanks in advance,

Mark

PowerMac G5 - Dual 2.7 GHz, Mac OS X (10.4.6), 4.5 GB RAM, 512 GB HD
  • ds store Level 7 (30,325 points)
    Try repairing your permissions in disk utility.

    Also you need to open your firewall, search help.
  • Mark Jenkinson Level 2 (285 points)
    The firewall had nothing to do with it...since Apache wasn't even starting.

    The problem was, as per the Console log, that it couldn't find "/private/var/log/httpd/error_log"...So, I opened the /private/var/log/ directory on my mac, and there was indeed no httpd directory at all. On a hunch, I created a folder and called it httpd and gave it the proper Owner (system) and Group (wheel) permissions...and low and behold It's all fixed.

    Thanks,

    Mark
  • brandon0104 Level 1 (55 points)
    I am having the same problem but I can't seem to find the /private/var/log/ directory. Will you please tell me where its located?

    Brandon
  • Mark Jenkinson Level 2 (285 points)
    Hi Brandon,

    The easiest way to get to that directory is to click the "Go to Folder..." option in the "Go" menu in the Finder. This will bring up a little dialogue (sheet) where you can type /private/var/log and it will open up this invisible directory.

    Hope this helps,

    Mark
  • brandon0104 Level 1 (55 points)
    OK I got that far but apparently adding that folder was not my problem becuase it still says Starting forever!

    Thanks