Previous 1 2 Next 17 Replies Latest reply: Jan 12, 2013 2:21 AM by mgabriel1
mgabriel1 Level 1 (0 points)

Mountain Lion Server rookie, so forgive my ignorance please.


Here are some details:

DNS at the registriar has an A record ( pointing to my public IP and an MX record pointing to

Server is a MacMini, Mountain Lion clean install, V10.8.2, all software updated

DNS on MacMini server has Primary Zone of with an A record ( pointing to my private IP (behind my router) and an MX record pointing to

Cable modem with no NAT and all ports open.

Router is a Time Capsule V7.6.2 with all appropriate ports open for mail.

Client is an Mountain Lion (updated from Lion) OS, v?, all software updated

Apple Mail setting - IMAP account, incoming server:, username and password are same as server user account, outgoing server:


My problem: all devices (MBP and iPad) sync with the server for drafts and sent folders (haven't checked junk and trash yet), but I get nothing sent to the inbox.  I have tried mailing myself from inside and outside my network, no go.  The mail log on the server shows activity for the user account, and states the inbound mail is saved to the users INBOX, but the clients never receive the mail.  The connection doctor on the MBP client shows successful logins to both the incoming and outgoing servers.


I have been scouring the internet for any clues for help and haven't been able to find anyone with this specific problem.  Is there anyone out there that might be able to provide some guidance? 

MacBook Pro (17-inch Late 2011), OS X Mountain Lion (10.8.2)
  • mgabriel1 Level 1 (0 points)

    OK...just got off the phone with Apple support.  They are stating the problem I am having could be caused by the junk mail filters being turned on at the Server...even though the filtering has been shut off for 24 hours.  Is this even correct??  Any help would be great...I have tried different ports, ssl no ssl, different authentication methods, rebooting between setting changes, application quiting and restarting...nothing works.  I am very confident the incoming mail is reaching the server, but not being pushed to the client.


    Help, help, help....

  • mgabriel1 Level 1 (0 points)

    "msgid=<>: saved mail to INBOX"

    This is why I'm saying the incoming mail is hitting the server.  Along with the line are others referencing my user account...Just don't get what is happening.

  • UptimeJeff Level 4 (3,420 points)

    Certainly an odd issue... A couple things come to mind.



    Is the 217A9850....... number really the GUID of the user you are logging in with?

    Every user (ex. mgabriel) has a unuique ID which is where their mail is stored.

    If your imap user is mgabriel, but the GUID for mgabriel isn't that 217A.. number, then we'll have to find out whats going on.


    You can check your GUID with this (replace mgabriel with your imap user)

    sudo /Applications/ -i mgabriel

    This will return a GUID. It should match the number above.



    I'm curious.. and maybe its an interesting excercise.

    Lets look for anything new received in you mail store.


    Everything below is in Terminal

    This assumes your mail store is in the default location. You can check with

         sudo serveradmin settings mail:imap:partition-default


    Send yourself some email, watch the log to be sure its delivered.


    Then this command will search your mailstore for any mail files modified less than 5 minutes ago.

    The path listed assumes the default mailstore location

    sudo find /Library/Server/Mail/Data/mail/ -type f -mmin -5 -name "*S=*"


    If nothing is returned, then no new mail files were written.

    If you see results like:


    Each line is a mail message.


    Past the results back here.



    In your mail client, did you set an IMAP PREFIX ?



    And finally, the logs will probably have the clues we need to solve this.

    Send yourself some mail, then post the (unedited preferred) logs from that time.






  • mgabriel1 Level 1 (0 points)

    First, thank you for your response.  I was a little worried that I might not get any help, so again, thanks.


    Now for the results:

    1) GUID does not match....

    2) mail is stored in the default location.  results of find return two lines...I increased the time (I think) to ten minutes:

    sudo serveradmin settings mail:imap:partition-default


    mail:imap:partition-default = "/Library/Server/Mail/Data/mail"


    sudo find /Library/Server/Mail/Data/mail/ -type f -mmin -10 -name "*S=*"


    /Library/Server/Mail/Data/mail//D29F8828-3980-4EE7-A2B3-5331A93F51D4/.INBOX.Sent Messages/cur/,S=578,W=600:2, Sab


    3) I am a recent windows convert and the waters are still a little muddy on how to access the system files.  I can copy/paste the logs from the window, but I am unable to find the Library location for the log files.

  • mgabriel1 Level 1 (0 points)

    I did try this command in Terminal, with results posted:

    sudo find Library/Logs/Mail/mailaccess.log


    find: Library/Logs/Mail/mailaccess.log: No such file or directory

  • UptimeJeff Level 4 (3,420 points)

    OS X hides many of the system related files/folders.

    /Library is hidden.


    You can get to them from the Finder's Go menu, you will see "Go to folder"

    Here, you can enter a path like



    But... The easiest way to view logs us with the Console application.

    Look in /Applications/Utilities

    From there, you can access most of the system/server related logs.


    The referenced logs should have the clues we need.

  • UptimeJeff Level 4 (3,420 points)

    You say that your guid doesn't match..??

    I'm thikinng you have more than one account.

    Maybe you are checking one via imap but delivering mail to another.


    During that 5 minute period you checked, mail was delivered to 2 accounts




    What GUID does your user have? You checked it with:

    sudo /Applications/ -i username


    Look at your user list... any chance you are checking a different account?

    Post the results of these commands so we can check what users you have in Local and LDAP


    sudo dscl . list Users | grep -v  _
    sudo dscl /LDAPv3/ list Users | grep -v _


    The last command might return an error if you aren't running open directory



  • mgabriel1 Level 1 (0 points)


    I currently do not have the ability to look at the server or the client.  I will be back to it late this evening.  I will report my finding then.  I really appreciate all you help.  I have been pondering the whole userID situation and believe that is quite possibly the problem. 


    At this point, I am the only user.


    On the server, under users I see my local account as admin for the MacMini AND a local network account for server admin.  Then, on the client, I am the local admin. 


    My assumption for the client was it wouldn't matter regarding the login credentials, as long as the IMAP account username and password were correct.  The problem may be a result of all accounts having the same user name, so the server has no idea which user to send the email to....seems logical. 


    If this is in fact the problem, I chalk that up to inexperience on network systems and servers.  Learning as I go on this end, I dont have years of experience with this stuff.  But, you have to start somewhere....

  • UptimeJeff Level 4 (3,420 points)

    Yep.. Sounds like duplicate or similar accounts.


    If you have a single Local and a single Local Network account, thats 2 accounts.

    The system normally prevents you from creating 2 users with the same shortname, but its still possible that it could happen.


    The admin account for Local Network defaults to Directory Administrator with a shortname of diradmin.


    A couple tips.


    Use a unique admin name instead of admin. You are less likely to be hacked.


    Its not the best idea to make your 'user' account an admin.

    If your user credentials are discovered and they can be used to admin the server, you could have all kinds of trouble.


    You should have an admin account and a separate account you use for services (mail, calendar, etc). Your user account should not be set as an admin.

    You could have a sheme like this:

         local:   mgabrieladmin  (administrator)

         localnetwork:   mgabrieldiradmin  (directory administrator)

         localnetwork:   mgabriel  (non-admin, use for mail and other services)



    We all learn as we go.. OS X Server is not simple like OS X, you really do have to get your hands dirty.

    Sounds like you are willing and able  :-)



  • mgabriel1 Level 1 (0 points)

    Well...your not gonna believe this one....

    I was working on checking accounts, rearranging accounts, etc. and the server app crashed in a small moment when I had no admin priviledges.  Unfortunately, I believe this requires some type of restore that I just didn't have an opportunity to establish.  I will dig into it this evening and see what happens.  Again, I REALLY appreciate your help and believe you haved steered me in the right direction.  Now it's just finding my way through my newly induced mess.

  • UptimeJeff Level 4 (3,420 points)

    Not sure I understand.

    You left yourself with no admin account?

    That would be really hard to do.


    If you could explain where you are, i could help..

  • mgabriel1 Level 1 (0 points)

    I was reworking all my accounts trying to understand which one was a local, admin, diradmin...accidentally uncheck the admin priviledge checkbox on all accounts.  The server app closed and now I cannot log onto the Macmini at all.  I would think I could reestablish to a restore point, but have not had an opportunity to look into it.  I am also thinking, since this was a new install, it would be easier to start fresh with a new install of mountain lion, the reinstall the server app.  I have already created a boot disk on a USB from past mess-ups...

  • mgabriel1 Level 1 (0 points)

    OK....back in business.  I am now able to log on to the server and am currently setting up the accounts as discussed.

  • mgabriel1 Level 1 (0 points)

    Here are the results for looking at users:

    sudo dscl . list Users | grep -v _







    sudo dscl /LDAPv3/ list Users | grep -v _






    Uptime - is there any way I could email you the logs?  I am not comfortable posting too much information here for lurking eyes to see...

Previous 1 2 Next