Previous 1 2 Next 19 Replies Latest reply: Jan 22, 2016 1:13 AM by linusik
Mheb Level 1 Level 1

I can't add my phone number in iMessage on my iPad it shows my email address and does not give me an option to add a phone number just more email addresses.


iPad mini, iOS 6.0.2
Reply by sberman on Jan 8, 2013 2:12 PM Helpful
Have you tried adding your phone number in one of the email fields? I suggest adding the phone number with your international dialing prefix.  For example, in the U.S., you would add it as:+1(xxx)yyy-zzzz
Reply by mjkranzler on Apr 18, 2013 10:27 AM Helpful
Hey guys, I just came across this thread while helping two friends set it up on their laptops, and they ran into the same roadblock, being unable to add their phone number to iMessage on Mountain Lion. After some trial and error, here's what worked for me, from that point on: 1. On your iPhone, go to Settings > Messages2. Log out of your Apple ID at the top, and then log back in3. Deselect all of your accounts that are not chat accounts (so if you also use Gchat, you can keep your Google account checked) (I don't know if this step is necessarily required, but it's what worked twice for me; feel free to experiment with this yourself)4. Give iMessage a minute or two on your laptop, while open, to get the new information. You should get a couple pop-up messages telling you about the new settings. Just click OK for each, and you should be good to go! Hope this helps, I don't know why it's more difficult for some people, but basically if you just reset the permissions on your iPhone, it should resolve this issue.

All replies

Previous 1 2 Next