Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: OS Recovery Chunk Validation Failed - Possible Fix!

Hello All,


I have been troubleshooting the OS Recovery chunk validation failure for 3 days now and just found the weirdest fix. This might not work for you due to firewall or proxy issues but the steps below resolved it for me. So please feel free to try.


Mac Mini OS X Server 10.8.2


1. Boot from an OS Recovery drive or thumb drive.


2. Run the OS X Installer.


3. Open the Log Window.


4. Click the Save icon in the log window while the installer is running. This will error out the installer and show your current log. You will get a pinwheel for a minute but it will go away once the log saves.

- if I don't do this step I will keep getting "Chunk validation failed, retrying..." and chunk data never downloads and keeps retrying.


5. Now if I run the OS X Installer again the validation failure never comes up and chunk data starts copying as normal.


I have tested this about 3 times and it works for me. What a strange bug!!!


Hopefully this will help someone!


Thanks! 😉

Support all Mac machines, Mac OS X (10.5.7)

Posted on

Reply

Page content loaded

Jan 31, 2013 11:49 AM in response to jfs610 In response to jfs610

Hi jfs610,


You don't actually have to save the log. What I should have said was "You will get a pinwheel for a minute but it will go away once the log is created." Then just close the log or save dialog and run the installer again. But do not erase the drive or you will run into the same issue.


It seems like the installer doesn't know where to store the chunk data or it isn't recognizing the drive. But creating the log fixes the issue.

Jan 31, 2013 11:49 AM

Reply Helpful

Feb 20, 2013 1:46 PM in response to spraguga In response to spraguga

Dear,


I am having the same issue. I have already tried like 10 times to try to install the software at home and at work with better bandwidth but still with the same issue - Chunk Validation Failed.


I have a Mac Book Air and I am trying to install Lion 10.7.2


I am now downloading again the software until the error message appears and I will try the possible solution of Spraguga doing a SAVE clic. Of course I will let you know.


BR,

Feb 20, 2013 1:46 PM

Reply Helpful (2)

Aug 23, 2013 2:48 PM in response to spraguga In response to spraguga

I had this problem as well - with an Air at work...wasn't aware what was going on until I realized there was a log window under the windows menu.


I tried 3 successive times to complete the download using the "high speed" office connectionwireless once-ethernet twice] at work ranging from 4.5 hours to 6 hours and all failed with the "chunk validation" error. Local tech support didn't engage writing it off as "an Apple problem". I proposed that it was more likely to do with throttling and security settings on the firewall - both were rejected as implausible.


I took the unit home, replicated the steps from my 3 previous tries and 45 minutes later I had a complete install.


The moral of the story is try another network if you can - preferably one set up with more attention to functionality and less to security paranoia. Best of luck - this can be a time-consuming frustrating one to wrestle with.

Aug 23, 2013 2:48 PM

Reply Helpful

Feb 22, 2015 12:42 PM in response to Juicy-Tomato In response to Juicy-Tomato

I'd like to add another answer to help anyone who may encounter this. My scenario was for during the Yosemite recovery, error was showing the internet globe icon and "apple.com/support -2105F" so slightly different error number from what I have been reading.


Prior to this, the recovery process was stuck for hours on "Chunk download failed, retrying...". Eventually I cancelled that process, and that is when I restarted and was stuck with this internet globe icon.


To resolve this, I accidentally happened upon holding the OPTION key down (which was suggested at the first post) during power on. By doing so, the Wifi Network prompt appeared to allow me to choose ANOTHER network (not the firewall/router one, but the DSL one I have on my ISP modem). This was successful, and allowed the recovery process to complete in just over one hour.


So in my case, it did appear to be a Wifi/network/firewall issue. Although I did check and made sure I was using WPA2 and AES, still it did not work.

To answer Juicy-Tomato: your ethernet connection if it is not technically behind your firewall, will bypass it.


Hope this helps someone who is tearing their hair out 🙂

Feb 22, 2015 12:42 PM

Reply Helpful (1)

May 7, 2017 7:43 AM in response to Sterham In response to Sterham

Thank you so much for your reply to the question above!


I niggled at the "chunk validation failed" for 2 hours at the office, on a brand new 15" MacBook Pro 2016.... well once I read all the given replies including yours I switched to the hotspot of my iPhone and the installation went through just fine.... I even contacted Apple Care by phone but they didn't know what could cause it as well.

After it worked fine over the hotspot, I got back in contact with Apple Care and told them how I fixed it. They said they will contact the software team, so maybe they'll add a visual warning or give advice when the installer runs into this problem in the future.


Kind regards

May 7, 2017 7:43 AM

Reply Helpful (3)
User profile for user: spraguga

Question: OS Recovery Chunk Validation Failed - Possible Fix!