Previous 1 2 Next 16 Replies Latest reply: Nov 30, 2015 1:46 PM by Zagreus waits
hatstis Level 1 (0 points)



I have a late 2012 27-inch iMac with the GeForce 680MX 2GB graphics card. I'm trying to install Windows 7 or Windows 8 using Boot Camp, but neither works.


In either case, I can use the Boot Camp Assistant to create a bootable USB install disk, download the latest Windows support software from Apple, and partition the drive to allocate space for the Windows installation.


As soon as I partition the drive, the iMac restarts and tries to boot into Windows. But the only thing I ever see is a black screen (no blinking cursor), no matter how long I wait.


This seems like the exact same issue that plagued the late-2009/mid-2010 iMacs,

In other words, it looks like the drivers included with the default Windows install disk don't work on the late 2012 iMac, at least not when configured with the 680MX. 


Since this looks like the old problem but Apple doesn't appear to have provided drivers for the new iMac yet (the older iMacs above used ATI graphics, not NVIDIA), I tried to add the latest NVIDIA notebook graphics card drivers to the Windows install disk using the directions here, tion

In particular, I used these drivers,

They're not explicitly supporting the 680MX (I couldn't find any drivers for it in NVIDIA's website) but they do support the 680M and a whole slew of other cards. Thought it was worth a try.


Anyway, that didn't do the trick. Still the black screen for me.


Any ideas? Have others had this issue with the new iMacs?



iMac, OS X Mountain Lion (10.8.2), iMac 27 late 2012 GeForce 680MX 2GB
  • storyway Level 1 (0 points)

    Switch the computer off and start again, holding the alt-key, than you may choose the boot partition. this worked for me.

  • hatstis Level 1 (0 points)

    Thanks storyway, I know how to do that, but that's not the issue here. Boot Camp Assistant properly reboots the computer using the Windows partition. The problem is that the Windows Installer is missing proper graphics drivers and hence all I get is a black screen. To get back to Mac OS X, I've had to hard reset and then hold down alt/option to choose the Mac OS X partition instead. But that still doesn't get me any closer to installing Windows...

  • Ratz1 Level 1 (10 points)

    I'm running into this same problem, got the 680MX 2GB, and a 1TB Fusion, I've been scouring the internet and can't find anything....

    Anyone found a solution yet?

  • BruinBecca Level 1 (5 points)

    I am having the same problem. 

  • BruinBecca Level 1 (5 points)

    And go figure - I called AppleCare and did the exact same process following the Bootcamp Assistant as it's supposed to work and now it worked fine. 

  • hatstis Level 1 (0 points)

    Interesting; did you include the second of three steps (1. create bootable windows USB stick, 2. download latest drivers and support software, and 3. create partition and install)? Or did they ask you to do anything else?


    Perhaps they've quietly updated the set of drivers that they send out. I'll try it too and report out whether it worked or not.

  • BruinBecca Level 1 (5 points)

    I have a new late 2012 iMac 21.5 with a fusion drive. What I did was to erase the partition that didn't work last night and start fresh. The representative did have me unplug the power cord in the back and plug it back in after 60 seconds now that I think of it. I then went through bootcamp assistant and created a partition and it installed fine.  I have a SuperDrive and copy of Win 7 64 bit DVD 1 pack. I'm still working on getting drivers to install so my mouse and whatnot will work. My Internet is out but if I can't figure it out I will be calling back. Hope this helps!

  • BruinBecca Level 1 (5 points)

    Okay. It was a success! For the drivers, following my install I used bootcamp assistant and burned a copy of the downloaded drivers onto a CD. I switch to windows and installed them from there.

  • Dremondo Level 1 (0 points)

    Any luck yet hatstis? I'm having the same problem... Can someone pleeeeas talk me through it like a baby monkey...?

  • hatstis Level 1 (0 points)

    OK, I figured it out.


    You know how the Boot Camp Assistant gives you three options? Create Windows Boot Disk, Download Latest Drivers, Install. You basically need to do all three at once, from scratch.


    I'm not sure exactly when in the last couple of months, but Apple updated their drivers. A few days ago I gave this another shot. Initially I tried using the USB stick I had previously created, but using some of the links at the first post above, I tried to inject the new NVidia drivers provided by Apple. That didn't help. I got the black screen and all that all over again.


    But then I just tried to start from scratch, remaking the USB stick while simultaneously downloading the drivers. It then also asked me if I wanted to install a new helper tool. I never got that prompt before. Either that tool solved it, or when it was creating the boot disk now it was injecting the new drivers itself in some different way.


    Whatever it was, try starting from scratch and going through all the steps and you might be successful in classic "it just works" Apple fashion. Took them a couple of months, but they got there.

  • stevec1234 Level 1 (0 points)

    I've made the USB drive following the bootcamp prompts, but when I reboot, I get a "no bootable device" error. I'm not sure if I should be booting from the windows partition that bootcamp creates or from the USB stick.


    The USB stick does not show it as a startup device disk in preference, nor as a boot option using the 'option' key at boot time (not suprising now I think about it, its a FAT32 volume).


    I've tried windows 7 and 8, same deal. I would like to remove the bootcamp partition and start again, but bootcamp does not seem able to remove the thing.


    I would love to get this thing working.

  • stevec1234 Level 1 (0 points)

    By the way, when you started over with the bootcamp install, how did you remove the bootcamp partition? I have tried to remove it with the bootcamp assistant (ticked the "Remove Windows 7 or later version" tick box), no go, just get a blue and white striped status bar. Tried in Disk Utility, no go.


    I have a fusion drive on a late 2012 27" iMac. Bootcamp is proving to be an absolute pain, can't seem to get anything to work.


    Any advice on removing the dud bootcamp partition welcome.

  • hatstis Level 1 (0 points)

    Hmm, Boot Camp Assistant did work for me exactly the way that you describe it (i.e., just check the box, without checking any of the other two boxes, and have it do it). It did manage that part correctly countless times as I tried this and that. Not sure how to fix that piece, you might have better luck starting a thread about that particular issue or looking it up online. Good luck!

  • stanuk42 Level 1 (0 points)

    Another twist on this issue installing Win 7 Pro 64 on a new Mac Mini. Having tried everything I could see on line and talking to Apple support for several hours and after using first a usb 3 stick (wrong) then a usb hard drive and finally bought a new usb 2 stick on which to copy the iso of windows I still got a dead black screen after partition created.

    Tried changing USB keyboard and mouse to no avail but finally solved by the unlikely course of swapping the video output  connector from a VGA adapter to a DVI one (same monitor). Reran process from the partition stage and suddenly everything worked correctly. No idea why, but it made all the difference.

Previous 1 2 Next