Previous 1 2 Next 26 Replies Latest reply: Dec 12, 2014 1:54 PM by ShawnGaff Go to original post
  • Zman1111 Level 1 Level 1 (0 points)

    Great advice paulymort! I have a high res ipad that air played photos and music but would not show to mirror. The language switch did the trick. Thanks!

  • pixelkitchen Level 1 Level 1 (0 points)

    Good get! This worked on my iPhone 4s while trying to connect to Reflector App. Airplay button was not displaying... Now it is. Thanks aellis1519

    https://www.reflectorapp.com/

  • Jessy0419 Level 1 Level 1 (5 points)

    Changing the language helped with the Apple TV box but not with iTunes.  Still, I'm happy!

  • jlm70 Level 1 Level 1 (0 points)

    Tried to reset router, access point, apple tv3 (with latest fw and airplay on), changed languages on iPhone5 and iPad 2... Nope. The Airplay icon vanished...

    Dear Apple customer care... whose stores sell more than Tiffany per square meter... could you please say anything to help your valued clients and FIX this problem?

    Thanks.

  • minardi Level 1 Level 1 (0 points)

    I would seriously check your router, not the Mac or the Apple TV.

  • zaklee Level 1 Level 1 (0 points)

    My problem is slightly different.

     

    In my case AirPlay is working fine to stream from QuickTime Player and Beamer to my ATV3. Well, it works fine until all of a sudden it doesn't. Inevitably the stream is interrupted, the ATV goes back to the main screen and the AirPlay icon disappers from my menu bar. When it happens using Beamer there is also a message saying that no AppleTV is found.

     

    Each time, restarting the ATV restores function. No computer, router or even software restart/reboot is required.

  • Philip Lundberg Level 1 Level 1 (0 points)

    Worked for me as well. 

  • draichart Level 1 Level 1 (0 points)

    I am having similar issues.  I have apple tv (3rd generation), ipad 2, iphone 4s, macbook pro and imac mid 2011.  All have worked (today and before) with airplay mirroring, no issues.  I had yet to use my imac for airplay mirroring as I normally use my macbook pro.  Well was going to show some iphotos on the TV, but there was no appletv icon.  Nothing in system preferences.  I rebooted everything, turned options off/on on apple tv, etc.  Still no luck.  iTunes still sends music to AppleTV, but I can not get my appletv icon back onto my imac!  Very frustrating, all other devices work fine with it!  I use an airport time capsule as my modem, I even called apple customer care, they even waved the $20 fee, which is good, because they were just as clueless!

     

    Any ideas?

    thanks

  • pixelkitchen Level 1 Level 1 (0 points)

    I have the airplay button displaying but I'm now missing the "mirroring" switch. Reflector and AirPlay = wasted time.

  • pzbrit Level 1 Level 1 (0 points)

    I had same problem. I then remembered that I set up a guest network (in addition to my primary, secure, invisible network) on my newly purchased Time Capsule. After checking my iPhone and my Apple TV I discovered that they were on different networks. I then switched my iPhone to over to the guest network (thus matching my Apple TV) and BINGO, problem solved.

  • Dylan82Breda Level 1 Level 1 (0 points)

    I have a different solution that might work.

     

    I was unable to mirror my macbook to the apple tv after a timemachine restore, while other devices (iphone, other macs) still were able to mirror their displays. My Airplay icon had simply vanished. Tried resetting router, different ipaddresses, the works but nothing worked. Not even the 1st line apple helpdesk could help me (rebooting computer and clearing caches and stuff).

     

    I have not tried the language trick but my strange solution worked. This seems strange but I downloaded AirServer (trial is free) which turns your own macbook into a Airplay receiver. Suddenly my Airplay icon in the menu bar appeared. I could now mirror to my own Macbook (ricidulous I know) which I did. But then the magic happened: when I got to work today where the Apple TV is, my Airplay icon was showing in the menu bar and I could succesfully mirror again. Really strange but hey, it works

  • ShawnGaff Level 1 Level 1 (0 points)

    Go to System Pref-> Display and at the bottom there is a check box that says "Show mirroring options in the menu bar when available" make sure this is checked.

     

    Also on your apple TV go to settings -> airplay and make sure there aren't any restrictions that have been changed. These could cause errors.

Previous 1 2 Next