13 Replies Latest reply: Feb 7, 2013 6:56 PM by blackpointtk
Andrew N Level 1 Level 1 (80 points)

OK so this is a weird one.  I have had problems with my set-up ever since I upgraded my cable modem and picked a faster time warner service.

 

Normal set-up:

Time warner cable 30Mbps internet connection

Motorola SurfBoard SB6141

Time capsule 3rd generation (connected to cable modem via WAN port)

MacBook pro (connected via ethernet)

 

The internet connection is intermittent and painful.  www.speedtest.net gives around 2-3 MBps at best, and fails often.

 

To test I replaced the time capsule with an airport express (802.11n-version) and connected via wi-fi.  A full 30Mbps connection.

 

Is my time capsule on the blink?  Or could there be some sort of incompatibility between the Motorola Surfboard and the Time Capsule?

 

Any advice gratefully received.  I can't figure it out.


MacBook Pro 17", Mac OS X (10.6.1), 2.93Ghz Intel Core 2 Duo with 512Gb SSD Drive
  • LaPastenague Level 8 Level 8 (43,175 points)

    This issue crops up from time to time.. with no clearly defined issue.

     

    Can you try wireless to the TC.. you say that it is via ethernet now?

     

    I had a Gen3 which had a hardware problem which got progressively worse.. but it isn't a problem I have actually seen again.. most of the rest have been dead.

    I wrote it up here.

     

    https://sites.google.com/site/lapastenague/a-deconstruction-of-routers-and-modem s/apple-time-capsule-repair/new-issue-with-a1355-gen-3-tc

     

    Yours would be the bad and unreliable.

     

    Give it a test.. I want you to put the TC in a special mode.. we call wan bypass.

     

    Instead of bridging.. leave the TC in router mode. But turn off DHCP.

     

    Now plug the cable modem into a lan port, not wan.. and with the computer connected to another LAN port.. or test with wireless as well.. To get this working you probably need to reboot the cable modem to drop connection to the TC and pick up the computer.. you can only attach a single computer and it will pick up the public IP.. then test the speed.

     

    You can also factory reset the TC and I would take the firmware back to 7.5.2 .. the later 7.6.1 is doing you no good at all.

     

    In the end.. I think you might need to replace the TC.

  • Andrew N Level 1 Level 1 (80 points)

    Thanks for the advice.  I haven't tried your test yet, but what I did do was borrow a friend's brand new 4th Generation Time Capsule.  It worked great at first.

     

    What I have noticed is that when I first switch on the cable modem and TC, everything is blazingly fast.  However, after a few hours things get slower and slower.  Right now I am getting speeds of around 3Mbps over wifi (having been 30Mbps at first use).

     

    There are about 7 devices sharing the connection (iphones etc.)

     

    Tough one to pin down as it isn't an immediate effect.  I have tried 2 different brand new models of motorola surfboard cable modems, but the issue continued.

     

    Driving me crazy.

  • LaPastenague Level 8 Level 8 (43,175 points)

    The simple solution is to replace the apple router with another brand..perhaps you can borrow one.. use the TC in bridge still for wireless. That slowing down effect can be due to a long list of issues.. and nutting out what it is .. could be impossible with the amount of info Apple lets us get into on the TC.

     

    I would do the basics..

     

    Reset to factory and start over.

     

    Give everything SMB name.. TC itself, wireless, different name for 5ghz and hard disk.

    Short, no spaces.. pure alphanumeric.

     

    Lock the wireless channel used.

    Use only WPA2 Personal security with 8-12 character password unless you are paranoid. Pure alphanumeric.

     

    And track the wireless info in the log.. you must use v5 utility to do this... apple decided no log info for v6.

     

    logwirelessclient.png

     

    Watch what is using wireless, as all kinds of things can be happening and using bandwidth without telling you.. eg system updates.

    Wireless is shared medium and you should track everything to find what is using it.

     

    A netgear WNDR3800 running gargoyle is my solution to most.

  • Andrew N Level 1 Level 1 (80 points)

    Wow - what a helpful response.  Thank you.  So I have been playing around with things over the last week trying to pin down my problem.  Right now I have a brand new airport express with default settings plugged into the surfboard and one computer connected to it via 5Ghz wifi.  Same problems happening: works fine for a bit then everything gets choked up, generally after a lot of network traffic is happening.

     

    Here's a ping to 8.8.8.8 during a period of it choking up:

     

    PING 8.8.8.8 (8.8.8.8): 56 data bytes

    Request timeout for icmp_seq 0

    Request timeout for icmp_seq 1

    Request timeout for icmp_seq 2

    Request timeout for icmp_seq 3

    64 bytes from 8.8.8.8: icmp_seq=3 ttl=46 time=1853.703 ms

    64 bytes from 8.8.8.8: icmp_seq=0 ttl=46 time=4857.091 ms

    64 bytes from 8.8.8.8: icmp_seq=2 ttl=46 time=2854.908 ms

    64 bytes from 8.8.8.8: icmp_seq=1 ttl=46 time=3856.024 ms

    64 bytes from 8.8.8.8: icmp_seq=4 ttl=46 time=855.117 ms

    64 bytes from 8.8.8.8: icmp_seq=5 ttl=46 time=951.458 ms

    64 bytes from 8.8.8.8: icmp_seq=7 ttl=46 time=262.873 ms

    64 bytes from 8.8.8.8: icmp_seq=6 ttl=46 time=1263.906 ms

     

    Here's a traceroute:

     

    traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 72 byte packets

    1  192.168.0.1 (192.168.0.1)  1.087 ms  1.091 ms  1.385 ms

    2  * * *

    3  * * tge7-2.austtxk-er01.texas.rr.com (66.68.1.245)  3102.914 ms

    4  tge0-11-0-8.austtxa-cr01.texas.rr.com (24.27.13.82)  18.002 ms  25.482 ms  22.500 ms

    5  agg22.dllatxl3-cr01.texas.rr.com (24.175.41.46)  19.696 ms  23.425 ms  15.812 ms

    6  ae-4-0.cr0.dfw10.tbone.rr.com (66.109.6.88)  20.850 ms  23.006 ms  24.075 ms

    7  107.14.17.234 (107.14.17.234)  16.404 ms  16.377 ms  15.339 ms

    8  74.125.48.65 (74.125.48.65)  62.360 ms  90.147 ms  63.274 ms

    9  72.14.233.67 (72.14.233.67)  15.814 ms  19.638 ms  16.354 ms

    10  72.14.237.217 (72.14.237.217)  17.516 ms  17.329 ms  18.501 ms

    11  216.239.47.121 (216.239.47.121)  24.035 ms  34.666 ms  24.192 ms

    12  216.239.46.61 (216.239.46.61)  23.184 ms  32.404 ms  30.130 ms

    13  * * *

    14  * google-public-dns-a.google.com (8.8.8.8)  24.035 ms  26.205 ms

     

    It can only be something up with my ISP, however calling them doesn't help.  They inevitibly tell me to connect without the AE, and after a reset everything works fine (for a while). Sigh.

     

    Something to do with my new DOSCIS 3.0 modem and associated 30Mbps connection?

  • LaPastenague Level 8 Level 8 (43,175 points)

    Thanks for the traceroute..

     

    From the IP the Motorola surfboard is a full router? Is that correct? My bad in not picking that up but our local cable companies have switched over to netgear cable modems.. so the last Motorola we got here is 5101.

     

    Your pings are shocking.

     

    The express is not showing up so I presume you have it bridged.

     

    What happens when you run ethernet direct to the modem?

     

    Can you turn off NAT in the modem and put the TC in place.. so you remove the routing part of the surfboard.

     

    But even the traceroute, which is always difficult to use as a completely true picture..

     

     

    3  * * tge7-2.austtxk-er01.texas.rr.com (66.68.1.245)  3102.914 ms

     

    That is woeful. No wonder it is slow.

     

    I would definitely try another router.. non-apple.. as we are finding some of the more modern connection stuff working badly with the apple.. with no clear idea of why. I am just not sure in yrou case where the problem is.

  • Andrew N Level 1 Level 1 (80 points)

    No the surfboard isn't a router, although I believe it has some sort of DHCP mode when not connected to the internet:

     

    "The SURFboard cable modem can be used as a gateway to the Internet by a maximum of 32 users on a Local Area Network (LAN). When the Cable Modem is disconnected from the Internet, users on the LAN can be dynamically assigned IP Addresses by the Cable Modem DHCP Server".


    It's all automatic, without any settings.

     

    I have been using the airport express in DHCP/NAT mode.

     

    Right now it is working fine.  Here's the traceroute:

     

    traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 72 byte packets

    1  10.0.1.1 (10.0.1.1)  4.292 ms  0.733 ms  0.847 ms

    2  * * *

    3  tge7-2.austtxk-er01.texas.rr.com (66.68.1.245)  12.041 ms  6.793 ms  9.368 ms

    4  tge0-11-0-9.austtxa-cr01.texas.rr.com (24.175.41.74)  18.120 ms  17.248 ms  24.046 ms

    5  agg22.dllatxl3-cr01.texas.rr.com (24.175.41.46)  19.936 ms  16.180 ms  15.790 ms

    6  107.14.17.136 (107.14.17.136)  17.937 ms  18.153 ms  15.559 ms

    7  107.14.17.232 (107.14.17.232)  16.031 ms  15.910 ms  18.045 ms

    8  74.125.48.65 (74.125.48.65)  17.281 ms  19.066 ms  18.320 ms

    9  72.14.233.67 (72.14.233.67)  17.164 ms  16.549 ms  18.625 ms

    10  72.14.237.217 (72.14.237.217)  17.322 ms  17.283 ms

        72.14.237.221 (72.14.237.221)  17.805 ms

    11  209.85.243.178 (209.85.243.178)  22.379 ms

        216.239.47.121 (216.239.47.121)  29.743 ms  34.995 ms

    12  216.239.46.39 (216.239.46.39)  31.078 ms  22.745 ms

        216.239.46.59 (216.239.46.59)  23.206 ms

    13  * * *

    14  google-public-dns-a.google.com (8.8.8.8)  27.002 ms  25.224 ms  29.123 ms

     

    I think the problem actually lies in the Motorola Surfboard.  I have tried 2 of them, but I think it is time for another brand.

  • LaPastenague Level 8 Level 8 (43,175 points)

    Ok, that looks more like default settings.

    1  10.0.1.1 (10.0.1.1)  4.292 ms  0.733 ms  0.847 ms

     

    I could not understand how you were getting

    1  192.168.0.1 (192.168.0.1)  1.087 ms  1.091 ms  1.385 ms

     

    I would recommend you stick to the apple default IP.. just because we have seen issues when people try to use something off default.

  • blackpointtk Level 1 Level 1 (0 points)

    Hi there. I am having the exact same problem as you. I'm on my 2nd Motorola SB6141, both have behaved the same. Have tried with my 4th gen Time Capsule, 2nd gen Airport Extreme (N), and have now just purchased a brand new Airport Express. My speeds are great sometimes, and painfully slow others. If I have Airport Utility open (v6) it actually appears my connection to the internet is dropping and then reconnecting temporarily, back to dropping, etc.

     

    I've connected the cable modem direct to my MacBook Pro using ethernet and the speed was constant. I could only leave it configured this way for maybe three hours, so not a long enough time to see if it slowed eventually, but using the time capsule (or airport extreme) sometimes the speed goes from 20Mbps that I pay for to 0.1Mbps via speedtest.net in a matter of minutes.

     

    Some things I think could either cause or exacerbate the problem are new wireless clients trying to connect- say I come home and turn on my Roku XS or my iPad, my connection instantly slows to basically nothing. Another strange thing is I had initially connected the Surfboard to the WAN port of my time capsule, and then an ethernet cable from the LAN port of the Time Capsule to the WAN port of my Airport Extreme to extend my network via ethernet (roaming network I believe it's called)- this worked initially then seemed like it was bringing my network down when I would attempt to reconnect it this way.

     

    Any help would be greatly appreciated. Thank you.

  • LaPastenague Level 8 Level 8 (43,175 points)

    Have tried with my 4th gen Time Capsule, 2nd gen Airport Extreme (N), and have now just purchased a brand new Airport Express. My speeds are great sometimes, and painfully slow others.

    I think you need to try with a non-apple router.. it does make it difficult as the apple stuf all uses fundamentally the same firmware.. if there is a bug somewhere.. then it spreads across all the products. Although you could try your 2nd generation Extreme on earlier firmware.. 7.5.2 .. if the extreme matches the TC.. or even one 7.5.1 just as a way of testing.

     

    There is so little access to the firmware in the apple routers to see what is really going on.. check NAT tables, check arp tables etc which you can do on a normal router are blocked from you. Beg or borrow or buy on 7day return a standard netgear, linksys etc brand router and see if the same thing happens..

  • Andrew N Level 1 Level 1 (80 points)

    Well after a lot of troubleshooting, I have concluded that my airport network is perfectly fine.  When connecting directly to the modem via an ethernet cable I also get the same slowdowns happening.

     

    I have had two visits from an engineer who tightened up some of the cable connectors and looked at the amplifier outside the house, but couldn't find anything specifically wrong.  Our only conclusions about cause were:

    1) The modem's firmware needs updating (which can only be done by the cable company - and they don't)

    2) This motorola DOCSIS 3.0 modem is just too sensitive to certain noise in the cable and to try a differnet modem.  He suggested a UBEE model instead if I could find it.

     

    Airport is not at fault.

  • blackpointtk Level 1 Level 1 (0 points)

    Hi guys- thanks for the info and responses. I believe I too have isolated this to the cable co. I've now been able to get the problem to happen via Ethernet as well. Ran a trace route and the figures were terribly slow. I have a case number now and am waiting for a tech to come by in two days. My theory is that the docsis 3.0 modems are more sensitive then the 2.0 ones. With the 2.0 modems I had no problems at all, but with two different Motorola SB6141 modems the problems have been bad. I hope they can come make the signal I'm getting from the cable co better. The line coming from the pole to my house is brand new, so I'm thinking its more upstream. I'll keep you posted on any new findings/progress.

  • Andrew N Level 1 Level 1 (80 points)

    Yup looks like you are having exactly the same problems. I have tried 2 motorola modems - the 6121 and 6141 - both exactly the same.  No problem with my old 20Mbs service with an ancient modem.

     

    Here's a periodic bad traceroute:

     

    traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 72 byte packets

    1  192.168.0.1 (192.168.0.1)  1.130 ms  1.050 ms  1.658 ms

    2  * * *

    3  * * tge7-2.austtxk-er01.texas.rr.com (66.68.1.245)  1557.654 ms

    tge0-11-0-8.austtxa-cr01.texas.rr.com (24.27.13.82)  34.598 ms  31.670 ms  31.961 ms

    agg22.dllatxl3-cr01.texas.rr.com (24.175.41.46)  35.675 ms  25.261 ms  23.819 ms

    ae-8-0.cr0.dfw10.tbone.rr.com (66.109.6.52)  25.715 ms  27.750 ms  31.928 ms

    7  107.14.17.232 (107.14.17.232)  52.037 ms  26.829 ms  36.122 ms

    8  74.125.48.65 (74.125.48.65)  31.267 ms  43.023 ms  29.232 ms

    9  72.14.233.65 (72.14.233.65)  24.227 ms  24.834 ms  15.554 ms

    10  72.14.237.215 (72.14.237.215)  24.212 ms  50.957 ms  45.335 ms

    11  216.239.47.121 (216.239.47.121)  83.322 ms  39.615 ms  35.804 ms

    12  216.239.46.39 (216.239.46.39)  38.296 ms  43.530 ms

        216.239.46.59 (216.239.46.59)  48.822 ms

    13  * * *

    14  * google-public-dns-a.google.com (8.8.8.8)  4938.330 ms  43.667 ms

     

    You can see the huge delay in line 3.

     

    I *think* things are a little better since my engineer visit - seems like simple things like bad co-ax connections can wreak havoc on an already sensitve line.

     

    He saw a few things:

    - Repeated frequency switching on the modem

    - A noisy line at the amplifier in the street after a long cable run - which of course aplifies this noise.

     

    His comment basically was that DOCSIS 3.0 was a new beast and they are still ironing out problems.  If it still happens I will investigate a different brand of modem.

  • blackpointtk Level 1 Level 1 (0 points)

    Engineer finally came out to my house. It was annoying to have to fill him in on my story for the millionth time when I already had a case number with my bad trace route numbers in it, but anyway... He went up on the pole, moved my line to a different port because he said my port had some oxidation on it. He then said he was calling in some other engineers to come back and replace the entire junction box on my pole. He also said the signal level was too low at my junction box and those guys would turn up/amplify the signal somewhere further upstream. I have not been able to confirm whether those final two things took place, but I have not noticed any slowdowns since that engineer left my house. It's a bummer that I returned the Motorola SB6141 I bought on Amazon, but I'll take paying TWC $4/month over this frustrating experience of basically having no internet any day.