7 Replies Latest reply: Dec 16, 2014 3:58 PM by Michael2255
TNTajB Level 1 Level 1 (0 points)

My iphone's default setting is "file sharing is off". How do I enable it?


iPhone 4, iOS 6.0.2
  • AstroRon Level 1 Level 1 (0 points)

    Same here - trying to file share an iPad - Says "File Sharing is off"

     

    Windows 8

  • Rudegar Level 7 Level 7 (21,935 points)

    ipads don't support sharing files with computers over the network

    with ipads you don't really have access to a filesystem so the concept don't make sense

  • AstroRon Level 1 Level 1 (0 points)

    I'm a little confused, How can iPad users transfer files to and from the device such as; AwesomeNote restore files, Keynote.

     

    Literally this site http://support.apple.com/kb/HT4094 has an image of an iPad connected to iTunes that shows how to share files with apps - this is the how to instructions and it has an iPad.

     

    I am able to access that screen and see the apps that will allow sharing, but there are no files and it says "File Sharing is off"

     

    Pro Tip: Any area of an application that notifies a user of Enabled/Disabled On/Off for a feature - please have a link to the setting to change it.

  • PudriK Level 1 Level 1 (0 points)

    File Sharing doesn't work over Wifi, so I ejected the iPad in iTunes (it was connected over WiFi), and connected it with a cable.  It worked, give it a shot.

  • mcovill Level 1 Level 1 (0 points)

    I was trying to add a Keynote presentation from my iMac and couldn't seem to get it on the iPad.  I "Add..."ed the presentation in the File Sharing section to the Keynote app and synced the iPad. It didn't show up in Keynote.  Like you - in iTunes - it also said File sharing is off.  After syncing the iPad several times (plugging and un-plugging the USB cable) the File Sharing finally stayed active - but the presentation still wasn't on the iPad.  I removed it from the list, then added it again.  Still, it didn't show up.

     

    Then I finally figured out that even though it is in the list of shared documents in iTunes for Keynote, you still have to go to the Keynote app on your iOS device and press the "+" button in the top left of the "Presentations" page and choose "Copy from iTunes" - it's not automatic like I had become used to with the way documents are automatically shared between devices through iCloud.

  • mrvalli Level 1 Level 1 (0 points)

    Great, this tip helped as it is a bit cryptic on many actions in iTunes (wondering why iTunes cannot be so specific on these points, esp. when there is so much screen space available so there can be some tips by the side when it says 'File Sharing off').

    So the work around, turn off Wi-Fi and disconnect and connect USB even if connected before, bingo the file sharing comes back.

  • Michael2255 Level 1 Level 1 (0 points)

    It's those little details that drive us crazy. I thought Mr. Jobs said we would not need a computer anymore?