Previous 1 2 Next 26 Replies Latest reply: Jan 21, 2013 1:41 PM by mica44 Go to original post
  • mica44 Level 1 Level 1 (0 points)

    Ah.

  • tomcat907 Level 1 Level 1 (0 points)

    Yes, the edited photos are there, the thumbnails are there, but some pictures are black and 0 kb unless you revert to original photo. It is frustrating because it does not happen on all edited photos, only some. As I said, I have had the problem on Sony, Nikon, and Fuji cameras and I am running 10.7.5. It also seems to happen when I have big libraries like after a trip where I have several hundred photos. I can't confirm that, but I don't seem to suffer the same problem if I edit one or two photos in a Library of less than 100.

     

    Another problem I am having with iphoto is that when I plug my iPhone in and the pictures are being imported, the thumnails just appear gray. The photos are there and they do upload, but you have to import all since you can't see the thumnails.

     

    I am just managing with my iPhoto at this point until I have time to do my homework on other software like Picasa or Lightroom. It is dissapointing thought since all of my devices are Apple products.

  • Old Toad Level 10 Level 10 (121,305 points)

    Export the original photos of some of those problem photos to the desktop. Launch iPhoto with the Option key held down and create a new, test library.  Import those photos and check to see if the same problem persists. If it doesn't then your current library is the culprit.  If it does there is one more test to run: log into another user account on you Mac and try editing those same orignial files there in iPhoto.

     

    This can tell us if the problem is local, your library or account or universal which might mean a reinstall of iPhoto or the system.  Post back with the results.

     

    OT

  • mica44 Level 1 Level 1 (0 points)

    The problem reoccurs with me in the test library.

     

    When I switch to another user and try to edit the photos, every editing option is grayed out. I have never seen this happen before!

     

    mica44

  • Old Toad Level 10 Level 10 (121,305 points)

    See if you can open those photos with Preview and then do a Save As and create a new jpeg file with a diffrerent file name.  Import them into iPhoto and try to edit.  If you can then it is a problem with those files from the camera and not iPhoto or the library.

  • tomcat907 Level 1 Level 1 (0 points)

    Here's what I did.

     

    1. Opened one of the photos in the iPhoto using Preview. It is fine.

    2. Go to iPhoto and edit the same photo.

    3. Go back to Preview and try to open the same photo. It gets an error that says the "The file “DSCN0712.JPG” could not be opened because it is empty."

    4. Go back into iPhoto, use "revert to original" on the photo. It reappears.

    5. Go back to Preview and open the reverted photo and it works fine.

     

    Something in the IPhoto edit program is messing up the JPEGs.

  • Old Toad Level 10 Level 10 (121,305 points)

    Were these the photos you exported to the Desktop. Those are the ones I wanted you to open with preview and do a Save As to create an entirely new file and then import into your library as new photos.

     

    If you used Preview as the external editor while in iPhoto that was not what we wanted to do for this test.

  • tomcat907 Level 1 Level 1 (0 points)

    Here is another clue.

     

    If I am in Edit Mode, where there is a thumbnail of all the photos in the library along the top, I can see the edited photo OK.

     

    If I am in the viewing mode where you just click on one of the photos then use the arrow keys to see the next photo, the same edited photo is black.

     

    Do you think this indicates that the IPhoto Edit program is putting info into the JPEG that it can read, but no other program can?

  • mica44 Level 1 Level 1 (0 points)

    I can open the photos in Preview.

     

    However, in the other user:

     

    Preview cannot access my entire Shared Library. I do see the Shared Library in iPhoto there though. Just can't see those photos in Preview.

     

    if I slide a new photo from my shared library to the desktop, rename and put back into the unshared portion of iPhoto, then I can open it in Preview.

     

    If I do the same into the shared library, then it won't even slide in from the desktop (into the shared)! It refuses to to do it.

     

    This has to be important in diagnosing this...

  • tomcat907 Level 1 Level 1 (0 points)

    I did the other test. Took a photo from the iPhoto libarary and put it on my desktop, changed the name, put it back in the library. Then I edited it. When I went to view it again it was black. I applied "Revert to Original" and it came back.

  • mica44 Level 1 Level 1 (0 points)

    I did the same test as above on my side (user=me).

     

    BUT MINE WASN'T BLACK! It worked after  exporting, changing name, importing, editing.

     

    The same photo did not perform when I simply duplicated the original and edited. (it turned black).

     

    I am surprised it worked. I sure don't want to have to export, change name, import first in order to edit.

  • mica44 Level 1 Level 1 (0 points)

    My work around has been to use iPhoto preferences to change the default editor to an app called Flare. So now when I click "edit", Flare automatically opens up for me to edit the photo and I click the "save to iPhoto" button when I'm done.

     

    Flare has seems to do all that iPhoto can do for editing except "straighten" a crooked photo.

     

    mica44

Previous 1 2 Next