Previous 1 2 3 4 Next 53 Replies Latest reply: Oct 26, 2015 4:57 PM by RLS7537 Go to original post
  • revdlee Level 1 (0 points)

    None of the suggestions on this thread worked for me, but this: http://royalwise.com/rw/troubleshooting-iphoto-emails/

  • janeem48 Level 1 (0 points)

    So glad I found your answer to probs with iPhoto. Been having repeated probs. Thanks a million

  • Bergscholtz Level 1 (0 points)

    I tried all the options above including deleting the Yahoo account from the System Preferences and nothing was successful. I have iPhoto 11 v9.4.3, running OS X V10.8.3 and am trying to use Yahoo . Any additional suggestions?

  • revdlee Level 1 (0 points)

    Bergscholtz, the solution from royalwise that I posted was for you to delete your mail account from within iPhoto not system preferences and it was specific for Apple's Mail app.

     

    But you can try it for Yahoo: In iPhoto go to iPhoto>Preferences>Accounts to delete your Yahoo account. Afterward, try opening a new account.

     

    If this doesn't work, others have found this to work for Yahoo: http://hintsforums.macworld.com/showthread.php?t=9387

  • Micah Donahue Level 1 (0 points)

    I just started having this problem w/ Yahoo Mail Plus (no ads, $19/yr) and FIXED it tonight. Here's how in case it helps others. I can't guarantee it'll work w/ a free Yahoo acct, but it may be the only way to fix a Plus acct so I thought I'd log the fix. 

     

    You do need to know your Yahoo pass, of course. Once you can log in and out of Yahoo mail w/ no problem, then go to Prefs > Accounts in iphoto and delete the Yahoo acct you were trying to use to send photos. You CAN'T edit it the way you need to. Click the + to add a new account, and pick email as the type (not facebook).

     

    Trick #1, in the next window DON'T choose Yahoo mail as the mail service for your account, choose OTHER. Then enter all your info as normal on the next window (the form). If iphoto doesn't fill in the server address automagically use iphoto.smtp.mail.yahoo.com.

     

    Trick #2, UNCHECK use SSL.

     

    This worked for me on both my and wife's Yahoo plus accounts. HTH.

  • Bergscholtz Level 1 (0 points)

    Micah, This worked for a free Yahoo account. Thanks!

  • Micah Donahue Level 1 (0 points)

    That's great. Thanks for letting us know so fast!

  • dsnows Level 1 (0 points)

    Micah, thank you. I had tried everything and this finally worked. I think the trick #1 is the key, setting up the email account as "other" rather than yahoo. Trick #2 didn't seem to matter for me. Works whether SSL is checked or not. 

  • Tigervision Level 1 (10 points)

    Micah... you the man.  Thanks.  My unpaid Yahoo account works now.

     

    Here is something bizzar.  The Other trick worked for my yahoo accounts with SSL checked.  But my icloud account stopped working!!!!  It stopped working before I added my yahoo account with the Other trick.  I tried deleting it and re-adding it... no go.

     

    So in a change of reversal, my yahoo works and icloud doesn't.  WTH apple?

  • AeroKT Level 1 (0 points)

    I'm getting a better response using this approach but still no luck. My iPhoto emails have been working fine up until just recently. I originally got the same error of "The email server didn't recognize your username/password combination...etc" My error message now while trying to send a picture via email using iPhoto is: "Your email did not go through because the server did not reply. Check your Internet connection. If the connection is working properly, the email server may be down. Try sending your email again later"

    My wireless is working fine.

    Under iPhoto>Preferences>I click my email account.

    Account Type is: Other

    Outgoing Mail Server is: smtp.mail.yahoo.com (I tried this and iphoto.smtp.mail.yahoo.com and neither have worked)

    Port: 465 (should I try a different one?)

    User Name: firstname.lastname (no @yahoo.com right?)

    Unchecked SSL

     

    I am using: iPhoto '11 Version 9.2.1 and Mac OS X Version 10.7.5

     

    Any help would be appreciated!

    Thanks all!

  • Micah Donahue Level 1 (0 points)

    FWIW, I'm on:

    ---------------

    a paid yahoo plus account

    iphoto.smtp.mail.yahoo.com server

    port 25 (I didn't choose this, it used 25 automatically for me)

     

    Just confirmed working for me, so maybe it is your port?

  • misshell2 Level 1 (0 points)

    I've got the same problem! All of a sudden I can't send pictures!

  • buieville Level 1 (0 points)

    Karen,

     

    Saw your post re. IPhoto problem with not recognizing email server username/ password .... also my problem; your advice worked like a charm. 

     

    Thanks for your expert advice.

     

    Bob

  • tunesmith82 Level 1 (0 points)

    The easiest solution for me was just to go to iPhoto->Preferences: General and set "email photos using" to "Mail" instead of "iPhoto". You can still resize photos, but you get your standard Mail settings that will work.

  • k-hawk Level 1 (0 points)

    i finally got this working after having this darn apple for 1 year!  thank you micah and tunesmith.

    i ended up removing my acct and recreating like micah said.  but then went into general tab and set to MAIL instead of Iphoto and it works.....omg.  what a beating apple!  thank you all for helping