Previous 1 2 Next 27 Replies Latest reply: Jan 22, 2013 3:23 PM by etresoft
armondfromglendale Level 1 Level 1

Hi everyone,

 

My apologies if I am posting this in the wrong forum/section.

 

I am developing a C++ Cocoa app using the latest version of XCode on my MACOS which is running Mountain Lion. It is a fairly simple C++ app but upon copying the executable to another machine, it states that it will not run due to the version of MACOS being different. Apparently my wife has 10.7.5 and I have version > 10.8 so I'm confused how I can make my simple C++ app written in Cocoa work on other macs. Any advice would be greatly appreciated.

 

Thank you

Solved by Dave29483 on Jan 22, 2013 1:41 PM Solved

Glad I could be of help.

 

Happy coding!

 

<Edited by Host>

  • etresoft Level 7 Level 7

    Set your Deployment OS to 10.7.

  • armondfromglendale Level 1 Level 1

    I did that and upon moving it to the 2nd MAC, it still informs me the OS is not compatible. I am really confused at this point. Any other points you can offer?

  • Frank Caggiano Level 7 Level 7

    Locate the app in the Finder and do a Show Package Contents. Look in the info.plist near the bottom is minimum system  version required key, what does it say?

     

    If it still shows 10.8 and you're sure you changed the deployment to 10.7 try doing a clean before building again.

     

    Also how are you copying the app over to the other Mac?

  • armondfromglendale Level 1 Level 1

    Mac # 1

    ------------

    OS Ver: 10.8.2

    XCode Ver: 4.5.2

     

     

    Mac # 2

    ------------

    OS Ver: 10.7.5

     

     

    1. On MAC # 1: In the XCode app, I right click on PRODUCTS folder and choose SHOW IN FINDER. I then grab the APP file and drag it to a brand new folder called "TEMP" on the desktop

     

    2. I open up Disk Utility

     

    3. Click on FILE -> NEW -> DISK IMAGE FROM FOLDER

     

    4. I choose the the TEMP folder

     

    5. It successfully creates the DMG file

     

    6. I then right click the DMG file and press the COMPRESS option which zips it up

     

    7. I then use a file sharing service (yousendit.com, sendspace.com, etc.) to submit the file

     

    8. MAC # 2: I get the app, decompress it. I then double click the DMG file which opens the Disk Image

     

    9. Upon double clicking on it, it states that there are compatibility issues and that the program is not able to run. I get two options 1) Ignore  2) Report.

  • armondfromglendale Level 1 Level 1

    I checked the INFO.PLIST file you mentioned within the "SHOW PACKAGE CONTENTS" option and the minimum version is blank.

  • Frank Caggiano Level 7 Level 7

    Did you try doing a clean and then a build?

     

    Also you're doing a build for running, correct?

  • armondfromglendale Level 1 Level 1

    Yes I did the clean and then build but I think that "may" be where my problem lies. I did simply a "run" but not the "build for running" option. Let me try that real quick.

     

    What should I put in the Minimum System Version field? It is currently blank.

  • armondfromglendale Level 1 Level 1

    I just tried again with now the minimum version having a value of 10.7 and got the following:

     

     

     

    TEST APP cannot be opened because of a problem


    Check with the developer to make sure TEST APP works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.


    Click Report to see more detailed information and send a report to Apple.


    IGNORE     REPORT...

  • Frank Caggiano Level 7 Level 7

    You got that last message on your system or the system you sent the app to?

     

    I'm really at a loss here, never experienced the problems you are seeing. Perhaps this has something to do with the fact you're writing in c++, I've never used Xcode to code in c++.

     

    Hopefully someone else here will chime in with some ideas.

  • Dave29483 Level 1 Level 1

    Hi,

     

    Had this myself when testing a C++ based game I am developing on a friends iMac.

     

    He's running 10.7, I'm running 10.8.2

     

    In the end I simply changed the "OS X Deployment Target" to 10.7 and all was well.

     

    Changing the "Base SDK" doesn't make a difference.

     

    You need to change this on the settings for the Target under "Targets" rather than "Project"

     

    Hope this helps...

  • armondfromglendale Level 1 Level 1

    In fact that is what I'm doing. I am testing a C++ SDL based game app. The OS X Deployment Target is set to 10.7 but I am still getting that error.

     

    Wow I never imagined developing apps on MAC and getting them deployed to other MAC's would be such a nightmare!

     

    If anyone else has any suggestions, I am willing to try.

  • Dave29483 Level 1 Level 1

    Does it have any dependency libs which need their Targets setting as 10.7 also?

  • armondfromglendale Level 1 Level 1

    The libraries I am using are the latest versions of:

     

    - SDL Mixer

    - SDL Image

    - SDL Font

     

    I was able to successfully add them to the project, add their include/headers paths but as far as it having any specific dependencies which target their setting as 10.7, I'm not sure. How would I know?

  • Dave29483 Level 1 Level 1

    Ah,

     

    In that case you may find it can't find the SDL libs on Mac #2

     

    On Mac #2 right-click the app you sent over then Show Package Contents - > Contents -> Mac OS then run the binary directly. This will give you the terminal window and should give you some output as to what it is looking for.

Previous 1 2 Next