1 Reply Latest reply: Jan 11, 2013 8:15 PM by LordAcoustic
LordAcoustic Level 1 Level 1 (0 points)

Good Evening Apple Spport Community,

 

I've been having an issue with Spotlight recently. Basically, it was/is not indexing correctly/at all.

 

My current situation: Spotlight does not display search results for anything but definitions. No Applications. No Folders. No Files. Nothing.  I've attempted several things to remedy this issue.

 

For instance, I've tried adding and removing my HD from the Spotlight preferences under System Preferences. I receive the Privacy List Error: The item couldn't be added or removed because you don't have the appropriate permissions.

 

So I read more around the interweb/community and find several suggested sudo commands that may help. I've tried:

 

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

 

sudo mdutil -a -i off

sudo mdutil -a -i on

 

These do not seem to work.

 

A possibly unrelated issues is that my TimeMachine (using an external drive) has spot backing up. It'll just sit there with the "preparing backup" message and never go anywhere beyond that.

 

I've tried my luck trying to interpret a lot of the more technical vernacular on my own, but to no avail of my issue. Thus, I am trying a more direct approach. Any assistance you could provide in this matter would be greatly appreciated.

 

Cheers.


iMac, OS X Mountain Lion