Previous 1 2 Next 15 Replies Latest reply: Jan 20, 2013 5:36 AM by Jimbanzee
Jimbanzee Level 1 (0 points)

Hi

 

My partner has recently bought a second-hand (but fully functional) Macbook Pro running OS X 10.5.8 to set up in our home office.

Our wireless router is not in the same room (it's in the living room via the hallway) but no other computer or device in the house has any problems detecting and connecting to the router.

 

My partner's pc netbook and my iPhone 4S connect fine all through the flat. My iMac (located in the office) also has no problems.

 

We have managed to get the Pro connected to the internet wirelessly a couple of times in the living room (although not all the time) but as soon as it is moved into the office the connection cannot be found or successfully connected to.

 

Can't help but think that there's some little setting or something that we've not done that is causing the problem - seems odd that all the other devices connecting have never had any issues! I'm not completely technically minded, but have had enough experience with computers to feel fairly confident on them - just wondered if anyone might be able to suggest anything?

 

The Network Preferences pages don't seem to be any help to me - I've tried several things in there that would usually help to rectify a troublesome connection.

 

Any help or advice would be so much appreciated - my partner bought this Macbook Pro to replace her netbook and a reliable online connection is paramount as she is designing websites etc. with it!

 

Thanks,

Jimbanzee


MacBook Pro, Mac OS X (10.5.8)
  • courtcrow Level 1 (0 points)

    Im having this problem too... its very frustrating!!

    but I just went to system preferences and searched proxies... and added "auto proxy discovery" its working now, but i looked up what proxies is and I am still wondering if it is safe to be on them... hopefully someone is answering my question and ill let you know! but try that for now! it worked for me!!!

  • JohnTh Level 2 (365 points)

    And are you connecting directly to the wireless router?

  • Jimbanzee Level 1 (0 points)

    Hi Courtcrow

     

    I'm sorry to hear that you're also having trouble - thanks for the advice about the proxies - I too do not really understand what they are, but I will give your suggestion a go (although it'll have to be tomorrow as there's some very important web based work going on right now (we decided that we needed access so bought a really long ethernet cable to connect directly from the other room)).

     

    Jimbanzee

  • Jimbanzee Level 1 (0 points)

    Hi John

     

    Thanks for your reply also...

     

    We are trying to connect the Macbook Pro to the wireless router wirelessly, and having trouble with that.

    We have just bought a really long ethernet cable in order to be able to work in the other room as a temporary measure, but would like to get the wireless connection sorted!

     

    Jimbanzee

  • JohnTh Level 2 (365 points)

    Do this with your router. Connect your MBP to the router's IP address via Ethernet cable. You can get this from the router's manual (check also for the initial username and password to access the site). Go to the wireless setup from here, and change the name to something that you can recognise. Make sure that it is password protected. Save it so that it'll write itself to its flash memory (your network will briefly not work). Once this is done, open network preferences on your MBP and search for this NEW network using WiFi (not your Ethernet connection). Remember that all this while you are still connected to the Ethernet, though you are NOW selecting WiFi as a method to connect to the Internet. Select it and lock it. Disconnect the Ethernet cable, shut down / or put it to sleep, then restart and see if it works.

  • Jimbanzee Level 1 (0 points)

    Hi John

     

    That sounds positive - I'll give that a go as soon as I can - not able to try it out at the moment but will definitely let you know how it goes!!

     

    Jimbanzee

  • JohnTh Level 2 (365 points)

    Ok ... hope it works! Btw, is there any particular reason you're on 10.5.8?

  • Russa Level 4 (1,315 points)

    Suggest you go into Systems Preferences/Network and delete "-" the wifi service then recreate "+" it on that Mac. Also auggest if you are using WEP security to change it to WPA2.

  • ralemany43 Level 1 (0 points)

    I have a similar problem.  My macbook connects in one room  of my house.  It will not connect in any other room.  I sent it back to have it checked and it worked fine there so they sent it back to me.  Problem with my macbook or my network? All other devices work just fine.

    Thanks for any help!

  • JohnTh Level 2 (365 points)

    Have you tried what Russa has suggested above?

     

    If that still doesnt work, then try out what I had suggested to Jimbanzee above in this very post. And let us know how it went.

     

    I'm not very sure where the problem really originates from but there seems to be an issue with MB and MBPros connecting wirelessly to the router as a lot of people seem to have the same problem.

  • ralemany43 Level 1 (0 points)

    Yes I have tried the above suggestion(Russa) and we already use a WPA password. I will try the other suggestion and get back to you! Thanks:)

  • JohnTh Level 2 (365 points)

    Please switch to a WPA2 Personal, and for good measure make it a hidden network too.

  • Jimbanzee Level 1 (0 points)

    Hi JohnTh

     

    Thanks for your suggestion (and apologies that it's taken forever for me to try this out and get back to you)!

     

    I think I've done what you suggested but I think my lack of computer knowledge is letting me down as it did not work.

     

    I went to Network in System Preferences whilst connected to the internet via Ethernet cable, and managed to connect to my router, I then locked the changes, removed the cable and then restarted but straight away upon logging in, it had lost the changes and was unable to find the wireless connection.

     

    To be honest, it will not always find it when the ethernet cable is plugged in - in fact, I've witnessed it go from green light connection, having found the router and getting an ip address to amber without the ip address to not being able to locate the router (all whilst still plugged in on ethernet) within the space of about two minutes!

     

    I'm a bit hazy on the details of your suggestion when you say:

     

    Go to the wireless setup from here, and change the name to something that you can recognise. Make sure that it is password protected. Save it so that it'll write itself to its flash memory (your network will briefly not work).

     

    I went to the Network page of System Preferences straight away - is there somewhere else I should do the wireless setup? Our wireless connection is (as it is on my iMac which connects fine wirelessly) protected with a WPA2 Personal password.

     

    How do I save it so that the setup will write itself to it's flash memory? Sorry not sure where this is!

     

    I have also tried to remove the 'remembered' network from the advanced airport settings using the '-' button and then adding it '+' back in, but this also does not seem to work.

     

    We are planning on upgrading the operating system from 10.5.8 once we can get a secure connection - my partner is happy that she can connect to the internet via Ethernet cable but she is wanting to sell her PC netbook (in order to part fund the purchase of the Macbook Pro) and she's not happy to do so until she can connect wirelessly successfully!

     

    Finally, thanks for all your help and suggestions - really appreciate it and hope to find a solution!

     

    Jimbanzee

  • Jimbanzee Level 1 (0 points)

    Hi Courtcrow

     

    I tried your proxies suggestion but when I ticked to auto add proxies it was asking me for a PAC URL address, something I don't have (I don't think!)

     

    I'm glad it worked for you though!

    Jimbanzee

Previous 1 2 Next