8 Replies Latest reply: Feb 10, 2013 3:12 PM by alex149
alex149 Level 1 (0 points)

I have tried the reindexing stratergy to find all of the missing loops but I still get a message saying that they need to be downloaded and will be downloaded with software update, this has not happened and its starting to get on my nerves, btw im pretty good with computers (I can program) and I still cant seem to figure it out.

 

Additional info:

 

I have mountain lion and a macbook air and I downloaded garage band for free from the app store when I got my mac


MacBook Air, Mac OS X (10.7.1)
  • léonie Level 10 (91,054 points)

    One more thing to try: Sign into the AppStore with your AppleID, before you click onto the loops in GarageBand to force the download. When you are prompted to download now or later, select "Download later". Wait a bit, then look at the AppStore updates tab.

  • alex149 Level 1 (0 points)

    yeah i tried that one as well, ive even tried installing earlier versions of garageband, basically ive come to the conclusion that its mountain lions implementation of the updates and appstore, you know how theyre now merged rather than as seperate programs.

  • léonie Level 10 (91,054 points)

    Alex,

     

    have you tried everything in this thread? The problem seems to be different for everybody:

     

    If nothing helps try dagon's full monty for a reinstall:

    Re: GarageBand '11 won't download additional loops

     

    Or a manual download using the Terminal as mteep suggests:

    Re: GarageBand '11 won't download additional loops

     

    Léonie


  • alex149 Level 1 (0 points)

    yeah, ive tried everything now, i didnt get a cd so i cant use the first one, and the terminal one just seems to not be able to update it, im really stuck, maybe i should try reinstalling it then using the terminal method, its just that ive reinstalled it about 5 times already, its really starting to get on my nerves

  • delgleli Level 1 (0 points)

    I was having a problem like you and didnt want to delete gb. after everything, I remembered that I had moved the gb app into a different folder, when I moved the gb app back into the root of the application folder, and went to software update and did a command R it appeared!

     

    Good luck

  • alex149 Level 1 (0 points)

    cheers for the help, but this still hasnt helped, i think im just going to have to wait for an update to fix this

  • delgleli Level 1 (0 points)

    Let me list the exact steps I used, maybe something else is needed, just in case.

     

    1. delete the files under /library/audio/apple loops index/

    2. open garageband

    3. click on instrument that needs loading, click on option to download later

    4. exit garagaband

    5. under the apple, pick software update (it opens up the app store)

    6. when it says nothing to update, click on command-R

     

    this is when I saw the update show up, the command-R is apparently different than when it loads up and says its looking for updates...go figure, it almost feels like Im running something in windoze!! ha ha

     

    I think deleting that loop index file helps, I just checked and after my download worked that file reappared in that folder, perhaps its blocking you from actually downloading?

     

    good luck

  • alex149 Level 1 (0 points)

    no, its still being stubborn, do you think it baing a macbook air would make a difference?