2 Replies Latest reply: Jan 13, 2013 5:41 PM by steve359 Branched to a new discussion.
Cruzer54 Level 1 Level 1 (0 points)

This iMac is running 10.4.11 and I would like to update it. The packaging on my Snow Leopard disc from a more recently purchased MacBook says it does not support PowerPC chipset machines. Can't find much info about 10.5 and it is not offered on the Mac.com download pages I have seen so far.

Is it worth the bother and where can I find OSX that is out-of-date but newer than what I amrunning?