Previous 1 2 Next 15 Replies Latest reply: Feb 27, 2015 12:51 PM by iamsudo
Larry Sharp Level 1 Level 1

Safari will not prevent search engine from providing suggestions, even though that block is checked in Privacy preferences.


MacBook Air (13-INCH, MID 2011), OS X Mountain Lion (10.8.2), Safari 6.0.2
  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    You'll still be offered the results of locally searching your history and bookmarks.

  • Larry Sharp Level 1 Level 1

    I understand that, but I'm still getting two panels, one headed "Google Search" and the other "Search 'X' in History." It shouldn't be doing that.

     

    Thanks very much for responding, though.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    When you enter a search term in the smart bar, Google Search is one of the options, but there should be no suggested searches other than what you entered. Are there other suggestions? If there are, check that Prevent search enging from providing suggestions is still selected.

  • Larry Sharp Level 1 Level 1

    I've tried that several times. The problem remains, even though the options is still checked.

     

    Tried it on another up-to-date Mac and had the same result.

     

    Thanks for your continue interest.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    You wrote earlier:

     

    I'm still getting two panels, one headed "Google Search" and the other "Search 'X' in History." It shouldn't be doing that.

     

    That is, in fact, exactly what it should be doing. Please post a screenshot (shift-command-3) showing what you think is incorrect behavior.

  • WhatACompletePainInTheButt Level 1 Level 1

    The check box only controlls the search engine behaviour when typing search terms into the upper, location, "smart search" bar. If it is checked and you type into this bar, then no suggestions are provided.

     

    However, if you are on www.google.com and you type into the ACTUAL GOOGLE SEARCH BOX, then suggestions ARE provided no matter what the setting is.

     

    This behaviour has been present since the release of mountain lion at least.

     

    There is probably nothing Apple can do with the box on google's page.

    Apple appears to be doing the right thing with the upper, location, "smart search" bar.

  • guppiefish Level 1 Level 1

    I also seem to have having this problem, despite having checked the "prevent" option in Preferences. Typing words into the Safari search bar (NOT the Google search bar on one of Google's search pages) leads to suggestions being made:

     

    Screen Shot 2013-05-26 at 13.04.04.png

    as well as connections being made to lhr14s21-in-f7.1e100.net:Screen Shot 2013-05-26 at 13.04.23.png

    which http://66.161.36.140 suggests resolves to a Google IP address block.

     

    I'm using Safari Version 6.0.4 (8536.29.13) on Mac OS 10.8.3.

  • michaelbartholomew Level 1 Level 1

    I am suffering the same issue in Safari 6.1.1 on OS X 10.7.5. I have the appropriate option checked on the Privacy tab in Safari's preferences window and I am still receiving suggestions while typing. The only way to truely disable the search suggestions is if I use private browsing, which is not a full time option.

  • sancho_p Level 1 Level 1

    The checkbox works with my 7.0.1 Safari (Mavericks 10.9.1) as expected, if set, the section for “Google Search” will be filled by the typed characters only.

     

    However, the “preload Top Hit in the background” may send several requests while you are still “thinking” what to search for, you may disable that, too.

  • guppiefish Level 1 Level 1

    Thanks Sancho. I've always had the "do not preload top hit" option set. I'm still having this issue with the latest Safari/Mavericks.

  • TML100 Level 1 Level 1

    Hi Linc...

     

    I have Mac Pro Tower with which the attached monitor is randomly going to sleep, so I have to press the power button for 10 secs to turn it off and restart to bring it back.  I have reset the SMC per one of them without any effect. 

     

    I have noticed you comment on this issue in other posts.   

     

    How do I start a new question on this topic to interact with you

     

    Tim

  • Tapple_t Level 1 Level 1

    This is still a problem for me in Safari 7.0.5. In the normal browsing mode, despite having "Prevent search engine from providing suggestions" ticked, search suggestions are still listed in the address bar under the heading 'Google Search'.

  • iamsudo Level 1 Level 1

    I had this problem also in 10.8. Now on 10.9.5 I moved Safari's application support folder and property list file to the trash, killed cfprefsd and restarted Safari. That option is never written to file. I compared both before and after states of the plist.

     

    If I change search provider it still sends the search queries, but the key SearchProviderIdentifier shows in the plist.

     

    For those that it seems to work, could you please post key and value that's written to plist for that option?

  • iamsudo Level 1 Level 1

    For 10.9.5 try this in Terminal

     

    defaults write com.apple.Safari SuppressSearchSuggestions TRUE

     

    I still have to check it with a proxy and in Wireshark.

Previous 1 2 Next