6 Replies Latest reply: Jul 13, 2014 1:15 PM by WildBlue2030
Frankns Level 1 Level 1 (55 points)

I'm wondering if there is a way to set the default email field label to "work" each time I capture an address from an email.


Typically, when I add an address from a colleague - either using the "From" header or by using the data detector in a signature, Mail and Contacts label the address as "other" or "home" but never "work."   For nearly all of the contacts I add, I have to edit them manually as a result, changing both the email and address labels. 


This is probably trivial, I understand, but it's one of those annoying inconveniences that can nag at a person after a while ...

  • Barney-15E Level 8 Level 8 (42,040 points)

    Try going into Contacts Preferences, Template, and change the default fields to Work.


    Also, you can add and remove fields to that template. Click the - to remove. To add an item, use the Add Field menu. That way, your new contact card has all the fields you want.

  • Frankns Level 1 Level 1 (55 points)

    Alas ... no joy.  Tried those things a while back.


    My default fields are "work" - both for phone and email - and I've deleted all other fields.


    If it makes a difference, the back-end is MS Exchange.

  • Barney-15E Level 8 Level 8 (42,040 points)

    I don't know about using an exchange list, but I can imagine that might be the issue.

  • Frankns Level 1 Level 1 (55 points)

    Thanks Barney ...


    No, I'm not using an exchange list.  I'm just saying that my back-end mail service is Exchange.


    One additional detail, I'm starting to think that this has something to do with adding data to an existing record.  From the bottom of a current message from Jon Doe, attempt to add his phone number to the existing record in Contacts ... in these cases, the field label seems to suffer. 


    And Contacts is entirely local, no sync to Exchange.

  • Barney-15E Level 8 Level 8 (42,040 points)

    Mail and Contacts are not linked in any way except Mail grabbing contact information from Contacts. So, your email server would have nothing to do with adding a contact.


    The whole way the Template has been implemented has been going through changes over the last few versions. Maybe they'll get to making those things stick, eventually.

  • WildBlue2030 Level 1 Level 1 (0 points)

    I'm pretty sure the issue you are having is related to using Exchange Server. I have both an iCloud (used to be dot mac) account, and two different Exchange accounts configured on my Mac. I have set the preferences of Contacts to be "work-centric" (LinkedIn as a standard field, work as the primary phone, work as the primary address). When I add a new contact with the iCloud account selected in the left bar of Contacts, the new contact respects the preferences I set. When I add a contact from either of the Exchange accounts, it uses the original defaults of "mobile" for the primary phone, "home" for the primary address, etc.


    This is especially annoying since I use iCloud for personal contacts and Exchange for work.


    Something I haven't tried: Delete all the accounts from Contacts, set the preferences, and then reconnect all the accounts. It is possible that the Exchange accounts will respect the preferences that were set when the Exchange accounts were added.  Maybe someday I'll have the patience to try this...