Previous 1 2 Next 16 Replies Latest reply: Apr 2, 2013 7:57 AM by babowa
burke.minsley Level 1 Level 1

My new (late 2012) iMac does not appear to have a recovery partition- is this how new iMacs are built?

iMac, OS X Mountain Lion (10.8.2)
  • mende1 Level 10 Level 10

    All Macs come with Recovery HD installed. To check if you have it, the best way is to press Command and R keys while your Mac is starting, so if your Mac doesn't connect to the Internet to access to Recovery, you have Recovery HD.


    Another way to check if you have Recovery HD is to open Terminal and type:


    diskutil list


    Then, under that command, you will see all partitions of the hard disk, so you should see Recovery HD at the bottom. If it doesn't show up, you don't have Recovery HD

  • babowa Level 7 Level 7

    Recovery partition is a hidden file/partition.


    Do you have the debug menu enabled in Disk Utility and checked to show all partitions? If so, then it will show up in Disk Utility like this:


    Screen Shot 2013-01-15 at 8.52.04 AM.png

    To enable the debug menu, run this in Terminal:


    defaults write DUDebugMenuEnabled 1


    Quit Terminal, launch DU and select Show Every Partition from the Debug Menu.

  • The Heftster Level 1 Level 1

    I can confirm this. I just received my 27" with 1TB Fusion drive. I also have no recovery partition at boot. If I hold down ALT while booting I just get the Macintosh HD icon and network options. Nothing else.


    I have enabled Debug menu in Disk Utility (I used Lion Tweaks to turn the menu on). This screenshot shows a whole lotta crap on the drive INCLUDING a recovery partition, but I have no ay to access it at boot-up.



    This is frustrating!!


    It all started when I tried to bot my iMac off an external drive. I have an external drive with 10.8.2 installed. It shows up when I hold down ALT after startup chime, but iMac refuses to boot from it. just makes the "Ø" symbol and shuts down after a minute.


    A little googling indicates that the Mac OS version on the iMac may be unique to the machine, and I need to install the right version on my external drive before the machine will boot it. But the only way this can be done is via the Recovery drive that comes with the iMac, and that was when I realized - it's not there.


    Now I'll have to Carbon Copy Clone my Fusion Drive in case it crashes - and hope that works as a bootable disk, because Apple seems to have forgotten to give me any other option!


    Any ideas - other that buying Mountain Lion on a USB drive?

  • babowa Level 7 Level 7

    Well, looking at your screenshot, I have to say I have absolutely no idea what all you have there except that it appears to be a mess. You have an abundance of Macintosh HD's in addition to a boot disk, yet everything is greyed out.


    The only thing I can think of is using Command + Option + R while restarting; it will take you to Apple's servers and you can access their Disk utility - I'd erase the drive and repartition and then install the OS.

  • The Heftster Level 1 Level 1

    Well it appears I'm a bit of a tool


    I kept on stubbornly refusing to try the Command+R shortcut after the startup chime, as I saw no reason to. I have 2 other Macs running Mountain Lion and I ususally access the recovery drive by just hoding down ALT.


    Seems this new iMac has different firmware and I can only access the recovery disk by using the CMD+R shortcut.


    Ok it works - but even though I updated the Mountain Lion version on my external HD using my new iMac's recovery partition, it still refuses to boot via the external drive. This may be due to other factors. I have an external LaCie drive attached using a FireWire-to-Thunderbolt adaptor. So, now to try using USB ports instead. That's another story for another thread.



    In case you're wondering - that didn't work either. I still can't boot off the external via USB either. So I'm gonna search for that topic now.

  • jackpot1 Level 1 Level 1

    Confirming on a brand new 27" iMac that was purchased about two days ago...


    No Recovery Partition - verified using 'diskutil list' - also by using the debug menu.


    Wondering why Apple would ship machines like this... especially when you need that partition to enable FileVault2...

  • ssls6 Level 4 Level 4

    I just ordered a new imac.   I recently learned the FW was gone, then the audio in, and now you say booting off an external drive?  I'm gonna pay close attention to this thread.


    I did find this link that explains some of this I think

  • Mike Osborn Level 4 Level 4

    My guess is the recovery partition's just aren't accessing it properly. Are you sure you're holding down the Command and R keys when booting up?

 've done something to delete it.....?

  • jackpot1 Level 1 Level 1

    Brand new out of the box... 'diskutil list' will show ALL partitions...


    Another odd thing.  We bought two iMacs that day.  The other iMac does indeed have the Recovery Partition.  Too bad I need to FV2 the one without it.



  • babowa Level 7 Level 7

    Using Command + Option + R to access internet recovery (or Command + R if it will boot into internet recovery with that combo) and simply installing over the top should create a new recovery partition. FWIW, recovery and internet recovery are not quite the same process. My thought is: even if it does not show as a hidden partition, as long as you can access IR, the process is available and working. So, have you tried the key combos just to see if it is available? You wouldn't have to go further, if you can get to Apple's servers and the IR window pops up, it is working - at that point, you can simply quit and restart with your internal.

  • jackpot1 Level 1 Level 1

    IR does indeed work - still won't help though with FV2. 

  • babowa Level 7 Level 7

    Well, then, I'd reinstall over the top to see if a recovery partition is created. (I don't use FileVault, so have not tried that).

  • Sebastien S. Level 1 Level 1

    I can confirm, someone I know receive the iMac 27 and there is not recovery partition on the 3TB Fusion Drive.

    So I checked corretly (I work in IT) and there is no Recocery installed...

    Waiting for Apple official answer, actually they try to make us reinstall from Time Machine, but I read in forums that most of people then failed to download the Net Recovery... as there is NO recovery partition in this mac, it's dangerous to try anything.


    Thanks !

  • IM Arrnot Level 1 Level 1

    I have one (fusion drive 27) right in front of me that I was attempting to image from another fusion 27 image we just created.  The recovery partition does not show up if you hold down option while booting as it did in Lion.


    However, it does boot into recovery mode if you hold down cmd-r on boot.


    I am not attaching the computer to the wifi or network so it is not getting the internet recovery...



    Also, I used a thunderbolt ssd to copy the image over.  Blazing fast.  5 mins to scan the image and 5 mins to restore a 40 plus GB disc image loaded with all the creative apps we use here.  I highly recommend picking one up for that purpose if you do that type of work with macs.

Previous 1 2 Next