14 Replies Latest reply: Jan 17, 2013 7:31 PM by Snagged
Snagged Level 1 Level 1 (0 points)

I tried the Mcafee antivirus for mac and uninstalled it because I didn't like it. Well since then, my homepage, toolbar buttons, search engine, and window size preferences will not hold. after non use for period of time. my preferences change to something else. I've tried reparing permissions, restarting computer and tried looking for com.apple.safari.plist but with no luck. Thought about trashing safari and reinstalling it. please some help with this.


iMac, OS X Mountain Lion (10.8.2), mid 2011
  • ~Bee Level 7 Level 7 (31,160 points)

    Snagged --

     

    That's exactly why so many of us here always strongly discourage use of Norton or McAfee AV.  Bad news, really.  Did you use the official McAfee UNinstaller, or did you just take the app to the trash?

  • Snagged Level 1 Level 1 (0 points)

    I had some funny business happening with my email and wanted a second opinion to ensure that there was no bugs on my computer, thats why I installed the mcafee, anyhow,I think that I just trashed mcafee, and then found the uninstaller for it and ran it too.

  • ~Bee Level 7 Level 7 (31,160 points)

    Snagged --

     

    Have you searched for "McAfee" using "Search" on your Mac?

    Did you load on any other internet apps / plugins or extensions?

     

    Do you have AdBlocker on there?

  • Linc Davis Level 10 Level 10 (169,490 points)

    Triple-click the line below to select it:

     

    ~/Library/Preferences/com.apple.Safari.plist

     

    Right-click or control-click the highlighted line and select
      
    Services Show Info
     
    from the contextual menu. An Info dialog should open.
     
    Does the dialog show "You can read and write" in the Sharing & Permissions section?
    In the General section, is the box labeled Locked checked?
    What is the Modified date?

  • Snagged Level 1 Level 1 (0 points)

    Bee

    I have searched for Mcafee on my Mac and found zero results. The only loaded extentions are the  reload button and duplicate tab button in which i think was already installed. I dont use any add blockers and not sure as to view what plugins are installed.

  • Snagged Level 1 Level 1 (0 points)

    -Linc Davis

     

    In Sharing and Permissions it shows system has read & write and everyone has no access.

     

    in general it shows that its not locked

     

    Date modified is January 12 2013 ( the date in which all this nonsense started)

  • Linc Davis Level 10 Level 10 (169,490 points)

    Back up all data.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.

     

    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. You can demote it back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:20 ~ $_ ; chmod -R -N ~ $_ 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2

     

    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:

    resetpassword

    That's one word, all lower case, with no spaces. Then press return. A Reset Password window will open. You’renot going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

    Select

    Restart

    from the menu bar.

  • Snagged Level 1 Level 1 (0 points)

    -Linc

    after running sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:20 ~ $_ ; chmod -R -N ~ $_ 2> /dev/null  in step 1 , resulted in this message : chown: /Users/Applepie/Library/Saved Application State/com.titanium.OnyX.savedState: Operation not permitted.

    is this a normal responce?

  • Linc Davis Level 10 Level 10 (169,490 points)

    Please run the following command in the same way as before and post the output:

     

    ls -Odeln L*/Sa*/*OnyX*

  • Snagged Level 1 Level 1 (0 points)

    -Linc

     

    ls -Odeln L*/Sa*/*OnyX*


    drwx------  2 501  20  uchg 68 Sep 23  2011 Library/Saved Application State/com.titanium.OnyX.savedState

  • Linc Davis Level 10 Level 10 (169,490 points)

    The folder is locked. The command I gave you should have unlocked it. Please try again.

  • Snagged Level 1 Level 1 (0 points)

    which command is it that I'm to try again? The sudo chflag one, or the ls -0deln one?

  • Linc Davis Level 10 Level 10 (169,490 points)

    Repeat the whole procedure in my post starting with Back up all data.

  • Snagged Level 1 Level 1 (0 points)

    Everything seems to be in order now,  Thankyou for all your help.