Previous 1 2 Next 26 Replies Latest reply: Oct 13, 2015 6:37 AM by Kelly015
icsbicr Level 1 (0 points)

I can't edit the artist names in iTunes 11. I'll select a group of songs and then click "get info" and change the information, and the changes show in iTunes when I'm under "song" but when I sync my ipod or when I'm under the "artist" tab, they are still listed as diffrent artists.


I have Hillsong, Hillsong Live, and Hillsong United songs. I don't want them all the be under diffrent artists, I want them all to be Hillsong. So I select the songs, get info, change the name...and yet still, when I sync, I have Hillsong, Hillsong Live, and Hillsong United.

I hope this was clear, thank you!

  • pink.sixth.gun Level 1 (0 points)

    Same here!! It bugs the crap out of me! I listen to foreign music and prefer that the name of the artist be in that language. Im picky that way. lol So when I buy albums from the US itunes, of course the name is converted into English and it bugs me so bad! lol Hey Apple! Change it back!


    Anyone else have this issue as well? Any fixes?




  • thisistrivial Level 1 (0 points)

    Hello, it was annoying me too but I've found a fix! If you put the song/artist in question into a playlist you can click on teh artist like in previous versions and edit it there! Hope this helps.

  • Steve Taylor1 Level 5 (4,670 points)

    I'm not sure about this but if you put the Artist name in the Album Artist field as well as artist and give all the tracks the same album name i Think it will work.

  • Alan Weiss Level 1 (0 points)

    Ah... another brilliant "feature" of iTunes 11!  There are too many stupidities in this new version to even attempt to itemize here, but this one is truly amazing.  I ran into this problem after buying some classical music from the iTunes Store.  The tracks had the composer's name in the "artist" field and nothing in the "composer" field.  Changing the contents of "artist" seems to work, as icsbicr noted, but then if you play the track, or do Cmd-I, or various other things, the artist changes back to the original (and, in this case, incorrect) content.  If someone at Apple thinks we ought not to be allowed to change "artist" for purchased content, then at least they ought to prevent us from doing it right away instead of seeming to change it and then later changing it back.


    So here's how to fix it.  You don't want to mess with Mickey Mouse circumventions like "various artists" and "part of a compilation" (as suggested in, because those tags are INCORRECT.  If you want the information to be correct, you've got to change the tags in the music file itself.  I realize this is a huge pain, but Apple doesn't seem to care too much about causing their customers big pains.  I used a product called Fission from Rogue Amoeba, though there are probably plenty of other products which will do the same thing.


    You need to be careful so you don't get the iTunes data base out of sync with the file system structure.  What I did was copy (not move) the files from the iTunes folders (use "Show in Finder" from the context menu if you're not sure where they are) to another folder somewhere and then deleted them from iTunes.  Then I used Fission to edit the tags in the file to show the correct information and saved the files to another folder (keeping the original files as they were, just in case of trouble).  Then I added the files with the edited tags to iTunes.  The only small problem I can see is that the tracks no longer show up in the "Purchased" list, but I can live with that.


    Good luck.

  • volcomgrl1223 Level 1 (0 points)

    the easiest way I found to fix this is to view my music by artist, find the artist you wish to edit on the left hand side of the screen, right click on said artist and click "get info" here you can edit the info.

  • Alan Weiss Level 1 (0 points)

    I think you misunderstood the point of the problem.  Yes, we can change the artist, but if it's a purchased track from the iTunes Store it doesn't stay changed.  At some later point it changes back to the original (often incorrect) value.  (I'm not absolutely sure that being purchased from the Store is what characterizes the problem, but so far that's when I've experienced it.)

  • alasdairw Level 1 (5 points)

    I fixed it:


    Right click on the song/movie, show in windows explorer, select all songs from album, right click, properties, untick read only in attributes.

  • iCrucify Level 1 (0 points)

    I've figured out a solution to your problem which I also had this problem to begin with.


    • Go to the song that you want to edit.
    • Right-click the song and click on "Show in Windows Explorer."
    • Now right-click on the song file that you want to change the song information that's linked to the song you want to change to begin with.
    • Click on "Properties."
    • At the bottom of the list where you see Attributes, uncheck the bow where you see "Read-only."


    Now you should be able to change your song information on iTunes 11.



  • gtrpro Level 1 (0 points)

    OK. This is the solution to your problems.  To change the information of a song on iTunes 11, you need to (mostly like iCrucify said):

    • go to the song you want to edit the information of.
    • right-click the song and click "Show in Windows Explorer".
    • right-click the song title in the new window that should have popped up. click "properties.
    • at the bottom of the newest window, uncheck the "read-only" box in the attributes section.
    • (now what's different)...change the information of the song at the top of the page where it says the artist and the title of the song (ex:David Guetta - Titanium) to what you want
    • click "OK" at the bottom
    • when you doubble-click the song to play it, it will now show an exclamation point; it will ask you if you want to locat the song.  click "Locate"
    • then find the song on a window that pops up simmilar to the window that popped up when you clicked "Show on Windows Explorer".  doubble left-click the song.
    • this song's information can now be changed directly on iTunes 11 by clicking on the song you want to edit once, waiting a second, then left-clicking it again (to prevent from just playing the song)
    • Type in the desired info, click "enter", and you're set!

              Hope this helps.  It may seem (and be) kind of a roundabout route to the solution, but I know it works.

  • triggr337 Level 1 (0 points)

    I have this problem.  If you go to Music/iTunes/iTunes Media/Music, it will show all of your artists.  If you go into one of these you find the albums by this artists, them songs inside the albums folders.  What is happening is that when you edit the sonf info, even if it says it's changed in iTunes, it won't change in the files and therefore it doesn't sync to your device.

  • PoppaWoody Level 1 (0 points)

    I'll repost this at the top so people will see this right away instead of trolling and trying a 100 different ways that don't work. From above poster:





    I fixed it:


    Right click on the song/movie, show in windows explorer, select all songs from album, right click, properties, untick read only in attributes.






    Message was edited by: PoppaWoody

  • PoppaWoody Level 1 (0 points)

    Took me a while to find the correct resolution and thanks to the other poster who put this here:


    Right click on the song/movie, show in windows explorer, select all songs from album, right click, properties, untick read only in attributes.



  • miaspop Level 1 (0 points)

    The songs I'm unable to edit do not have the read only atribute set. i'musing Windows 7 and iTunes Anyone find a solution to a similar problem?

  • martinb79 Level 1 (0 points)

    ok this worked for me. i created an aac copy of the tracks that needed to be fixed and you can edit those to your liking! but having 2 copies of the same song annoyed me so the down side is that i did have to go back and delete the originals

Previous 1 2 Next