11 Replies Latest reply: Jan 29, 2013 12:17 AM by Linc Davis
andrewfromworksop Level 1 (0 points)

I'm using iMac with OSX 10.8.2 mountain lion with safari 6.0.2 and every time I close safari it forgets /resets my preferences eg toolbar settings homepage and preferences I have tried reseting safari rebooting iMac Ive turned icloud on/off i use the extension adblocker and kaspersky security

iMac, Mac OS X (10.6.8)
  • ~Bee Level 7 (31,425 points)

    Delete AdBlocker.  Restart Safari and test.  If still not right, delete Kaspersky.


    Let us know how you are doing, OK?

  • Linc Davis Level 10 (192,809 points)

    Triple-click the line below to select it:


    Right-click or control-click the highlighted line and select
    Services Show Info
    from the contextual menu. An Info dialog should open.
    Does the dialog show "You can read and write" in the Sharing & Permissions section?
    In the General section, is the box labeled Locked checked?
    What is the Modified date?

  • andrewfromworksop Level 1 (0 points)

    Hi Ive done that and checked com.apple.safari plist and it does say system read and write everyoneno access and modofied date is 10/12/12

  • andrewfromworksop Level 1 (0 points)

    tried deleting adblocker and kaspersky then resetting safari made no difference

  • Linc Davis Level 10 (192,809 points)

    Back up all data.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. You can demote it back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    { sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -Rh $UID:20 ~ $_ ; chmod -R -N ~ $_ ; } 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2


    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:


    That's one word, all lower case, with no spaces. Then press return. A Reset Password window will open. You’renot going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.



    from the menu bar.

  • andrewfromworksop Level 1 (0 points)

    deleted adblocker made no difference deleted kaspersky made no difference still havent re installed adblocker but changed security to Intego still made no difference I am still unable to get safari to save options and toolbar settings

  • ~Bee Level 7 (31,425 points)

    Andrew --

    Please follow Linc's recommendations, OK?

    Let us know the results.


    If you insist on putting on "security" apps, you can always expect problems, IMHO.

    Intego is often more probematic than AdBlocker.

  • andrewfromworksop Level 1 (0 points)

    Thanks Bee have tried Linc's solution it hasnt made any difference not having any security apps makes no difference either and I no longer use adblocker at the moment

  • Linc Davis Level 10 (192,809 points)

    Please enter the following command in a Terminal window as before and post the output:


    ls -@Oaeln L*/Saf*

  • andrewfromworksop Level 1 (0 points)

    ok linc here s the terminal output


    Last login: Sat Jan 26 16:10:04 on console

    andrew-brogdales-imac-2:~ andrewbrogdale$ ls -@Oaeln L*/Saf*

    total 2032

    drwxr-xr-x@ 18 502  20  -         612 28 Jan 11:44 .

              com.apple.quarantine              38

    drwx------@ 58 502  20  hidden   1972 17 Jan 19:03 ..

              com.apple.FinderInfo              32

    0: ABCDEFAB-CDEF-ABCD-EFAB-CDEF0000000C deny delete

    -rw-r--r--   1 502  20  -       29328 26 Jan 08:26 Bookmarks.plist

    -rw-r--r--@  1 502  20  -       21863 28 Jan 11:32 Configurations.plist.signed

              com.apple.quarantine              21

    drwxr-xr-x   4 502  20  -         136 28 Jan 10:56 Databases

    -rw-r--r--@  1 502  20  -          65 11 Dec 07:36 Downloads.plist

              com.apple.quarantine              21

    drwxr-xr-x   5 502  20  -         170 28 Jan 11:32 Extensions

    -rw-------@  1 502  20  -         192 28 Jan 11:43 Form Values

              com.apple.quarantine              21

    -rw-r--r--@  1 502  20  -        5553 28 Jan 11:44 History.plist

              com.apple.quarantine              21

    -rw-------@  1 502  20  -      139264 28 Jan 11:44 HistoryIndex.sk

              com.apple.quarantine              21

    -rw-r--r--@  1 502  20  -       10725 28 Jan 11:44 LastSession.plist

              com.apple.quarantine              21

    drwx------   9 502  20  -         306 28 Jan 11:35 LocalStorage

    -rw-r--r--@  1 502  20  -          42 25 Jan 19:22 LocationPermissions.plist

              com.apple.quarantine              21

    drwx------@  4 502  20  -         136 14 Nov 13:48 ReadingListArchives

              com.apple.quarantine              38

    -rw-r--r--@  1 502  20  -      717598 13 May  2010 Safari Desktop Picture.jpg

              com.apple.quarantine              38

    -rw-r--r--@  1 502  20  -         802 21 Jan 13:46 TopSites.plist

              com.apple.quarantine              21

    -rw-r--r--@  1 502  20  -          42 21 Jan 13:46 UserNotificationPermissions.plist

  • Linc Davis Level 10 (192,809 points)

    Triple-click the text on the line below to the clipboard, then copy it to the Clipboard (command-C):




    Quit Safari. Disable Safari synchronization in iCloud, if applicable.




    Go Go to Folder


    from the Finder menu bar. Paste (command-V) into the text box that opens, then press return.


    A folder window should open with a file named "Bookmarks.plist" selected. Move the selected file to the Desktop, leaving the folder open.


    Relaunch Safari. It will open with the default set of bookmarks. Delete them all. Select


    File Import Bookmarks


    from the Safari menu bar. Import from the bookmarks file you moved to the Desktop. Arrange the bookmark folders as you wish.


    Re-enable synchronization if you disabled it. If Safari now performs normally, you can delete the old bookmarks file. Otherwise, quit Safari again and put back the file you moved, replacing the newer one with the same name. Close the Finder window and post again.