Previous 1 2 Next 16 Replies Latest reply: Jun 25, 2015 5:33 AM by Jane zz
Nisan A. Level 1 Level 1 (0 points)

It's been about three days since youtbe suddenly stopped loading in my mac. It loads a tiny bir in the adress bar and when I wait a good few minutes it says that Safari can't open the page.

I've alreay tried several DNS settings but that doesn't seem to be the case. Also, none of my proxies are checked.


Any ideas on what may be the problem?

iMac, OS X Mountain Lion (10.8.2)
  • KarenSelena Level 4 Level 4 (1,960 points)

    Did you already try resetting Safari??  If not, click on the word safari beside the apple, then select "reset safari". 

  • Nisan A. Level 1 Level 1 (0 points)

    I've just tried it and nothing changed, but thank you!

  • KarenSelena Level 4 Level 4 (1,960 points)

    Try uninstalling then reinstalling a fresh copy of the Flash Player plugin.


    Uninstall Flash -


    Re-install Flash -

  • dominic23 Level 8 Level 8 (35,340 points)

    YouTube videos not playing?


    One of the following steps should help.



    1. Install Adobe Flash Player.




    2 .Are Plug-ins Enabled?


        Enable Plug-ins


        Safari > Preferences > Security


        Web Content:

        Click in the box for "Enable Plug-ins".



    3. Check  whether you are currently  in  YouTube HTML 5 trial.



        At the bottom  left of the page  uncheck the box for


       "You are currently in the HTML5 trial".



         Now try YouTube.



  • Nisan A. Level 1 Level 1 (0 points)

    Just did that as well, didn't change anything :c

  • Nisan A. Level 1 Level 1 (0 points)

    The problem isn't that youtube videos are not playing, it that I can't open the site itself, but thank you!

  • Linc Davis Level 10 Level 10 (178,440 points)

    Select the text below (not including the blank space at the end of the line), then copy it to the Clipboard (command-C):



    Launch the Network Utility application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Network Utility in the icon grid.


    Step 1


    Select the Lookup tab and paste (command-V) into the address field. Press return. Post the output that appears below – the text, please, not a screenshot.


    Step 2


    Select the Ping tab and do the same.

  • GoldenAvenger Level 1 Level 1 (0 points)

    try to reinstall safari /update it /install the latest adobe flash player

  • Nisan A. Level 1 Level 1 (0 points)

    the lookup one:


    Lookup has started…


    Trying ""

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16027

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 9, AUTHORITY: 0, ADDITIONAL: 0



    ;                              IN          ANY


    ;; ANSWER SECTION:                    591          IN          MX          50                    591          IN          MX          20                    591          IN          MX          40                    591          IN          MX          10                    591          IN          MX          30                    170609          IN          NS                    170609          IN          NS                    170609          IN          NS                    170609          IN          NS


    Received 216 bytes from in 72 ms



    the ping one:


    Ping has started…


    PING ( 56 data bytes

    Request timeout for icmp_seq 0

    Request timeout for icmp_seq 1

    Request timeout for icmp_seq 2

    Request timeout for icmp_seq 3

    Request timeout for icmp_seq 4

    Request timeout for icmp_seq 5

    Request timeout for icmp_seq 6

    Request timeout for icmp_seq 7

    Request timeout for icmp_seq 8


    --- ping statistics ---

    10 packets transmitted, 0 packets received, 100.0% packet loss

  • Nisan A. Level 1 Level 1 (0 points)

    Also, I don't know if it would help but we tried to open youtube from my mom's macbook pro and another macbook pro and it still didn't open. However we can access youtube from our iphones and ipad.

  • Nisan A. Level 1 Level 1 (0 points)

    Alright, I figured it out and solved it. Just in case there's someone with the same problem:


    I just wennt to go > go to folder > /etc


    found the hosts file.


    dragged it into simultron to open it.


    found the two lines for, deleted them. Saved it and it works!


    Thank you to all who has tried to help :O)

  • Linc Davis Level 10 Level 10 (178,440 points)

    You wrote above that you had changed your DNS settings, so I assume you know how to do that. In your router, change the DNS settings to use your ISP's DNS servers. Usually all you have to do to make that happen is to delete whatever you put in. The DNS server addresses should be populated automatically.


    On the clients, also remove the DNS server addresses. Your router should then be used as a DNS proxy, which will refer all queries to your ISP.


    Test. If there's no improvement, please repeat the Network Utility tests and post the results.

  • nuseybe Level 1 Level 1 (0 points)

    Hi. I have the same problem. My macbook pro doesnt open youtube in any browser (safari, chrome, firefox..). I tried the solution you gave us here but i cannot save the changes in the host file. Actually the file was locked to change anything but i gave permission. Then still it doesnt accept any change in the file. I am trying this on Textedit because I dont have smultron. So is there any other way you know, to solve this problem? thanks.

  • Nisan A. Level 1 Level 1 (0 points)

    Hi! I had the same notice, so I didn't want to mess with it and used smultron, here's a download link for it, I think it'll work if you open it with smultron and let you save it :O) Here, give it a try:

Previous 1 2 Next