11 Replies Latest reply: Sep 10, 2013 12:52 PM by scottunderwood
yukon9 Level 1 Level 1

I bought unlocked iphone 5 last Nov.. WIFI connection works well, and updated to ios 6.02. after two month, iphone 5 can't connect password-protected wifi, starbucks and macdonald's wifi. Sometime show wifi connected, but internet doesn't work.  I tried reset iphone5, but useless


Meanwhile, iphone 4, blackberry and android connect wifi very well under same wifi environment.

  • whatheck Level 5 Level 5

    Try Resetting Network Settings from Settings > General > Reset.


    If that doesn't do it, this Apple doc might be able to help ya out -> iOS: Troubleshooting Wi-Fi networks and connections

  • yukon9 Level 1 Level 1

    Thanks! I tried everything, even walk to apple store to restore my iphone5, but still not work. it's no problem to connect apple store's open wifi, but still cann't connect any password-protected wifi.

  • yukon9 Level 1 Level 1

    tried everything again, but still not work

  • whatheck Level 5 Level 5

    Well, if it works at the Apple store but it isn't anywhere else, you may have to test on more Wi-Fi networks or change the way your network is setup.


    What type of router and wireless security are you using?


    See this Apple doc for configuration tips -> iOS and OS X: Recommended settings for Wi-Fi routers and access points

  • yukon9 Level 1 Level 1

    THANKS! I tried everything many time, but the problem keep same.


    Do some reseach and found wifi problem for iphone 5 is very common, it's absolutely apple problem, not setting, not router issues.


    I think the problem is from ISO6.0.2.If apple couldn't solve this problem soon, sugguest not to buy iphone 5 unless willing to pay expensive cellular data.

  • HolyRolly Level 1 Level 1

    Help us Apple! Same issue here. Just picked up iphone 5 yesterday and cannot connect to any secure network even with the correct password!

  • yukon9 Level 1 Level 1

    went to apple store, they told the problme was router setting. It's definitely a joke. Can I ask stacbucks to re-set their routers because I am using IPHONE 5??!!! I said under WIFI environment, only my iphone 5 can't connect to WIFI, any android, BB, iphone 4/4s has no problem for WIFI.


    I have iphone 4, ipad, ipod, but only iphone 5 has problem, but disappointed this time. I also ask for exchange, but was told it's not hardware problem because it can connect apple store's wifi. Crazy!

  • HolyRolly Level 1 Level 1

    Went to apple store. They noticed a few other glitchy things about my phone so they did a wipe (yes info was backed up). I took it home and was able to connect to my secure wi-fi finally!!! Even after the restore it worked as well. The phone works perfectly fine now.

  • yukon9 Level 1 Level 1

    You are lucky, but my iphone5 keeps same problem. I visited apple store again for wifi problem. this time they use their iphone as hotspot, my iphone 5 could connect it well. They suggest me to change a router, I did, but still useless.


    Really frustrated! also really disapointed. The reason I bought iphone 5 is that past phones including my iphone 4 run every stably,  but not iphone 5. My iphone 5 just two-months new, and have such baffling problem. It's definitely a expensive joke.

  • andros_nic Level 1 Level 1

    I had the same issue and usually a reset of all the network settings on iphone did the trick.

    this method did not work with my iphone 5 . i did something in router settings that seemed to change things a lot, for the better.


    the wifi channel usually the routers use is channel 11, so i changed mine to channel 1. this solved my issues and the iphone connected just fine to the network, without restarting the iphone or resetting any settings or switching off and back on the wifi.


    i am on 6.1.3 iOS

  • scottunderwood Level 1 Level 1

    I had the same issue, my phone won't connect to networks with a password.  What worked for me is to allow the phone to discover the network SSID. 


    Then I clicked Other...

    Type in the name of the SSID that was discovered.

    Click Security.  Here's the tricky part, it's probably wither WEP, WPA, WPA2.  A little trial error required here.

    Enter the password you've been provided.


    This should do the trick, after you play with the right security type.