Previous 1 2 Next 18 Replies Latest reply: May 8, 2013 2:18 PM by LaPastenague
Cal F Level 1 Level 1 (0 points)

Hi,

 

I have connect my external hard drive to the USB port of the Airport Extreme but I cannot see it in the finder, cannot access it in any way, but I do see it in the disks tab in the Airport utility.  I've tried to connect with the IP address but I get a response of "does not exist."  I've also tried to connect through the wireless network's icon at the top right of the screen, but, I only see the network itselfk not the router.  I have tried every method in this article (HT1331) but it will not work.  Obviously the router is working because I'm connected to the internet, but I cannot connect to it in anyway to access the USB mounted drive.

 

HELP!!

 

C. Fleming

raptorcc@gmail.com


Airport Extreme, Mac OS X (10.6.8)
  • LaPastenague Level 8 Level 8 (44,070 points)

    In the file sharing page, turn on the guest account to read and write access.. you don't have to do this all the time but this is to help.

     

    In finder you will see there are differences between Snow Leopard in your profile and Mountain Lion which I am sure you are using.. you need to turn on shared or devices.. sorry I am swapping between them and have forgotten myself.

     

    If you keep having trouble.. not at all unusual on ML, you might need to reformat the USB.. it must be GPT partitioned and use HFS+ (although FAT32 supposedly works.. ??)

     

    There is another little quirk with Mountain Lion I have also just experienced.. My USB drive.. even plugged directly into the ML computer will not show up. Correct formatted etc.. ML just has some distaste for some brands of USB drives. It works perfectly in Snow Leopard.. just another of those little "Features" offered with the latest OS. Do a google .. some drives like Lacie are particularly prone to the issue.

  • Cal F Level 1 Level 1 (0 points)

    LaPastenague,

     

    Thanks for the feedback.  I have file sharing turned on.  I turned on guest accoount read and write.  By the way, when I plug the drive directly to the computer, via the USB port, it works great; it shows up immediately and I can easily rerad and write to it.

     

    Still stuck.

  • LaPastenague Level 8 Level 8 (44,070 points)

    How is the drive formatted and partitioned.. ie MBR will probably not work as a network drive.. it might work locally.

     

    Did you try direct connection in finder.

     

    Go.. connect to server..

    AFP://IPairportextreme

     

    See what shows up.

  • Cal F Level 1 Level 1 (0 points)

    LaPastenague,

     

    The drive is formatted as NFTS.  Here is what the instructions say. The NTFS Driver (5MB) allows you to mount the NTFS partition on both a GoFlex and Backup Plus drive as read and write (NTFS would normally be read only in MacOS), so the drive can be used to drag and drop files between a computer running Mac OS and one running Windows. The instructions specifically say "do not allow Time Machine to use the GoFlex Satellite device..."  When I have the drive connected to my Mac, I have moved files to a PC connected to the network and from the PC to the Mac via the network.  It just does not work when connected to the Airport Extreme.

     

    Yes, I've tried to connect theough the "Go" tab in the finder.  It says "Connection Failed" The server may not exist or it is unavailable"....

     

    By the way, I can see the drive under the Disks tab in the airport utility program.  It correctly identifies it anmd shows how much space is left.

     

    Thanks & still stuck.

  • Bob Timmons Level 10 Level 10 (90,640 points)

    The drive is formatted as NFTS

    That......is the problem.

     

    The USB port on the AirPort Extreme will read/write to drives that are formatted in HFS+ or FAT16/32.

     

    NTFS and exFAT are not supported.  See this Apple support document to confirm:

     

    http://support.apple.com/kb/HT2426

  • Cal F Level 1 Level 1 (0 points)

    Ok - That's bad news... The installer that I got from Seagate does not have an option for anything other than NTFS.  Any suggestions on what I should do and still have compatability with a PC?

     

    Thanks

  • Bob Timmons Level 10 Level 10 (90,640 points)

    The PC will be able to read and write to a drive at the AirPort Extreme if the drive is formatted in Mac OS Extended (Journaled)...also known as HFS+....or a format of FAT 32.

     

    If you have access to a Mac, you can use Disk Utility to format the drive.

     

    Unfortunately, this will erase the contents of the drive, so if you do not have a backup copy of the data on the drive, you will first have to transfer that data to another drive.  Then format the drive and move the data back over to the drive and connect it to the AirPort Extreme.

     

    I would recommned HFS+ if you plan to keep the drive permanently connected to the AirPort Extreme. If you plan to move the drive around and will need to connect it directly to a PC, then you would want to format the drive in FAT32.

  • Cal F Level 1 Level 1 (0 points)

    OK - Progress made.  I transferred all the files to another drive and then formatted the Goflex drive using "FAT 32".  I plugged it into the Airpport extreme and I was able to transfer files, no problem.  It still does not show up in the finder, but it does show up on the far right side of the desktop.  I can live with that.  Thanks for all of the help.

  • Bob Timmons Level 10 Level 10 (90,640 points)
    It still does not show up in the finder, but it does show up on the far right side of the desktop.

     

    Open a Finder window and look for the AirPort Extreme icon under the SHARED heading. Is it there?

     

    Click the icon, then double click the folder representing the drive that appears just to the right.

     

    If you do not see the AirPort Extreme icon, open Finder Preferences and make sure that you have enabled to option to display "Connected Servers" on the desktop.

  • Cal F Level 1 Level 1 (0 points)

    OK, I'm back.. Needed some time to recover from the frustration.  Bob Timmons and everyone else thanks for your help.  I can see the Airport exttreme in the finder and access the files from my iMAC YEA!!!

     

    I was in 7th heaven until I tried to access the connected (USB) drive from a PC on the network.  But, I cannot see the roouter or the USB drive on the network from the PC; yes, I can see my iMAC and another hard drive I have connected to the iMAC. 

     

    Then I thought, OK, I'll just share the files on the external drive, but there does not seem to be anyway to do that.  I tried sharing the file using the "File, Get Info, Enable Sharing" procedure, but there is no "Enable sharing" button, only one that says "Locked"  HELP!!!!

  • LaPastenague Level 8 Level 8 (44,070 points)

    Load bonjour for windows onto the windows machine.. the best way is to load the whole airport utility which includes bonjour.. that will help the PC find the disk.

     

    Make sure your names are SMB compatible.. ie Short.. no spaces.. pure alphanumeric.

     

    For everything.. name of device, share names, wireless names if using wireless to the PC.

     

    Then open windows explorer and type in the address bar.

     

    \\Airportextremename or \\AEIPaddress.. where you replace those with the actual share name or IP address.

     

    If you still have issues, make sure your windows is set to home , not work or public.

     

    Turn off any firewalls.

     

    Ensure that the guest account is turned on and you have full read and write access. .you can also load the windows workgroup name.. ie WORKGROUP

  • Cal F Level 1 Level 1 (0 points)

    Hi,

     

    I have a related problem - I cannot share any of the files on the drive connected to my airport extreme.  When I go to file sharing, I can see the files, but they are greyed out and cannot be selected.  If I try to share an individual file using the get info method under the file menu, there is no "shared Folder" button in the window.

     

    Help!

     

    Thanks.

     

    Cal

  • LaPastenague Level 8 Level 8 (44,070 points)

    Are you running Airport Utility from windows?

     

    If not then please load it.

     

    Turn guest account on to full access, ie read and write.

     

    You should be able to access the files. If not create the directory from windows, and copy the files to it from the Mac.. your issue I imagine is simply permissions.

  • Cal F Level 1 Level 1 (0 points)

    HI,

     

    OK - I've successfully been able to get the PC (by loading the Airport extreme utility for Windows to the PC) to access the external drive connected to the router.  So, all is good there.

     

    Now, I want to connect my Sharp acquos smart TV to the same external drive connected to the airport extreme router.  The TV is wirelessly connected to the net, I can connect using the icons and the Shrarp Aquos net, but when I use the "LAN" icon so that I can view the photos on the external drive it won't connect.  Any ideas?

     

    Thanks!

Previous 1 2 Next