0 Replies Latest reply: Jan 17, 2013 9:42 AM by byofuel
byofuel Level 1 Level 1 (0 points)

I can authenticate with Dovecot 2.1.12 but cannot select the Inbox without getting this error:


c select inbox

c NO [SERVERBUG] Internal error occurred. Refer to server log for more information. [2013-01-16 18:22:13]


Here's the server log:

dovecot[15643]: imap(u1): Error: Failed to autocreate mailbox INBOX: Mailbox already exists


Auto create settings are currently set to 'no' -- when they were set to create, the problem was the same.  Passwords are currently plaintext for testing purposes -- Imap authentication works.


It's running on OS/X 10.7.3  Our config is below.  Thanks for any suggestions...


# 2.1.12: /usr/local/etc/dovecot/dovecot.conf

# OS: Darwin 11.3.0 x86_64

auth_debug_passwords = yes

auth_username_chars =

disable_plaintext_auth = no

mail_location = mbox:~/mail:INBOX=/var/mail/%u

mail_privileged_group = mail

namespace inbox {

  inbox = yes

  location =

  mailbox Drafts {

    special_use = \Drafts

  }

  mailbox INBOX {

    auto = no

  }

  mailbox Junk {

    special_use = \Junk

  }

  mailbox Sent {

    special_use = \Sent

  }

  mailbox "Sent Messages" {

    special_use = \Sent

  }

  mailbox Trash {

    special_use = \Trash

  }

  prefix =

}

passdb {

  args = scheme=plain /etc/passwd-imap

  driver = passwd-file

}

protocols = imap

ssl = no

userdb {

  args = username_format=%n /etc/passwd-imap

  driver = passwd-file

}


MacBook Pro, Mac OS X (10.7.3)