2 Replies Latest reply: Jan 17, 2013 1:04 PM by Allan Eckert
Finley_L Level 1 Level 1 (0 points)

i need to update my macbook because i am trying to install some things to it, im not sure if its lepoard or not i just know its a 2007 Version 10.5.8, it was given to me by a friend


MacBook Pro, Mac OS X (10.5.8)