Previous 1 2 Next 21 Replies Latest reply: Jul 15, 2015 6:19 AM by ckeilah Branched to a new discussion.
AWMarine Level 1 (5 points)

USB 3.0 SuperSpeed hub problems have plagued my Retina MacBook Pro using the current OS 10.8.2 since June. I'm on my 2nd Retina after a warranty exchange, and my 13th USB 3.0 powered hub. After all this, the problem appears to be isolated to the Mac not communicating with the hubs. Similar problems have been posted for the new iMacs with USB 3.0. Apple says they comply with the 2008 USB 3.0 standard, but that does not appear to be the case.


No problems were identified with the drives connected directly to the rMBPro. When connected to the hub, however, the drives fail to mount, spontaneously eject, or mount as USB 2.0 or USB1.1 according to the System Report. This happens whether 1 drive or 5 are mounted. All this has been documented with screen-sharing video, screenshots, and data capture over a 1.5 hour call with AppleCare to gather data for engineering.

I've worked with AppleCare and found engineering to be non-responsive to the "escalations". Engineering blames the problem on the hub manufacturers, and the manufacturers blame it on Apple. With 13 different hubs (7 different brands) all exhibiting the same unacceptable behavior; and two Retinas, Apple seems clearly at fault.


I'm aware of others having similar problems from user reviews on Amazon & other vendors. The reviewers typically don't list their platform or OS so it's difficult to establish which are late model Apple users. One of the worst hubs I ran across is being used on a friends PC with Windows 7.


  • Has anyone else been having such problems with USB 3.0 hubs on late model Macs?
  • Was a satisfactory solution identified and, if so, what?

If you reply, please state your Platform (Mac type/model) and the OS being used.


I expect to be meeting with an Apple Genius next week and can use all the information available, including links to information.

MacBook Pro with Retina display, OS X Mountain Lion (10.8), OS is current. Hubs are powered.
  • UrbanDesign7 Level 1 (0 points)



    I have an iMac 27" 2012. First, I had the same problems. Talked to the manufacturer of the Raidsonic HD Docking Station (for 2 Drives), and they told me to change the Cable. Did this, then everything worked fine.


    Now I had to order a new iMac due to a graphics problem. Today, the new one arrived and after everything worked well for 30 Minutes, the problem reappeared. Then plugged und unplugged the harddrives several times, and did nothing for 30 min (iMac was running in idle). When I tried to shift 20GB of Data to the iMac, it worked fine.


    So I assume there's a problem with the USB 3.0 driver from apple. I would suggest to talk to apple about this issue and to get them to update their driver as its a software issue.


    I hope that they will fix this problem soon...


    If anyone has the same problems or any advices or workarounds, please comment!

  • D.Cornelius Level 1 (0 points)

    I have mid-2012 MacBookAir 13" (MacBookAir5,2) running Lion ( 10.7.5 ). 8Gb RAM, 512GB SSD.

    Hub is: ( J-Tech  JTDUSB3.0-4P)  ( 4-port, powered ).

    Most problematic device:  Anker USB 3.0 to 10/100/1000 Gigabit Ethernet adapter.

    Symptom: The GigE adapter works fine all the time when plugged directly into the MBA USB3.0 ports.

    When plugged into the J-Tech hub, the LEDs on the GigE adapter stay dark about 90% of the times I've tried to plug it in.  I've messed around with sequencing of power application to the hub, the adapter, removal of other devices... there's some 'magic recipe' for getting the GigE adapter to power up on the hub.  Once it does power up ( in the 10% case)... the GigE ( and the other 3 devices on the USB3.0 hub ) fairly well...


    But, I also see random disconnections of a USB hard drive off the hub.  Gulp.  It's only holding my TimeMachine data. eek.

    I'd be very interested to know whether Apple fesses up on this.  Your data seems to point to MacOS being the problem area.


    Chime in if you want more data.

  • geordidog Level 1 (5 points)

    This is definitely a problem with Apple.  I have just received a new 2012 i7 mac mini which I purchased to use the USB 3 ports in my Home Theater.  I have a 7-port USB 3 Hub from Uspeed that works fine as a USB 2 hub but not at all as a USB 3 hub. It connects and randomly disconnects or does not connect at all with flashing blue lights that indicate a connection problem.  (The blue lights should just remain on.) My USB 3 drives work when connected directly to the mac mini.  The USB 3 hub from Uspeed works fine with a USB 3 port on HP laptop I have.  The problem is that I have 7 3tb drives with movies that need the USB 3 speed for proper playback.  I don't understand how Apple can have a problem with an Intel logic board that should have no problems with USB 3.


    I hope something is done or perhaps some third party can make a hub with drivers that actually works.  If you have a hub that works in USB 3 in system 10.8.2 please let me know by posting here.

  • AWMarine Level 1 (5 points)

    Have done testing with USB 3.0 hubs on my MacBook Pro Retina alongside a friend's Toshiba laptop running Windows 7. The Mac fared poorly. The Toshiba with Windows had virtually no errors with the 6 hubs tested.


    Why is it that the Windows world has USB 3.0 down and, after 8 months, Apple is still brushing these problems aside?



    An expansion of my original posting above can be found at my reply to the posting titled

    USB 3.0 Hub that works with 15'' Retina MBP (OS X Mountain Lion)


  • Robert Albury Level 1 (80 points)

    I have an iMac 21.5 late 2012 (iMac13,1) running OS 10.8.4. I have just bought an Anker (Uspeed) usb 3.0 - 4 port powered hub.


    It works great with all the usb 1 and usb 2 peripherals I have but the only USB 3 items – both hard disks demount at odd moments – such as in the middle of a file xfer or opening the disk window. This leads to a corrupted disk and requires erasing and reformatting. Althernatively when using the disk the system will report error code -50 and do nothing.


    Both disks work and have worked perfectly when other ported through an usb 2 hub or alternatively through the imac usb 3 port.


    After reading AWMarine comments about his tests with different usb 3.0 hubs I have concluded that Anker is the best of the hubs available and that it appears that all the USB 3.0 hubs do not work consistently with the latest macs. So I have decided to return the hub and wait until apple sort out what appears to be their problem with the usb 3 implementation.


    That is unless anyone knows better and how to cure this problem.

  • Robert Albury Level 1 (80 points)

    I must recommend Anker on their support - they offered a refund on the hub I purchased without quibbling, they also said

    'According to our tech team, there is a bug of the latest iOS which conducts a incompatibility with our hub (VIA 812 chipset). Chipset manufacturer is reporting this to Apple, we will need to see the progress later'


    Is there anyone out there who has a USB 3 hub that works with hard drives?

  • Eric Root Level 9 (50,234 points)
  • Robert Albury Level 1 (80 points)

    Hi Eric,

    I am not sure why you are posting a link to the FAQs. There does not appear to be anything of any relevance to the discussion there. Or have I missed something.

  • Scott3G Level 1 (0 points)

    I have had very similar problems with my 15" Macbook Pro Retina. USB 3.0 hubs have constant problems. Often after waking from sleep, the ports 'disappear' and connections to my hard drives and other devices are interupted. I've tried at least 5 different brands and all appear to have the same issues. Thunderbolt works fine. Web searches reveal several other forums all complaining about the same things. While I love my Mac, I have to admit it really feels like Apple has dropped the ball on this issue. On a PC, I never noticed any troubles like this.

  • AWMarine Level 1 (5 points)

    There's some good information that I've come across, but where to start. I've not posted on this Board since February, although I've been busy, and actively trying USB 3.0 hubs, calling AppleCare, etc. This week I'll be visiting the Genius Bar on this hub issue again.


    Again, I'm using a Mid-2012 MacBook Pro with Retina Display. I'm upgraded to OSX 10.8.5. My USB 3.0 hubs are all powered. Drives consist of two 3.0 TB Desktop drives and three Portable drives, plus a Thunderbolt drive that can also be used as USB 3.0.


    I recently had to return a "HooToo" 7-Port USB 3.0 as unstable. Their webpage on Amazon had the usual cautions about updating the OS, but nothing out of the ordinary. I went ballistic when I read the manual which stated:


    • "2012 Mac Mini and 2012 MacBook Pro with Retina Display are currently not recommended for use with this product because the unstable performance [sic]". No kidding, this was in the manual and not on the site.


    Then, in the next paragraph labeled "Features", the manual stated:


    • "Via VL812 allows this hub perform [sic] stably and perfectly compatible with your Windows, Mac OS or Linux" Systems."


    The reference above to 2012 Macs should be taken to heart when commenting on Apple and the USB 3.0 Hub Issue. Please list your Mac model and year, along with the OS X version so the rest of us can make sense out of what's affected.


    HooToo was right, their hub was unstable with my 2012 Retina. After applying for a refund from Amazon and listing the defects with the hub, their support reps contacted me and agreed to add the sentence to the webpage so another Mac owner doesn't walk into that trap.


    Needless to say, my 1-Star review wasn't too positive. It largely matched, and expanded on, 1-Star reviews by 3 other Mac Owners. Apparently nobody challenged the vendor and the misleading advertising continued.


    This was followed by the below from an executive with a hub vendor after the hub I'd ordered demonstrated similar problems as the others. He stated:



    "In terms of the background issues, the biggest one is that USB 3.0, even though it's in theory been around since 2009, actually really only stabilized last year (2012). Intel released their first USB 3.0 hardware, Windows 8 was Microsoft's first stack, and Apple released the first USB 3.0 systems. Everyone was scrambling to understand and fix subtle compatibility issues of all the combinations. For example, there was an Intel hardware bug that caused a lot of confusion:



    Apple released the 2012 macbooks as a 1st gen attempt in this context. The Retina definitely had special issues.


    By the end of last year, everything was getting better. For USB 3.0 hubs, you really want firmware from early 2013. Chipset and firmware version does make a difference.


    At this point, we have some reports of lingering problems with 2012 Macbook, but they've become fewer and farther between. Apple (with 10.8.x and SMC/EFI updates) and the industry seems to have worked around most of the large and small problems. So anyone with remaining issues with all up-to-date peripherals might want to consider whether it's a per-unit issue with their system and see if Apple has any advice.


    Hope that background helps."




    It really does help. If you're having USB 3.0 Hub problems, take a minute and re-read the above then share it with other Mac owners having USB 3.0 problems. The above is clear about the source of the problems with USB 3.0 hubs. It's coming from Apple. The above comments are coming from a manufacturer, and from a vendor, who have to face angry Mac owners daily. BTW, the second source shall remain anonymous. Anybody that nice, and honest enough to shed some light on Apple's Hub Problem deserves anonynmity. It's what I've come to believe this is what we were facing since my first USB 3.0 hub in June 2012 with my first Retina Display. (I'm now on my 19th hub.)


    I've done testing for Uspeed as LaptopMate, and later as Anker. While Uspeed gave me better results than most of the hubs, there was an unacceptably high levels of errors that could, and did, corrupt my data.. (I may be using 3 to 5 USB 3.0 drives and they'd just disappear on their own.) The VIA VL812 chipset was supposed to be the answer. After using several hub with this chipset I've found it not to be the answer, although they work great with Windows as I've been told. 


    Current drive problems encountered included:


    • Failure of drives to mount.
    • Spontaneous and unprovoked disconnects of (one or all) drives.
    • Spontaneous re-mounting of drives after they sponteneously dismounted. (Infrequently they'd loop and begin dismounting and  re-mounting repeatedly on their own.)
    • The drives/hub would apparently lockup as USB 1.1 or USB 2.0. (That's 12 MB/sec or 480 Mb/sec., instead of 5 Gb/sec.) The hub would have to be Reset by unplugging all cables to remove any possible source of power feeding back to it.



    I've had corrupted files, trashed hard drives, and a corrupted software RAID-1 Set (mirrored) that had to be rebuilt over 14 hours, after backing up the data for insurance. All this because of defective USB 3.0 hub operation on Apples, although Apple has denied that the hub is their problem, they're only responsible up to the port on the Mac. My view is that


    If you're having USB 3.0 problems be sure to post reviews with the vendors and online to tell your story. And, comment freely on this community. It's my understanding that Apple follows these comments. It's my impression that USB 3.0 is a low priority, way behind Thunderbolt, iPhones and iPads, and the iOS 7 and the Mavericks OS X. USB 3.0 doesn't seem to be their thing.


    I hope this helps. If so, the feedback would be appreciated.

  • Robert Albury Level 1 (80 points)

    Just a note to say thank you AWMarine for your persistence and efforts to try and reach a conclusion for this problem. I agree that it is very sad that Apple cannot be bothered to find a solution. It is pointless offering a port if no normal devices are able to connect properly to it. Hardly part of the Steve Jobs view of perfection.

  • MikeBaeuml Level 1 (0 points)

    I have a realtively new iMac 27" Late 2012. Trying to connect USB 2.0 und USB 3.0 devices (Printer, Harddisks, EyeTV) to the iMac via two differnet USB-Hubs (Initec 8 port USB 3.0 and even one industry grade EXSYS USB 3.0 Hub) made the iMac run crazy. Constant spontanuos ejects, error warnings, harddisks absenting in the middle of a data transfer. I have spent 3 full days with this problem, exchanged the harddisk, the hub and finally the USB cable, always wondering what the problem might be. Now I am learning this problem might be the Apple USB implementaion.




    Do something and fix this problem!!!

  • UrbanDesign7 Level 1 (0 points)

    I totaly agree with you!


    Unfortunately Apple won't do anything as long as there appear to be "only a few" customers with these problems, although I am sure that there are far more people outside with this problem.


    In this case, apple is acting really bad as they are ignoring the customers. I tried to solve the problem through the support several times, but all I got was "you have guarantee, why don't you send your iMac in?" When I replied that it won't solve the problem, because it appears that this is a software issue and all the other Macs from this generation will have the same problems, I got the answer: "then I'm sorry, but I can't help."


    Apple, PLEASE do something about this issue!!!


    I'm slowly getting really upset...

  • Eric Root Level 9 (50,234 points)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Or you can use your Apple ID to register with this site and go the Apple BugReporter. Supposedly you will get an answer if you submit feedback.

    Feedback via Apple Developer

Previous 1 2 Next