9 Replies Latest reply: Oct 17, 2006 3:22 PM by Tom Gewecke
Penguhwin Level 1 Level 1 (0 points)
I received some e-mail yesterday letting me know the RSS link on my webpage doesn't work.

After consulting iWeb help, I learned that since I'm not using .mac, I need to specify my server name for the links to work correctly (as a default, the page was linking to my desktop files, which obviously wouldn't work).

Okay. So in publishing my webpage, I typed in: http://www.mysitename.com and assumed all would be well...

Nah.

Now, when it publishes, the link turns into:

http://www.mysitename.com/mysitename.com/News/rss.xml

Which won't work.

I tried just typing in http:// and http://www. but none of these will give me the line I need.

Is this a bug, or am I doing something wrong? The solution seems very straightforward - but it isn't working.

Thanks!

iMac 17" Intel, Mac OS X (10.4.6)
  • Tom Gewecke Level 9 Level 9 (74,710 points)
    Okay. So in publishing my webpage, I typed in:
    http://www.mysitename.com and assumed all would be
    well...

    Nah.

    Now, when it publishes, the link turns into:

    http://www.mysitename.com/mysitename.com/News/rss.xml

    Which won't work.


    Is your site inside iWeb perhaps named "mysitename.com", but you did not upload the folder with this name to your server (but only its contents)? If so, reupload the entire folder and the index.html published alongside it.

    In any case, it would help if you would provide the url for your site and the name it has inside iWeb.
  • Penguhwin Level 1 Level 1 (0 points)
    Thanks, Tom
    I think you hit the nail on the head (my site is dougsulpy.com, by the way).
    I didn't realize when I was publishing my site to my desktop that it saved a folder under the site name, and ALSO an index.html file alongside it.

    This brings me to my next problem/question (beyond the rss feed issue) ... I'm uploading these to my godaddy server (using their internal FTP client). Thus, my directory on godaddy looks like this:

    (folder) dougsulpy.com
    (folder) home_files
    (folder) stats
    (file) index.html

    with the first and last being my iWeb material, and the other two being godaddy internal folders.

    However, if I type in my website name, it automatically looks for:

    http://dougsulpy.com/Home.html

    ... which isn't there, and gives me a "file not found" error.

    If I look for dougsulpy.com/ THAT works, but the home page it brings up is:

    http://dougsulpy.com/dougsulpy.com/Home.html

    which doesn't seem very tidy.

    My intuition is that all of the stuff in the iWeb dougsulpy.com folder should be in the directory that holds the folder itself (since this would include the "missing" Home.html file that would work) - but this leaves the problem that there's ALSO an index.html file WITHIN the dougsulpy.com folder, leaving no place for the "outside the folder" index.html file that iWeb saves when I publish the thing to my desktop...

    I've asked Godaddy about this (i.e., just WHAT should go in that main directory), and their general answer was: "Gee. Never saw that before."

    Hopefully, you or someone else out there can help.

    Thanks!
  • Tom Gewecke Level 9 Level 9 (74,710 points)
    Don't use godaddy's internal uploading junk, use a real ftp program. Suggestions can be found here:

    http://homepage.mac.com/thgewecke/iwebserver.html

    Upload just two items, the entire folder dougsulpy.com and the index.html published along side it. (Inside dougsulpy.com should be an index.html, home.html, and a folder called called home_files.)

    The structure on Godaddy has to be the same as the structure on your drive. Using Fetch or another real ftp program should let you do this very simply.
  • Paul White Level 1 Level 1 (5 points)
    I had to visit the site because I was curious as to what an "Ulpy" was ... now I know.
  • Yogi Ev Level 1 Level 1 (0 points)
    Did you ever solve this dilemma? I am having the same exact problem on my website. I was relieved to see your posts. But I noticed, you never got the answer to the double-file name in the path question. My site is www.yogiev.com and i'm having the same problem with the RSS SUBSCRIBE button, it wants to link to www.yogiev.com/YogiEv/blog.xml. i called GoDaddy support and got the same response. that they've never seen that problem before. obviously they didn't talk to you!

    as far as the other guy's suggestion to pull the entire folder YogiEv along with the index.html file onto the ftp site, i got the exact same problem you were having, i.e., when i'd go to my site i'd be taken to www.yogiev.com/YogiEv/{page-name}. it's not tidy indeed. and it was causing other problems on my site. other people when they'd navigate to www.yogiev.com they couldn't get on the page. when i originally called GoDaddy about this, they said, "no, don't drag the YogiEv folder itself onto the ftp site, just select all the files inside the YogiEv folder and drag the files onto the ftp site, there shouldn't be a master folder on your site called YogiEv because your site is called YogiEv.com"

    so my site now loads cleanly for everyone who visits, but the RSS SUBSCRIBE button still links to the file in my hard drive path, not the url itself. so did you solve this?? can anyone solve this???

    thanks man,
    ev
  • Tom Gewecke Level 9 Level 9 (74,710 points)
    and it was causing other problems on my
    site. other people when they'd navigate to
    www.yogiev.com they couldn't get on the page.


    The only reason that would happen is that you did not upload the index.html file which is published alongside the folder which has the same name as your site does inside the iWeb app.


    when i
    originally called GoDaddy about this, they said, "no,
    don't drag the YogiEv folder itself onto the ftp
    site, just select all the files inside the YogiEv
    folder and drag the files onto the ftp site, there
    shouldn't be a master folder on your site called
    YogiEv because your site is called YogiEv.com"


    If your site inside iWeb is called YogiEv, then you must indeed upload that folder, along with the index.html file published alongside it, and the Godaddy comments are simply wrong.


    so my site now loads cleanly for everyone who visits,
    but the RSS SUBSCRIBE button still links to the file
    in my hard drive path, not the url itself.


    The only reason it would do this is that you failed to type http://www.yogiev.com in the box when you published to a folder. However, looking at your site, I see this is not the case, the button does not link to your hard drive. Your only problem is failing to upload the YogiEv folder and its associated index.html

    I think everyone else has been able to fix this by uploading the right stuff, using a real ftp program.
  • Yogi Ev Level 1 Level 1 (0 points)
    hey tom, thanks for your reply. i'm gonna do as you suggest, right now. i'll pull down the entire site, and repost it w/the main folder and the index file published alongside the folder (i know exactly what you're saying), and will report back. best, evan
  • Yogi Ev Level 1 Level 1 (0 points)
    hey tom, ok i did what you said. now the RSS feed does indeed work, but when i navigate to yogiev.com (make sure to clear your cache before you do this), the first time i did it thru a bookmark which was to http://yogiev.com/home.html and i got an error message saying there was no such page.

    then i went to www.yogiev.com and what loaded (same as the other guy who posted here the original issue) is www.yogiev.com/YogiEv/home.html.

    i'm wondering why i have to have the folder-within-the-domain when people come to my site... and i think some people are going to have trouble connecting to the page based on my prior experience... that's why GoDaddy told me not to publish the folder, just its contents directly to the ftp site... so the sub-folder wouldn't appear in the path... but that's what makes the RSS link have trouble...

    so in short it looks like i'm having the same issue as the other guy... either there has to be the subfolder in the path, or the RSS feed doesn't work... and both options aren't ideal.

    i am using a real ftp program. cyberduck.

    thoughts/suggestions? thanks man.
  • Tom Gewecke Level 9 Level 9 (74,710 points)
    when i navigate to yogiev.com
    (make sure to clear your cache before you do this),
    the first time i did it thru a bookmark which was to
    http://yogiev.com/home.html and i got an error
    message saying there was no such page.


    Of course you did. Your site structure is now correct, so the old bookmark is not correct.

    then i went to www.yogiev.com and what loaded (same
    as the other guy who posted here the original issue)
    is www.yogiev.com/YogiEv/home.html.


    That is exactly what should happen. By the way, that other guy posted last May and he never said his problem wasn't solved.

    i'm wondering why i have to have the
    folder-within-the-domain when people come to my
    site...


    That's just the way it works. It's up to you to choose between having YogiEv show up in the browser address bar and a working feed, or not having it there and a non-working feed. There are ways to have a working feed and not have YogiEv if you want to start messing with your code every time you publish and before you upload, but I don't see the point of it.


    and i think some people are going to have
    trouble connecting to the page based on my prior
    experience...


    I don't see how that could happen now, but if it does, come back here right away. Of course they have to use your basic url, www.yogiev.com, and not an old bookmark based on the wrong file structure.