11 Replies Latest reply: Jun 26, 2014 7:09 AM by AsuraSunil
Newham Bridge Administrator Level 1 Level 1 (0 points)

Hello. I wanted to add a greeting message to a volume when users connect to it. Unfortunately I made a few typos when typing the message and no matter how many times I change it it keeps displaying the same message.

 

I've tried stopping and starting the service, restarting the machine, deleting the message entirely, deleting the share point entirely... There's nothing that I can do to make this message go away.

 

Any thoughts?


Mac mini Server (Mid 2011), OS X Server
  • FromOZ Level 2 Level 2 (405 points)

    You could look at it in the Server app however if you don't mind getting into the terminal you can run this command (copy/paste it)

     

    N.B. All the commands in the different font below are one line. The Apple forum software splts them when displaying. Copy/paste them as one line.

     

    sudo serveradmin settings afp:loginGreeting

     

    type in administrator password when prompted.

     

    You will/should see something like this

     

    afp:loginGreeting = "Your message you want to have go away"

     

    To reset it run this command

     

    sudo serveradmin settings afp:loginGreeting = ""

  • Newham Bridge Administrator Level 1 Level 1 (0 points)

    Thanks for this. Something I didn't realise that this message showed whenever anyone connected to the server, not just when the connected to a sharepoint.

     

    I thought that this message was getting applied to a specific sharepoint but I found that it's applied to the whole server.

  • CdaveC Level 1 Level 1 (0 points)

    Great info FromOZ!! Any chance you know how to disable this greeting all together? I'm running 10.8.2 server and I can't seem to find the switch to disable the message alltogether. My users are seeing a generic welcome message when they mount thier home directories.

  • dave_reed Level 1 Level 1 (0 points)

    Alas, this didn't fix it for me.

     

    I am using SERVER 2.1.1

    In the File Sharing section, I selected a specific share and activated the Edit Greeting... feature in the Cog Wheel drop down menu (thinking this would apply a specific message to that share only).

    I immediately discovered that the greeting applied to all users logging into any share on that server.

    I returned to the share and removed the text from the Edit Greeting window, leaving it blank.

    All users continued to get the greeting (for any share point)

    I then removed the share.

    The greeting persists.

     

    Hoping for a guru here!

     

    Cheers

  • simonc1 Level 1 Level 1 (0 points)

    I also have this problem. Tried removing the text from all AFP shares however I still get a greeting pop up whenever my laptop begins a Time Machine backup. Very annoying.

  • Jonathan Tom Level 1 Level 1 (0 points)

    I just wanted to chime in here to say that I'm having the same issue as the OP. I would love to say this solved the issue for me but the command:

     

    sudo serveradmin settings afp:loginGreeting = ""

     

    Simply returns the old greeting as if I was querying what the message was. I can use the command:

     

    afp:loginGreeting = "Your message you want to have go away"

     

    Which appears to have changed the message but when you connect to the share point it still displays the old message. I've also tried removing the share and re-adding it to no avail.

  • JustDrewIt Level 1 Level 1 (0 points)

    CdaveC wrote:

     

    Great info FromOZ!! Any chance you know how to disable this greeting all together? I'm running 10.8.2 server and I can't seem to find the switch to disable the message alltogether. My users are seeing a generic welcome message when they mount thier home directories.

     

    The problem is the server.app isn't removing the following file when the greeting is erased in the GUI. This is a work-around until apple fixes the problem. This command will kick everyone out of their network shares so it may need to be run during off hours. It worked for me in OSX 10.8 using server version 2.2.1

     

    Run the following from terminal after closing out of the server.app:

     

    sudo defaults delete /Library/Preferences/com.apple.AppleFileServer loginGreeting

     

    killall AppleFireServer

     

    Relaunch the server app.

  • marcuskyd Level 1 Level 1 (0 points)

    Did JustDrewIt's terminal commands work for anyone?  I'm having this problem too.  Newcomer here.

     

    thanks

    M

  • havinabubble Level 1 Level 1 (135 points)

    THANK-YOU! JustDrewIt

     

    having just migrated from an old server to a new 10.9.2 Mavericks, Server 3.1

     

    it turned on an annoying User greeting... which I couldnt find the setting for anywhere in the GUI

     

    Your terminal commands turned it off, FINALLY!

     

     

  • havinabubble Level 1 Level 1 (135 points)

    marcuskyd wrote:

     

    Did JustDrewIt's terminal commands work for anyone?  I'm having this problem too.  Newcomer here.

     

    thanks

    M

     

    YES!

     

    having closed out the app, sudo defaults delete removed my greeting

     

    killall (didnt do anything "No matching processes")

     

    but the problem was gone when I Relaunch the server app.

  • AsuraSunil Level 1 Level 1 (10 points)

    Thanks for the fix! My users will be happier now!