3 Replies Latest reply: Jan 20, 2013 9:35 AM by BDAqua
nadiafromvictoria Level 1 Level 1 (0 points)

Okay I'm having a bit of an odd problem. The mac I am using is my grandparents and it's the first time I'm using it in about a year and I had not experienced this problem that year before. I decided I had wanted to put some photos up on this mac from my camera and as per usual I I used the USB cord to do so, I then couldn't find it on my desktop or on my finder, I then started swapping the cord with USB slots that I had known were working, still nothing, I also tried different USBs, still nothing.  After a while I just checked a lot of forums to see what I can find, now everything is ticked in my sidebar preferences, I've checked everything. I also went to my utilities folder to see if I could find it and mount it, still couldn't find it. I started to believe that my computer just couldn't find USBs until, I checked on the 'more info' when you go to 'about this mac' and to my surprise under USB it says 'canon digital camera' Can someone please help me understand why  my computer would be finding the USBs however not allowing me to access them.


Please go a little slow for me as well, I'm not very used to macs at all.


Mac OS X (10.5.8)