7 Replies Latest reply: Jan 26, 2013 10:20 AM by UptimeJeff
joshakafergie13 Level 1 Level 1 (0 points)

so i had a website hosted from my osx server and i had bought the domain name from godaddy it worked great but i desided to instead of hosting it on my osx server to just host it on  godaddy so i turned to server off and added the domain to my godaddy account hosting and now it works but one problem all computers can veiw the website but mine. i think it has somthing to do with the fact that my mac was the one hosting it. but if i go to my browser and go to my wesite i get a error but than i go to any other computer and it works great help please

iPhone 4S, iOS 6
  • Strontium90 Level 4 Level 4 (3,545 points)

    You are referencing the DNS service running on your machine.  Two possible solutions.  Open Server.app and stop the DNS service.  Now, if your machine is doing more than hosting web sites, then this may cause more hard than good.  Second option, go to System Preferences > Network.  Select your network interface and review the servers listed in your DNS settings.  My guess is you will see or your machines IP Address as the first DNS server.  Remove this.


    The issue is that when your machine asks for www.yourdomain.com, it is asking itself for the location and the answer is your own machine. 

  • joshakafergie13 Level 1 Level 1 (0 points)

    I shut the server down and all and still didnt work so i uninstalled server. still didnt work changes networks still no good. im just not sure how to fix this help please

  • capaho Level 4 Level 4 (3,650 points)

    As Strontium90 mentioned, you most likely have DNS configured on your Mac such that it is still hosting the domain.  You need to delete the zone records for the domain from the DNS settings in your server before it will look for the domain remotely rather than locally.

  • joshakafergie13 Level 1 Level 1 (0 points)

    how would i go about doing that??

  • capaho Level 4 Level 4 (3,650 points)

    Open Server app, go to the DNS settings and then delete all entries for the domain.

  • joshakafergie13 Level 1 Level 1 (0 points)

    i did still nothing

  • UptimeJeff Level 4 Level 4 (3,390 points)

    A couple ideas


    check our /etc/hosts file, you might have an entry for your domain.

    sudo pico /etc/hosts

         do you see any entries for your domain? If so:

         edit the file by navigating with the arrow keys, delete the line

         with your domain. Hit ctrl-x when done (enter 'y' to save the change)


    Clear your DNS cache

         dscacheutil -flushcache


    Try a different DNS server, go into your network settings (In System Preferences)

    Go to Ethernet or Wifi (whichever you are using), click Advanced and under the DNS tab enter:

    Make sure no entries are ABOVE it.


    If none of this works, send the results of these commands:

         cat /etc/hosts

         cat /etc/resolv.conf

         dig +short mydomain.com   (replace with your domain)

    The results of these should point us in the right direction.