10 Replies Latest reply: Jun 12, 2014 12:31 AM by William Donelson
amtpict Level 1 Level 1 (0 points)

This has been discussed and posted in various ways here, but I haven't seen/found a solid solution yet which might be out there.

Has anyone figured out the solution to a USB3 drive ejecting on it's own?

 

My staff's OWC USB3 external portrable hard drive keeps ejecting during any operation: time machine, Carbon Copy, Lightroom, importing, moving files, etc. 

 

Attached is a screen shot of the warning box that comes up when the drive ejects itself.

Screen Shot 2013-01-18 at 10.47.28 AM.png

 

COMPUTER:

The machine is a 2012 NON-Retina MBP.

OSX 10.8.2

 

EXTERNAL DRIVE:

The drive is an OWC Mercury Elite On the Go drive: USB3 only

http://eshop.macsales.com/item/Other%20World%20Computing/MSU37750GB16/

 

We have used the drive, and cable on my 2011 MBP, OSX 10.7.5 with only USB2 on my machine, and it runs perfectly fine under all conditions.

 

ATTEMPTED FIXES:

Repaired disk permissions

Disk Warrior

Defrag

All Updates for OSX

Re-install OSX

All updates for 2012 MBP

 

Taken to Apple "Genius" bar twice.  They confirm the failures.  Initially blamed the drive/enclousure/cable.  Then blamed that there were firmware and other updates that would fix it....which they did not. 

 

YET TO ATTEMPT :

Creating a 10.7.5 boot partition on the 2012 MBP and test that.

Trying a powered external drive on the 2012 MPB

Trying a FW800 drive

 

Any thing else I am missing?  Trying to avoid having to send it into Apple Care and be without a needed machine for week+, and concerned that like others, it won't be fixed anyway.

 

Appreciate your thoughts.


MacBook Pro, Mac OS X (10.6.8)
  • amtpict Level 1 Level 1 (0 points)

    wooooowwww.  no one has resolved this, or had this issue?

  • ctyankee11 Level 1 Level 1 (5 points)

    I'm also having this issue with new Sans Digital Towerraid+ TR4U+B.  Drives disconnect after 10 minutes of non-use.  I don't have this issue with Newer Tech.: Guardian Maxximus in JBOB mode using Firewire 800 port attach.  Drives disconnected and connected correctly after sleep.  I've tried all the support remedies; cable changeout, etc.  Sounds like Disk enclosure issue. 

  • amtpict Level 1 Level 1 (0 points)

    Thanks for chiming in here with your experience.  Sounds like you are using some serious back up systems that seem like there shouldn't be any issues at all.  I am not sure if those drives and enclousures are powered drives, or bus power?

     

    I am surprised that those drives/enclousures also did the same thing.  Interesting. 

    Apple also thought the issue lie in the enclousure, and not the board or ports.  I have a little trouble believing this as the manufacturer builds the best enclousures to ensure absolute compliance with the parameters set out BY APPLE for their computers, as well as the manufacturer of the boards/ports, (I think is intel that made the USB3 board?).  Hearing that it happens to so many others, of various makers and drives, etc, leads me to believe that it is either a port issue not being relegated enough power to handle the swings in data transfer and the power required for it, or it's a firmware issue not dealing with power allocation properly.

     

    As I stated, the drive worked flawless on the 2011 machine, in USB2 mode, no problems at all. 

     

    I am glad to head that your FW800 would at least work properly.  I am thinking that is the only route to go at the moment, or having to use a dedicated DC adapter to power the drive.  Very frustrating that SOMETHING isn't working as it is advertised: whether it's Apple and not building or properly supporting the proper board/ports, or OWC for building an enclousure that won't work properly because the ports won't work properly.... know what I mean? 

     

    Thank you again for your reply.  Best of luck.  Will let you know what I find out.

  • SlickRick Level 1 Level 1 (10 points)

    I have something similar on a brand new iMac 27" i7 top of the line model.  I bought a USB 3 enclosure from OCW for a 120 gig SSD. I was using it as the cache drive for Photoshop CS6.  It began to display the same issues you are describing. I brushed it off and blamed the cheap enclosure I purchased.  This all occurred 1 week ago on 1-22-2013.

     

    On Saturday 1-26-2013 I was backing up a sweet sixteen shoot via time machine connected to the USB3 port and the drive ejected mid way of a 70 gig back up. I found that strange because I've never had a problem with that drive or the enclosure it's in. (By the way this is a USB2 enclosure)  I tried it 3 more times and the same issue occurred.  I figured it was the cable and switched it with another USB cable and this time it worked.

     

    Not thinking much about I assumed the problem was the cable.  The next morning I realized I still had one 8 gig compact flash card in my camera and I needed to back that one up.  This time I used my USB 3 RAW STEEL UDMA card reader to ingest the work. There were only 20 images on the card. During import the compact flash drive froze on the third image. I had to force quit and redo the import again.  It took 3 times before I had no issues importing the images.  I could not figure out what the **** was going on until it hit me. 

     

    During my trouble shooting I realized the 3 drives were, when they ejected themsleves, connected to the same port in the back of my iMac.  The second one closest to the SD card reader port in the back.  That was the free port I kept switching to use these different peripherals.

     

    I need to do a little more testing but I'm almost certain something is wrong the the USB3 ports in the back of the new computers. Never had these issues with my late 2009 iMac. 

     

    The last thing I want to is haul this machine into Apple after it took me 4 days to get it set up the way I use it for my Photography business.

     

    Disappointed big time!

     

     

    Screen Shot 2013-01-29 at 10.42.09 AM.png

  • amtpict Level 1 Level 1 (0 points)

    Huh.  That's really interesting, Rick.  I am surprised it does this will nearly all USB3 connected devices that you have!  I would think high load and high wattage draw functions like external drives on a back up routine or as a cache disk like you describe would indeed cause a trip...but a card reader?  That just seems very off.  I can't imagine that it's on every single machine as well...but boy it sure seems common to some extent on various machines. 

     

    We are at the stage of using another external enclousure with USB3 on it, as well as FW800.  We are also testing a USB2 cable on the enclousure to see if that will change a result at all.  Yes, slower data transfer, but again, this is just for testing. 

     

    As you mentioned, on one year previous models it seems to be no issues at all in any capasity.  I just have a wonky feeling that the USB3 ports themselves on the board, or the firmware driving them are just not properly engineered and programed.  I have not heard or seen people with USB3 drives and ports in the PC world as of yet.  Not saying they aren't out there, just no personal experience with it yet. 

     

    I also run a photography business, and I can feel your pain man! 

     

    Please do keep in touch with me as you test more, or hear more.  Appreciate your input here.

     

    Best of luck!

  • amtpict Level 1 Level 1 (0 points)

    Well, we figured it out after extensive testing.  It was the cable. 

    Now, we changed the cable in step 3 or 4, with another USB3 cable, but it had also failed. 

    The cable was from another manufacturer entirely, but same length and same specs.

    After trying every other avenue possible, and on the door step of Apple to ship back, we tried a DUAL USB cable: one that was a pig tail of USB3 & USB2 that terminates into USB3 mini/main plug.  It came with my Bare Drive adapter. 

     

    This worked like a champ: both as USB2 and USB3:

    Back up

    File Transfer

    Running off of the external drive,

    etc

     

    SO, if you are having issues and ejecting drives see if you can get ahold of a physically larger or double duty cable and test with it first.  Not sure why the OWC was not substantial enough to function on specs, but there you go. 

     

    Thanks all for the input.

  • William Donelson Level 4 Level 4 (2,495 points)

    USB3 radiates the same frequencies used by WiFi and many wireless products, and it also susceptible to them.

     

    USB3 is a terrible hack, and it's designers should be shot. I have wasted perhaps 30-40 hours trying MANY USB3 hubs; none of them are remotely reliable.

     

    If you must use USB3, use short best quality cables, and try to put them and your USB3 devices far away from otther WiFi or wireless items.

  • Fergus7 Level 1 Level 1 (0 points)

     

    I just got a new IMAC and experienced the same issue with a RAID 10 array with 4 drives spontaneously disconnecting in the middle of a data transfer with the message "you should eject disk properly, etc. etc." message.

     

    As many others I tried all the obvious solutions. Different cables, different drives, etc. Then I read something about radio wave interference from wireless keyboards. Well, I don't have wireless keyboards or mice (don't like them) but still, it stuck in the back of my mind.

     

    I did find that a USB 2.0 cable with noise suppression dongles at each end worked just fine, if a bit slowly. Anyway, I found an old set of ferrite couplings that were made for video cables back in the day and placed one set at each end of the USB 3 cable. I then moved my RAID array as far from the computer as possible and plugged it all back in. The problem has not reoccurred even with the transfer of very large folders of files from a networked PC RAID.

     

    Just a thought but it seems to have worked for me although the fact that this sort of thing is necessary does not speak well for Apple.

  • Thefiglah Level 1 Level 1 (0 points)

    WILLIAM DONELSON HAS IT!!!!! ( at least for now)

     

    I JUST STARTED GETTING THIS ISSUE AND FOR THE LIFE OF ME, I WAS BAFFLED.

     

    I was getting proper file transfers 50% of the time, not good. This was on film shoot utilizing Shot Put Pro 5, and I was extremely frustrated as for weeks prior I had a 100% success rate. I couldnt figure it out, because nothing had changed in my work-flow, no updates, no new OS, same hard drives. The only thing that had changed was that I had just started using a MAC magic mouse with my mac book pro, Maverick 10.9.2. As soon as I took the magic mouse away and disconnected it, so returned my 100% success rate.

     

    Its hard to judge and I am still not totally sure why it happens, but it seems that bluetooth/wifi/hotspot tech interferes with USB 3 cables and devices. The cables I had been using with my Glyph 4tb drives are quite thin and flexible, not very insuated at all, that might play a role in why some cables and drives are more affected than others.

     

    Thats all I have for now.

     

    Apple, what is going on here!!!!

  • William Donelson Level 4 Level 4 (2,495 points)

    I am now also shielding cables and boxes

     

    http://www.amazon.co.uk/Direct-Products-Shielding-Impedance-Conductive/dp/B00DDV G340/

     

    with this copper tape from Amazon.