4 Replies Latest reply: Jan 20, 2013 12:03 AM by Beatdoctor
Beatdoctor Level 1 (0 points)


My mid 2010 mac pro refuses to sleep.  It may be to do with some universal audio drivers installed with a recent hardware interface I've added, but maybe not.

I'm running 10.6.8 on a 2x 2.4 GHz Quad core Intel xeon with 32 GB RAM.

Whilst I don't know how to use terminal very well, after reviewing similar queries I typed the following string in terminal;

kextstat -kl | awk ' !/apple/ { print $6 $7 } '

And got this response;







my launch agents (in my user directory);






launch agents on Macintosh HD;







Launch daemons;



















Can anyone please help me with this?


Mac Pro (Mid 2010), Mac OS X (10.6.8)
  • Beatdoctor Level 1 (0 points)

    can't delete this - posted in error

  • Dale Weisshaar Level 6 (15,860 points)

    Can you tell us a little more about the recent installation? What is it exactly and are things compatible with 10.6?

    Here's my sleep faq.

    This is for a Mac that won't sleep.

    Here is Apple's  KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file. If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password). If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Some have resolved sleep issues by downloading the  Combo update,  from this site (yours may be corrupt), not Software Update  disconnect all firewire + USB devices except keyboard + mouse,Repair Permissions, re-install update, Repair Permissions again + try

    USER TIPS……..

    Check in System Preferences > Energy Saver is "Wake for network access" checked? If so, uncheck it.

    One user reported, " I couldn't make my macbook pro to go to sleep because I had my wireless headphone receiver still plugged in. I unplugged it and then it went to sleep."

    Also, if you have an External Western Digital (WD) hard drive and have installed  WDDMService and WDSmartWareD on your Mac, it may not sleep. Fix is to un-install those....you don't need them to use the drive.

    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    One provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute. After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    "I  have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps. Check the printer queue!"

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE

  • John Galt Level 8 (45,943 points)

    Failure to sleep is always due to a process keeping the system awake, but determining which is the challenge.


    • A first simple step is to create a new, temporary user account. Log out of yours and log into the temporary one. Determine if it sleeps then. If it does then you have a login item that is preventing sleep. System Preferences > Users & Groups > Login Items.
    • Whenever you suspect a problem related to power, including sleep, an SMC reset is also recommended.
    • Active Spotlight indexing will prevent sleep. Wait for it to complete.
    • Check your Sharing preferences for anything that could permit an active network connection.
    • Energy Saver "Wake for network access" can prevent sleep, but unchecking it will prevent the ability to remotely access a sleeping Mac over a network. A normally functioning Mac will sleep according to Energy Saver, but will wake periodically for network access, after which it will return to sleep according to the settings in Energy Saver.
    • Unfinished print jobs will prevent sleep. If a print job is queued, but if the printer is off or the connection to it is lost, the Mac will stay awake forever waiting for the printer to return.
    • Safari pages that periodically refresh themselves are very common. This will prevent sleep.
    • Frequently checking for new mail may prevent sleep. Change Mail's preferences to check for new mail less frequently.
    • iTunes and iPhoto sharing will prevent sleep.
    • Active Bluetooth devices will prevent sleep.
    • Active USB devices will prevent sleep.
    • Using Time Machine over a network can prevent sleep.
    • There are plenty of third party utilities designed to prevent sleep. One may not have been completely uninstalled.
    • Quit the process with the name powerd in Activity Monitor. It will re-launch on its own.
    • Any number of "anti-virus" utilities can prevent sleep, along with other miseries. Get rid of them.


    Mac OS X: Why your Mac might not sleep or stay in sleep mode: http://support.apple.com/kb/HT1776


    Good luck!

  • Beatdoctor Level 1 (0 points)

    Thanks so much Dale and John.


    Fortunately the issue has resolved for now by unplugging a firewire 800 peripheral ( an SSL Duende DSP plugin processor, that wasn't on or being used).

    The problem did occur again after a time of having everything plugged in again, but seems to be gone with that particular firewire cable unplugged.  Funny thing is, I've had that plugged in for years now with no problem. 

    The new hardware interface I mentioned earlier is a UAD Apollo (  http://www.uaudio.com/interfaces/apollo.html )

    I never use fax,  nor do I have a printer attached.  I have now turned off the printer sharing tickbox in sharing prefernces tho.  Similarly 'wake for network access' was off.

    disc permissions repair was previously unrewarding.


    So I'll see how it goes.

    Thanks again for your help!