Previous 1 2 Next 16 Replies Latest reply: Feb 14, 2013 7:46 AM by wayne mitzner
mkmichaelmk Level 1 (0 points)


maybe someone has a tip:


I have imported some very important Jpegs from a Nikon D90 to Iphoto. Then right click and edit in external photo editor (Photoshop). After finsihed editing, hit the save button. Closed the photo in Photoshop, and returned to Iphoto, where the new enhanced image show up.


Up to here "everthing normal".


Now, opening a day later Iphoto, I can see the thumbnails of the event (as usual) , BUT when clicking on them, a heavy reduced file size picture shows up for a second, followed by a heavy zoomed in part of the Image. First I thought, okay, at least the high resolution image is still there, and I only have to zoom back with the slider to get it to normal view - but this is not possible. It stays this size.


To save the pictures, I used the function "show edited Picture"in FInder, and so I started Copying them to a separate Folder, in fear i might loose them.


So, pictures are saved, but library is somehow not working right. I also used the "create new thumbnails" function when starting Iphoto with command/alt. But it did not improve anything.


Any idea how to fix it?




Macbook Pro, none
  • Terence Devlin Level 10 (137,945 points)



    There have been a couple of reports of this for images edited in PS and it seems to be a display issue rather than a problem with the actual files.


    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • mkmichaelmk Level 1 (0 points)

    Dear Terence,


    thanks for your superfast help - i tried it, but everythingworks fine in the new library!


    But: One thing is very strange, and I think it might lead us to the key problem:


    I made a new library, and imported Canon S90 Jpegs and Nikon D90 Jpegs for a test into it.


    Now, both are right-click edited in PS, and when hitting the "save button" in PS there is a major difference:

    With Canon Jpegs a pop-up opens asking me for the file size / compression quality. With the Nikon Jpegs, there is no pop-up. It saves nonetheless the file, and it shows up correctly in Iphoto.


    Maybe it has to do with the problem...

  • mkmichaelmk Level 1 (0 points)


    I created a new library, imported some jpegs, and edited them from Iphoto in PS... and first everything was fine.

    The files showed up correctly in Iphoto, and could be zoomed in all the way and back.

    And now 1 hour later - the same problem !

    All edited pictures are showing up in "Megazoom" when clicking on them in Iphoto!

    Help urgently needed!

  • Terence Devlin Level 10 (137,945 points)

    Given that it worked for a while and then the problem recurs, it may be a cache issue.


    Quit iPhoto and try delete the iPhoto Cache from




    and restart the app.

  • mkmichaelmk Level 1 (0 points)

    Dear Terence,


    thanks for your help - i cannot find this file, it simply does not exist (?)

  • Terence Devlin Level 10 (137,945 points)

    What version of iPhoto and the OS?

  • Old Toad Level 10 (135,487 points)

    If you're running Lion or Mt Lion that library folder will be invisible.


    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.


    Once you make your library folder visible you'll be able to find and delete the iPhoto cache.



  • mkmichaelmk Level 1 (0 points)



    thank you, now the folders are visible! I deleted the cache.db and restarted - but still the same problem. All images edited via right click in Photoshop, show up as a megazoom when clicking on them.

    Don´t know what to do now hope is gone ...

  • Old Toad Level 10 (135,487 points)

    Log into another user account on your Mac and see if the problem is repeated there.

  • wayne mitzner Level 2 (400 points)

    i think i have a related problem.  After upgrading to iphoto 11, when i now go to my iphoto, ALL my pictures are greatly reduced in size.   like 250K or so.  They all used to be about 2 mb.   What is going on?  Has iphoto destroyed all my pictures?   Please help. 

  • Terence Devlin Level 10 (137,945 points)

    That's not the same problem. iPhoto doesn't destroy your pictures. It sounds like you're accessing the thumbnails that iPhoto makes for display. Ever import one library to another?

  • wayne mitzner Level 2 (400 points)

    Hmm, yes, when i got the new iMac i imported the old pictures.  Maybe the thumbnails came in separately.  I'm not at home now, but will check later to see if there is another set of pictures at full size in the iPhoto library.


  • Old Toad Level 10 (135,487 points)

    How did you upgrade to iPhoto 11?  You didn't import your old library into a new iPHoto 11 library did you? If so that's a big no-no.

  • wayne mitzner Level 2 (400 points)

    yes, i did import it, since that's what someone at Apple told me to do.  The old computer was dead, and i had to import from a backup. 

Previous 1 2 Next