9 Replies Latest reply: Jan 21, 2013 10:57 PM by léonie
barrettdb Level 1 Level 1 (0 points)

I am running Aperture 3.4.3.

 

I had this version running on an Intel MacBook Pro, with its db on an external firewire drive.

 

I purchased a Retina MB Pro, and transferred all apps, etc. to the new laptop.

 

I also purchased a USB3 drive, and transferred my Aperture db from the FW drive to the new USB drive.

 

On my old laptop, I can open Aperture and export, modify, etc. photos from the FW drive.

 

On the new Retina laptop and the USB drive, I can load the db, but if I try to export or do anything, I get a warning that the original files cannot be found.

 

The db on both drives is idential in size and permissions.

 

What file or process have I missed in this updating process???


Aperture 3, OS X Mountain Lion (10.8.2), cannot reconnect files
  • léonie Level 9 Level 9 (65,295 points)

    Is your Aperture library referenced or managed, i.e. are the original image files included in the Aperture library, or does Aperture reference them in a folder outside the library? If the files are referenced, you may need to reconnect them. Select all image versions in the browser and use the command "File > locate Referenced files.,  see: Aperture 3 User Manual: Working with Referenced Images

     

    Do you use the same user name on your new Retina MBP as on your old mac? If not, you may have a permissions problem, because you are not the owner of the files.

     

    Set the flag "Ignore ownership on this volume" on your USB3 drive (you can do that in the "Get Info" panel for that drive, in the "permissions" brick).

    Also I'd recommend to run a permissions repair on the library, using Aperture's First Aid tools, see: Repairing and Rebuilding Your Aperture Library: Aperture 3 User Manual

       (hold down the key combination ⌥⌘ and double click the Aperture library, then select "Repair permissions" from the pop-up menu.)

     

    Regards

    Léonie

  • barrettdb Level 1 Level 1 (0 points)

    Hello, LeonieDF et al -

     

    Thanks for the input - and I should have added more info.

     

    "ignore ownership for this volume" was set. In additinon, permissions were checked and set, and all images are managed in the Aperture library. That's what makes this so frustrating. I will now attempt to totally rebuild the library.

     

    If you have anything else to add - or anyone - that would be terrific.

     

    Thanks,

    David

  • léonie Level 9 Level 9 (65,295 points)

    David,

    how did you transfer the library from your Firewire drive to the USB 3 drive? Did you copy it using your old mac? Could you try to copy using your new account on your new mac, or does the Retina mac not have a Firewire port?

     

    And how is your new USB3 drive formatted? Is it MacOS X Extended?

     

    Léonie

  • barrettdb Level 1 Level 1 (0 points)

    LéonieDF,

    Good points! I transferred the library from the FW800 drive on my older laptop to the new USB3 drive (MacOSX Extended format). I confirmed the size of the files and that when opened, they show (14110 originals).

     

    The new Retina MacBook Pro laptops do NOT have firewire ports. You can use an adapter, and I have one, so it is something I could try...

     

    I've also double checked permissions and everything is read/write (7777), so I'm good to go in that respect.

     

    The challenge for me is that the orginals are in the file/library that I'm using, and all of the data, metadata, etc. is there - and I can add FX, etc. (tried this), but I cannot print or export... (original is offline or cannot be found message).

     

    Thanks for trying to assist me.

    David

  • barrettdb Level 1 Level 1 (0 points)

    Additional: I can open the library in question in iPhoto and export and print.

  • barrettdb Level 1 Level 1 (0 points)

    Continuing additional: I quit iPhoto and as you know, it updates the previews - and when re-opened, now I CANNOT open any image. So, somehow, the library has been corrupted.

     

    Shall I totally rebuild this library? I have duplicates...

     

    Thoughts?

  • léonie Level 9 Level 9 (65,295 points)

    I'd try the following: Create the library on your new drive again.

     

    Connect both drives to your new Retina Mac, the old Firewire and the new USB 3.

     

    Then open the original Aperture library in Aperture on your new Mac,

    • select all images at once  and let Aperture export the images as a new Aperture Library on your USB 3 drive.
    • Then try if you now can open this new exported library with Aperture from your new mac.

     

    Regards

    Léonie

  • barrettdb Level 1 Level 1 (0 points)

    Hey -

     

    This worked like a charm. Thanks!

    DB

  • léonie Level 9 Level 9 (65,295 points)

    You are welcome! I am glad it worked for you.

     

    Léonie