13 Replies Latest reply: May 16, 2014 3:12 PM by pearmacintosh
Louis Jannett Level 1 Level 1 (0 points)

Mein Kalender lässt sich nicht mehr öffnen! Er öffnet einfach nicht und ich muss dann immer auf sofort beenden klicken! Bitte um Hilfe.... Bin am verzweifeln...

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 Level 10 (177,930 points)

    My calendar will not open anymore! It just doesn't open and I must always force it to quit [?]...


    I can't write German. Can you follow instructions in English? You may reply in German, but please use simple words and check your spelling and grammar.


    Google Übersetzer

  • Louis Jannett Level 1 Level 1 (0 points)

    Yes, I can follow your instructions in english! But please help me.

  • Linc Davis Level 10 Level 10 (177,930 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Louis Jannett Level 1 Level 1 (0 points)

    No this did not help. In the safe mode, my Calendar does not open. It is the same. The Calendar flashes but does not open. After that I have to quit the Calendar directly...

  • Linc Davis Level 10 Level 10 (177,930 points)

    Back up all data.


    Quit Calendar or iCal if it's running. Hold down the option key and select


    Go Library

    from the Finder menu bar. A folder will open. From that folder, move the following item to the Desktop, leaving the window open:

    • Calendars
    Note: you're not moving the Calendars application; you're moving a folder named "Calendars". Relaunch the application and test. If there's no change, quit again and put the file you moved back where it was, overwriting the one that may have been created in its place.
    If the application launches after you move the Calendars folder, you have two options: restore the folder from a backup that predates the issue, or use a third-party application such as Calendar Cleaner to try to repair the database.
    If the application still crashes when you remove the database, then the problem is either in a cache or a preference file. Those would be the following (some may not exist on your system):
    • Caches/com.apple.CalendarAgent
    • Caches/com.apple.iCal
    • Saved Application State/com.apple.iCal.savedState
    • Preferences/ByHost/com.apple.iCal.helper.*.plist
    • Preferences/com.apple.CalendarAgent.plist
    • Preferences/com.apple.iCal.Alarm.plist
    • Preferences/com.apple.iCal.AlarmScheduler.plist
    • Preferences/com.apple.iCal.helper.plist
    • Preferences/com.apple.iCal.plist
    • Preferences/com.apple.iCalExternalSync.plist
    • Preferences/iCalExternalSync.plist
    Here * stands for a long string of letters, numbers, and dashes.
    Delete the first group of items and test as above. If that doesn't help, move the preferences to the Desktop and test.
  • Louis Jannett Level 1 Level 1 (0 points)

    Thanks but which is the select ? I hold down alt but then nothing comes...

  • Linc Davis Level 10 Level 10 (177,930 points)

    When you hold down the option (or alt) key and select Go from the menu bar in the Finder, you should see an item named Library in the menu. Select that item. Obviously the words will be in German if you're using the German localization.

  • Louis Jannett Level 1 Level 1 (0 points)

    Thanks but this does not help... Where can I find this 3 items in the first group??

  • Linc Davis Level 10 Level 10 (177,930 points)

    It's not clear where you are getting stuck. Can you open the Library folder?

  • Louis Jannett Level 1 Level 1 (0 points)

    Yes, I can open the Library Folder in the Finder pressing the ALT Key and going to GO. But I can also go in my MacIntoTosh and then Library..

  • Linc Davis Level 10 Level 10 (177,930 points)

    I can also go in my MacIntoTosh and then Library.


    That's not the same folder. Please follow the instructions above.

  • Louis Jannett Level 1 Level 1 (0 points)

    Yeeees it works!!!! Thank you very very very much!!!

  • pearmacintosh Level 1 Level 1 (0 points)

    Hi Linc, I am facing the same problem and tried out all the steps mentioned here - but none fixed it in my case. The problem occurred when I entered a new calender entry and wrote a somewhat lengthy text including numbers and symbols like / into the location text field ("Ort"). Any idea?

    Thank you for your help.

    Macbook Pro OS X 10.9.3 (OS update also did not solve it)