2 Replies Latest reply: Jan 20, 2013 11:08 AM by thegrays
thegrays Level 1 Level 1 (0 points)

I have found many topics on this subject but none which answer my current problem.

 

Setup : MBP 10.7.5 / iMovie 11 - 9.0.8 (1778) and a Sony DSC TX10 camera connecting by Sony USB Cable.

 

When I connect the camera I can see several drives mount : 2 called no name and 1 PMBPortable. Lets ignore PMBPortable and the No Name for DCIM photos and only concentrate on the one which contains the PRIVATE->AVCHD folder.

 

I cannot simply connect the camera, open iMovie and the movies import automatically. While I have been able to import these MTS movies to iMovie in the past just by connecting the camera, no matter how many different ways of power up camera, open iMovie etc I try now,  I still cannot see the camera in "import from camera"- iSight only. iPhoto works but doesnt discover the movies either, and I am sure in the past it has found them and created iMovie or Aperture links.

 

THIS HAS WORKED BEFORE INTERMITTENTLY BUT NOT ANYMORE......

 

I have tried :

1. Recreating the PRIVATE->AVCHD->STREAM folder containing the MTS files on another USB : no result

2. Connecting the camera, turn on the camera (mounts folders) open iMovie, drives mount but with little yellow : import : no result

screen-capture-1.jpg

3. Reboot with camera connected, open iMovie,drives mount as above : no result

4. Copy the PRIVATE (->AVCHD etc) folder to my HD, reformat the card in the camera, connect to MBP, open iMovie , drives mount : no result

5. Copy the PRIVATE (->AVCHD etc.) folder intact  back to the camera, power down,*(camera came up with msg inconsistencies in database and repaired them, whatever they were) reconnect camera, power up, drive mounts, open iMovie, only sees PMBPortable  : no result

6. As above, power down camera, power back up, PMBPortable and No Name mount, open iMovie : no result

screen-capture-2.jpg

 

All the MTS files on the PRIVATE->AVCHD->BDMV->STREAM folder play on VLC no problem, but will not play with quicktime.

 

I have tried so many combinations now I am getting frustrated : I have seen this setup on this macbook work as recently as a few weeks ago.

 

Any ideas what I can try to solve this would be most welcome.


MacBook Pro, Mac OS X (10.7.5)
  • AppleMan1958 Level 7 Level 7 (27,395 points)

    I don't know the answer, so I am just talking out loud.

     

    The thing I would look at is why are there two disk drives named No Name mounted at the same time?

    If could be that your camera has both internal memory and a SDHC card.

    It could be that you have installed a totally unrelated application and the disk image is still mounted.

    If you can get down to one No Name mounted at a time, it might do better. I would try unmounting the one that does not contain the AVCHD clips. 

    If you see the two no names on the desk top, you can drag the one you don't need to the trash. Or Right-click it and choose Eject.

     

    Also, try importing from a card reader rather than directly from the camera.

  • thegrays Level 1 Level 1 (0 points)

    Thanks - for some reason the camera mounts 3 drives on connection

     

    PMBPortable drive that contains self executing Sony software to allow easy downloading and sharing of photos etc (not video) : unmounted

     

    No Name : internal memory is never visible in iMovie : unmounted anyway

     

    No Name : includes AVCHD folder and files - Mounted

     

    No Difference - can see No Name in imovie but still does not recognise the files to import.

     

    Tried also on card reader , same result.