6 Replies Latest reply: Dec 20, 2014 8:58 AM by Jita Is The Answer
puckish88 Level 1 Level 1 (0 points)

Just moved to a new apartment that uses an airport express as a wireless router (instead of the linksys router I had at my old place).  When I turn on my Canon MX870 printer to connect it to the LAN, the network simply does not show up.  All my other devices (multiple other computers, iphone, etc.) have no problem recognizing and connecting to this network, but for some reason it's not showing up on the MX870, and so I cannot get it connected to the LAN.  It is recognizing other networks in my building, just not mine.  Is there somekind of compatitbility or security setting issue with connecting the MX870 printer to a LAN via an airport express?  I even tried turning security completely off on the airport to see if that would do the trick to no avail.  I have installed all drivers, etc., on my computer, but that should not make a difference as the issue is one of simply getting the computer to recognize and connect to the network created by the airport express.  Tried restarting printer, router, modem.  Any help would be appreciated.  Thanks!


MacBook Pro, Mac OS X (10.5.6)