Previous 1 2 Next 15 Replies Latest reply: Dec 22, 2013 7:24 AM by Joel_M
silleme1 Level 1 Level 1 (0 points)

I have an Epson XP-400 AirPrint printer.  At initial setup my ipad 3 found the printer. About an hour later I tried and "No AirPrint printers found" came up.

I fooled around with the Epson iPrint app and the printer is found but when I tried later it was not found. Epson support failed to help.  I am using a PC with Win 7.

  • Joel_M Level 1 Level 1 (0 points)

    I have a similar issue.

     

    Initial setup was fine, but after a few minutes I get the "no AirPrint printers found" message on my 3rd gen iPad. If I switch apps (say, from Notes to Pages), the connection is lost immediately, and I have to turn the printer off and back on to restore the connection. My old MacBook (plastic) seems to print wirelessly without issues. Like you, Epson support was of no help.

  • Jerome.Serpenti Level 1 Level 1 (65 points)

    Hi silleme1 and Joel_M,

     

    Have you confirmed that you are using the same subnet?  In other words, are you sure one of the devices is not logging into the guest network whilst the other is logging into the general network?

     

    You may also try to isolate the issue by trying a different iOS device.  Does this issue also occur with an iPhone or iPod Touch? 

     

    If none of these work, you may resolve your issue by examining your network.  Per example, if you use an Airport Express base station rather than your router, does this resolve the issue?  It may be that your network is not compatible with the protocols used by Airprint.

     

    Kind regards,

  • Joel_M Level 1 Level 1 (0 points)

    I have tried another iOS device: a family member's iPad 2, and experience the same problem. Another XP-400 on a different network (but using similar hardware and the same network protocols, supplied by my local ISP) does not suffer the same problems with either iPad.

     

    This is the second XP-400 printer. The first I returned, assuming it was defective, but the second exhibits the same behavior, as does an HP printer borrowed from a friend.

     

    I tried relocating the printer and wireless router, and temporarily disabling the router's firewall, to no avail.

  • Jerome.Serpenti Level 1 Level 1 (65 points)

    Hi Joel_M,

     

    Then the issue does seem to be with your wireless network.  Although checking your security settings is a good idea, neither that nor changing ports will resolve your issue.  You may wish to contact your ISP to see if they have further troubleshooting steps you can take with your router.  Perhaps it is possible to update the firmware of your router?  Alternatively, you could try whether it works with an Airport Express.  In my experience, this should resolve your issue as Apple routers completely support Airprint protocols.

     

    Kind regards,

  • Joel_M Level 1 Level 1 (0 points)

    I'm sorry, but it is NOT the network. I have tried the printer in question and the iPad in question on another network that currently and successfully has the same model Epson printer and iPad 2 printing via airprint. Those devices work. Mine do not. It might be a printer issue still. Thanks for your help anyway.

  • Austin James Level 1 Level 1 (45 points)

    You should return the printer if it is still under warranty. You might have noticed, people with a similar problem almost always have an Epson printer. I hope I helped!

     

    Austin

  • Austin James Level 1 Level 1 (45 points)

    You should return the printer if it is still under warranty. You might have noticed, people with a similar problem almost always have an Epson printer. I hope I helped!

     

    Austin

  • Joel_M Level 1 Level 1 (0 points)

    Duly noted about the Epson printer. Thanks :)

  • silleme1 Level 1 Level 1 (0 points)

    I have followed all the postings and did try using the Airport Express.  Airprint now  works perfectly leading me to conclude the problem is with Comcast's router.

  • Jerome.Serpenti Level 1 Level 1 (65 points)

    Hi silleme1,

     

    Glad to hear you have been able to resolve your issue.  It is not that there is an issue with this router - it may work perfectly - the router just is not supporting the network protocols that Apple's Airprint relies on.  This is a common occurrence and accounts for - in my opinion - most of the issues with Airprint as you describe them.

     

    Kind regards,

  • NoiD™ Level 1 Level 1 (0 points)

    I have same issue. But I use a LinkSys WRT320N. I'l be damned if I need to buy an Airport Express to fix this. When purchasing this Epson XP-400, no where, not on Apples site nor Epsons site did it say, oh by the way, you may need to purchase a new router..

     

    I my case, It never worked from the start. But just now, turned on printer ran back an reboot router, pressed the button on top of router and then quickly tried to Air Print something. It found it this time and printed!!!! Turned off printer and tried, can't find printer (So apparently it doesn't automatically turn on like it does when email printing?) Turned Printer back on and it found it again. Guess my problem is fixed.

     

    I wish Epson could of just said "Reset Router" "Make sure Printer is on, because it will not wake up to AirPrint" instead of:

     

    Dear Max,

     

    Thank you for contacting Epson regarding your Epson XP-400. It is my pleasure to respond to your inquiry.

     

    Make sure there is not an error on the product's control panel and that there is no memory card inserted in the product. If there is an error message, see the User's Guide for your product to resolve it.

     

    If this did not resolve your issue, please reply to this email for further assistance.

     

    And:

    Dear Max,

     

    Thank you for contacting Epson regarding your Epson XP-400.

     

    I'm sorry for the frustration. If there is no new firmware found, this shows you have the newest firmware already on your printer and your AirPrint issue is not Epson firmware related.

    We can only recommend Apple's support site for troubleshooting as there are no steps or settings on the printer itself to allow or disable Apple AirPrint.

     

    We take your satisfaction seriously and hope that we have helped resolve your issue. If you receive a survey from us, we would greatly appreciate if you could take a few minutes to provide us with feedback about your support experience. Your ratings and comments are extremely important to us.

     

    If this did not resolve your issue, please reply to this email for further assistance. If you have a different support issue, submit a request via our U.S. or Canada Support Site and we will respond in a timely manner.

     

    Thank you again for contacting Epson.

     

  •  Sonia Level 1 Level 1 (0 points)

    your right, its not the network. I can always connect to the printer with the ip address, but not print. Its a bug from ipad. I am sick of this new ipad. wish i never bought it. it has too many problems

  • deggie Level 8 Level 8 (49,575 points)

    It isn't a bug on your iPad. Double click the home button, slide to the left and see if the printer icon is there. If it is press and hold the icon and close it. Reset the printer, iPad and your router and try again.

  • rjcheavy Level 1 Level 1 (0 points)

    I've had the same problem here in Dec 2013.

     

    Epson XP-400 does not show up as an Airprint available device more than once.   Network is fine, printer can be used from Windows the whole time, but sometimes it's found sometimes it's not.

     

    I don't have the answer, but the Firmware on the Printer is fully up to date and even the App from Epson "EPSON Prtiner Finder", only finds it once and a whilte.   I can usually find it by restarting the printer, but as people here have indicated, only once and then it does show up on the iPad or iPhone, OR, the Epson the Finder.

     

    So, my vote is to a bug with the Epson software and I guess I have to find a more reliable Airprint printer.

     

    SO SillieMe and Joel.  It's not your imagination and you had everything configured right...

Previous 1 2 Next