1 Reply Latest reply: May 30, 2013 6:28 AM by USD_Goerlitz
USD_Goerlitz Level 1 Level 1 (0 points)

Hello everyone,
after several weeks of trying different solutions we are stuck with trusted binding / OD binding in Deploy Studio.
We've added several workstations to our computers and they are renamed by a script this works fine.
The problem is that we have to add those workstations to our Open Directory and then add those workstations via OD to several groups.
The workstation is binded but it doesn't bind correctly.
We can see the OD server in the "Users and Groups" as "connected". But it's only bound locally (can only be seen on the workstation)
But it's not binded as we want it to be.
Our goal is that the workstation needs access to the directory (System Preferences -> Accounts -> Login Options -> Network Account Server -> Open Directory Access… --> LDAPv3 ...)
And then we have to use "Edit..."-> "bind" .After that the workstation is added to our OD and we can see it in our workgroup manager and add this workstation to the group.
Is it possible to solve this issue with Deploy Studio?
We've already tried to use "Enable trusted binding" but after imaging a workstation there is only the ouput "An error occured while trying to establish a trusted binding with the server "xxxxx",new attempt in 10 seconds..." and "Invalid credentials supplied for binding to the server"  in the finalize script and the workstation has to be bound to the OD manually.
But the credentials are 100% correct.We are using the login of your OD-administrator account for the trusted binding.
We've also tried to activate trusted binding without any login information in the fields for "Directory Admin", after that there is no error but the workstation has to be bound manually again.
It would be great if there is anybody who has the same issue and maybe solved it or has any idea what to do here.

Sorry if the english description for several "buttons" aren't exactly,we are using a german version of MAC OS X (10.8.2). I hope everything is easy to understand.
Just tell me if you need any additional information about things.

DPS Version: 1.0 RC 135 (121112)

Kind regards



This is my post in the official DPS forums but there wasn't any reply except one that we could use an own OD binding script.

Is there anybody who has a working script?I found one but it has AD inside and I don't know if it's that easy to delete the AD parts from this script.

It would be great if there is someone who could help with this issue.


Kind regards

OS X Lion Server, OS X Server
  • USD_Goerlitz Level 1 Level 1 (0 points)

    We're still looking for a solution for this issue as it still doesn't work.

    We also tried to solve it with this script but it didn't work either:




    computerid=`scutil –get ComputerName`

    dsconfigldap -v -f -a OD_SERVER -n OD_SERVER -c $computerid -u ADMIN_USERNAME -p ‘ADMIN_PASSWORD’

    sleep 10

    dscl /Search -create / SearchPolicy CSPSearchPath

    dscl /Search -append / CSPSearchPath /LDAPv3/OD_SERVER

    sleep 10

    dscl /Search/Contacts -create / SearchPolicy CSPSearchPath

    dscl /Search/Contacts -append / CSPSearchPath /LDAPv3/OD_SERVEROD_SERVER= FQDN of our OpenDirectory

    ADMIN_USERNAME= account used for binding computers manually




    It would be great if there is somebody who could help us with this issue.


    Kind regards