14 Replies Latest reply: Apr 15, 2013 5:40 AM by Ian R. Brown
Ian R. Brown Level 6 Level 6 (18,580 points)

I don't know whether anyone else has noticed this.


4.0.6 flashes every few seconds whilst working. I seem to get a fleeting glimpse of a warning message  .  .  . .  possibly asking about incoming connections.


I've deleted preferences etc. to no avail.


However, when I open the previous version (4.0.5) there is no instability of the interface at all.


I'm using OS X 10.6.8 and don't know whether it's that or something else causing the odd behaviour.


It seems to do the job OK but the flash every 5 seconds or so is rather irritating.

iMac, Mac OS X (10.6.8), Little knowledge... many opinions.
  • Russ H Level 6 Level 6 (18,880 points)

    Ian R. Brown wrote:


    I don't know whether anyone else has noticed this.


    I'm using OS X 10.6.8 and don't know whether it's that or something else causing the odd behaviour.



    FWIW, in one machine I'm running 10.6.8 and have no issues.


    If you don't have it, download and run COmpressor Repair from Digital Rebellion…amd check the trash prefs box.


    Good luck.


  • Warwick Teale Level 3 Level 3 (580 points)

    HI Ian, first place to look is in the /var/logs (console.app) and use the global search for COMPRESSOR.app to see if its a UI issue. It maybe from another components. The logs SHOULD show this error. YOu may have to dig around a abit. Use the 'Find command now in console.app too)


    YOu might want to consider upgrading the OS to something current if you can. 10.6.8 may be stable however the interation of the latest Compressor and Qmaster etc wit hthose frameworks etc in MACOSC 10.6.8 may not be clean.... just a guess too.


    Do you have Little Snitch.app installed and activated on this host? This is usually ok, however Qmaster may be asking the outside world for a look? could be. Little Snitch may have barred him form doing this.. just a thought. Litt;e Snitch message usually stay up in its UI.... just a guess.


    If the job is running and the backend is flashing these messages then search for QMASTER. You may also have DNS error message if your cluster is out hunting for other nodes.


    IF you are using QMASTER (submit with batch), then you might want to check the logs of those services via the SHARE MONITOR... I'd that this is not the source.


    The parms are not this issue me thinks.


    TRy this when you have time if you DONT need QMASTER on another host.


    Step 1: quiesce/ shutdown anything but COMPRESSOR and Qmaster.

    Step 2: turn off / disable you network on your mac. (use system prefs/network/ create a new SETTING "no network" and delete all the NICS.. apply this... = no network.

    Step 3: submit your batch again and determine the results


    See if you still get these flashing messages....


    IF not, then resinate your network (pull up the default system prefs settings for network) and apply.


    Post your results for others to see.


  • Ian R. Brown Level 6 Level 6 (18,580 points)

    Thanks to both of you.


    Russ, are you using OS X 10.0.6 ?


    Just possible it's a clash between the old OS.


    It's not 100% proof but it's highly suspicious when I open the earlier version of Compressor and it's interface is rock solid, then open the latest and get the flash every 5+ seconds. Then open the previous version and once again it's perfect.


    I trashed the prefs to no avail (first thing) .


    Warwick, I've got Little Snitch but as you can see from the above, this problem is limited to Compressor 4.0.6


    I have also tested Compressor Repair to no avail and re-downloaded Compressor.


    So it looks as though there is definitely some minor bug with this version.


    A few seconds ago I was shutting down Compressor and accidentally hit a random key which for some reason froze the offending flashing message on the screen, until I shutdown Compressor completely.


    Screen shot 2013-01-22 at 08.39.50.png



    I clicked "Allow" but once again 4.0.6 flashes every few seconds.


    Message was edited by: Ian R. Brown

  • Ian R. Brown Level 6 Level 6 (18,580 points)

    My iMac is a dual-boot machine so I booted out of Snow Leopard into Mountain Lion.


    Copied Compressor and the video file across.


    Compressor works flawlessly.


    So that suggests fairly conclusively that the issue is related to a SL/Compressor 4.0.6 clash.


    Incidentally I was using a 1080p30 clip together with the AVCHD/BD preset.

  • Warwick Teale Level 3 Level 3 (580 points)

    Hi ian, yeah could be.  I'm  on Mac osx 10.8.2.  I'd hazard a guess that Russ is the same.


    There were some big changes under the covers in Lion 10.7


    And some more under 10.8 ML


    Could be your issue


    Of u can upgrade the os it might be a start


    In the meantime. Why not try and disable your network and also Qmaster and see if can at least get a job out


    If that works, leave the network off and fire up Qmaster and repeat


    Worth a try



  • Ian R. Brown Level 6 Level 6 (18,580 points)

    I'm not bothering with it any more as the flashing did not prevent it from working and in any case I'll just use 4.0.5 which I also have on the computer.


    It was never a functionality issue, just a minor irritant.


    I'm thinking of deleting my iMac and reinstalling ML and all my apps from scratch.


    It's long overdue as I haven't done it since doing a complete erase and install of SL over 3 years ago.

  • Warwick Teale Level 3 Level 3 (580 points)

    Hi ian... Lol :) sounds like a good plan. 



  • Ian R. Brown Level 6 Level 6 (18,580 points)

    I'm going to put a "solved" on this issue as I can't see any real point in carrying on with it.

  • Ian R. Brown Level 6 Level 6 (18,580 points)

    You remember how I had the iMac in dual boot mode between SL and ML?


    Compressor 4.0.6  worked perfectly without flashing in ML.


    Well on Wednesday I erased my iMac and did a clean install of ML, something I had been intending to do for the last couple of years.


    Guess what?


    It flashes now in ML even though it was perfect in ML when in dual boot mode.


    Theoretically doing a clean install of the operating system should get rid of any glitches  .  .  .  .  .  but sometimes theory and practice don't always agree! 


    4.0.5 still works flawlessl, thank goodness.


    Incidentally, I  noticed that in FCP X 10.0.7, the Input Gain Control does not work on my newly upgraded iMac, but as I so rarely use the voiceover tool I can't remember when it last did work  .  .  .  if ever.

  • Warwick Teale Level 3 Level 3 (580 points)

    Hi ian.. GeeZ that's annoying. Do you still want to try and resolve this?


    If so:

    Step 1) Can you check the /var/logs for any messages relating to Qmaster , compressor.app and network?

    Step 2) Also, would you try funning compressor.app with Qmaster stopped (disabled) then

    Step 3) Disable all your  network (set a network config to have NO NETWORK NICs), restablish Qmaster and try compressor.app again.


    Post your results.


    FCPX issue.. Tackle that next..:)



  • Ian R. Brown Level 6 Level 6 (18,580 points)

    I am a complete novice with Console.


    In the  /var/log section there were only a few dozen entries (because it is a new system?), and none of them related to Compressor etc.


    I have never consciously used Qmaster (whatever it may be) and don't understand the instructions in Step 3.

  • Warwick Teale Level 3 Level 3 (580 points)

    Hi Ian, cool. A few notes....


    1) Console.app: make sure "show log list" is selected pane view.. ... Then look for "All Messages" under the "system log queries" heading at the top left of the logs....


    Look for anything or search using the filter on the top right corner of the new "find" ( cMd+F) in the edit application menu.  You're looking for any global messages that your Compressor.app UI or underwear may have logged. I'm uncertain if compressor.Pp keeps any non-error logs in ~/library/logs ....however if compressor.app prangs osx keeps partial dumps etc in crasheeporter .. You might se these if compressor locks up or fails. These are exposed in console.app as well under the user dumps or application logs.


    Tip: in the console.app's application VIEW menu, tick all the 'Show PID, Sender, etc" this pretties up the view and bolds up and icons the formatting a bit to make it easier to see stuff.


    While you're in there see if there's any Qmaster messages too.


    You can go in through the backdoor to see any RECENT messages that may be in ~/library/application support/apple Qmaster/logs/ . Now there are a dose of logs in there for the clustercontoller, service nodes etc. the will open and be formatted in console.app or preview.app and also quickview.


    See what u can turn up..


    2) apple Qmaster: this will/may want to access resources on a network.. You MAY have it started and I'd so there may be a cluster looking for some "company" (some service node "mates" on the LAN.


    If so, simply shutdown Qmaster using the compressor.app's "apple Qmaster" menu/share this computer/setup tab/untick the "share the computer" .. Wait 10 secs or so and Qmaster will terminate.


    Post your results for others to see.




  • Warwick Teale Level 3 Level 3 (580 points)

    ... Whoops neglected "step 3" .....  This is about organising a compressor.app usage test without aNy network available to your host. I'm curious to see if u still get your nagging message.


    So,, rather than pull out cables and bugger around with airport etc... Simply set up another network configuration with "no network" and pl this.


    Simple steps: all this happens in system preferences/network pane ...


    Step 1) open your default network setting as a above . Look for the "Location" list box. Unless you have a few of these it's probably named "automatic"


    Step 2) gear down on the list box for "location" and click on "edit locations" and select the "+" sign in the lower left of the new pane ... This creates. New "untitled" location


    Step 3)'overripe the name of "untitled" and rename it "no-network". Then click on "done" ...


    Step 4) in location list, select the new "no-network" configuration.


    Step 5) lastly, serially select each of the network interfaces that are there and delete them using the "-" sign in the bottom left of the network pane. Delete them all an finally click on "APPLY" .. No you have no network.


    Try compressor.app n see if you get any errors as I describe.


    When finished, just go back I to network pref and select your default configuration and "APPLY" it ? Your net work is reinstated!!


    Post your results for others to see.




  • Ian R. Brown Level 6 Level 6 (18,580 points)

    I have now solved the problem with a workaround ........... well actually there are 2.


    If you remember, I was getting irritating popups, lasting a fraction of a second every 5 seconds, asking whether Compressor could accept incoming connections.


    This only occurred with versions 4.0.6 and 4.0.7.   Furthermore, if I booted out of Mountain Lion into Snow Leopard, the popups stopped. Obviously the problem was caused by something on my computer clashing with Mountain Lion and the latest versions of Compressor.


    So back to the 2 workarounds.


    1. In System Preferences select "Block all incoming connections" or


    2. Turn off the Firewall.


    This sounds dangerous but apparently it is not, because assuming you are at home and connected to the internet by your ISP's router, you are getting all the protection that is necessary or possible.


    Basically the only time you need your Firewall switched on is if you are away from home using some wi-fi hotspot and this will only apply to laptops for obvious reasons, unless you are in the habit of setting up your iMac or MacPro in a park in the middle of your local town.


    Further Info   .  .  .  .  http://www.reedcorner.net/?p=224