Previous 1 2 Next 19 Replies Latest reply: Feb 3, 2013 10:09 AM by sjp2057
sjp2057 Level 1 (0 points)

My preferences opens then closes almost as soon as the window is open. It then wants to report the closure. Ive checked the communities and google but not found an answer yet.

 

my Lion 10.7.2 is up to date.

 

Any ideas welcome

 

sjp2057


MacBook, Mac OS X (10.7.5)
  • Dale Weisshaar Level 6 (15,860 points)

    Do you mean System Preferences?

  • sjp2057 Level 1 (0 points)

    sorry - yes i mean System Preferences.

     

    Since starting this question i have noticed that my iphotos is doing the same thing.

     

    sjp2057

  • sjp2057 Level 1 (0 points)

    getting mixed up here, i should have replied to you.

     

    try again

     

    sorry - yes i mean System Preferences.

     

    Since starting this question i have noticed that my iphotos is doing the same thing.

     

    sjp2057

  • Dale Weisshaar Level 6 (15,860 points)

    Start from your recovery system. OS X Lion or OS X Mountain Lion includes a built in set of utilities in the Recovery System. Restart your Mac and hold down the Command key and the R key (Command-R), and keep holding them until the Apple icon appears, indicating that your Mac is starting up. After the Recovery System is finished starting up, you should see a desktop with a OS X menu bar and a "Mac OS X Utilities" application window. Note: If you see a login window or your own desktop and icons, it is possible that you didn't hold Command-R early enough. Restart and try again.

    When your computer finishes starting up, choose Disk Utility from the Utilities window.

    Click the First Aid tab. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.

    Select your OS X volume.

    Click Repair. Disk Utility checks and repairs the disk.

     

    DALE

  • sjp2057 Level 1 (0 points)

    Just tried it and it said the volume was OK.

     

    Tried the Sys Preferences again and still closed as before?.

     

    sjp2057

  • Dale Weisshaar Level 6 (15,860 points)

    Did you run the Repair, not Repair Permissions, or just the Verify?

  • sjp2057 Level 1 (0 points)

    Hi

     

    Thanx for your help on this for me.

     

    I have tried it again and the utility said that the volume seemed OK so i have started the system preferences and it has come up with an empty window (which is better than before ) but it still shut down afterwards.

     

    I did run the repair as you said

     

    Steve P

  • Dale Weisshaar Level 6 (15,860 points)

    sjp2057 wrote:

     

    Hi

     

    Thanx for your help on this for me.

     

    No problem. Do you have a backup of your files at all?

  • sjp2057 Level 1 (0 points)

    Yes.

     

    steve P

  • Dale Weisshaar Level 6 (15,860 points)

    You could reinstall using your Recovery System.

    You'll need to have a good Ethernet or Wi-Fi network.

     

    DALE

  • sjp2057 Level 1 (0 points)

    `i will give it a try tonight

     

    thanx - I will be in touch

     

    steve P

  • sjp2057 Level 1 (0 points)

    Hi Again

     

    Ive tried to do the Recovery but it hang at 13hrs 18mins to go. The log said there was some files which could not be found.

     

    Looking at other entrys in this forum , some suggest the Plist in system preferences may be faulty ??.

     

    steve P

     

    NB what a game !!!

  • Dale Weisshaar Level 6 (15,860 points)

    See this thread from earlier today on systempreferences.plist

    Not being able to reinstall is not a good sign. If you go to Disk Utility, click on your main hard drive....not a partition...and read the drives S.M.A.R.T. status at the bottom of the window. Verified would be normal.

     

    DALE

  • sjp2057 Level 1 (0 points)

    Hi

    I have done as you said and the drive says Verified.

     

    I have removed the "systempreferences.plist" and deleated it however I noticed loats of other (6 No) the same name but with jumbled letters at the end rather than . plist. I have deleated these as well and rebooted .

     

    No difference.

     

    NB my Iphotos wont open now either . Loooking on other web sites they are suggesting some thing may be wrong with the pictures used for the screen saver .

     

    This is the first time (in 8 yrs) my mac has played up. 

     

    steve P

Previous 1 2 Next