13 Replies Latest reply: Feb 16, 2014 1:22 AM by lindafromnzl
tfdchief Level 1 (0 points)

I upgraded from SL to ML about a month ago and since that time I cannot receive images in Mail, all I get is a dimmed out "Missing Plug-in" where the image should appear. It's the same when sending an image, however images from web sites come through just fine. Rebuiling the Maiilbox didn't help nor, at least so far, none of the other fixes I have come across.  Any ideas or suggestions would be very much appreciated.

iMac, OS X Mountain Lion (10.8.2)
  • dominic23 Level 8 (36,385 points)

    Mail > Preferences >Viewing


    Checkmark the box next to "Display remote images in HTML messages".


    Hope this helps.

  • tfdchief Level 1 (0 points)

    I've already tried that sir. Just went back in to make sure and it was still checked.

  • dominic23 Level 8 (36,385 points)

    One of the reasons for this to happen is problem with Java plug-in.


    I do not have Java Runtime installed in this computer.


    So I cannot check it before posting an answer.


    Hopefully somebody else will pick this up and post an answer.



  • tfdchief Level 1 (0 points)

    My tech savvy son came to my rescue finally and after poking around in Termianal put two folders on my desktop then stated "Your problem is in one of these folders but I'm not sure which one. See if there's something that doesn't work right and we'll add these back in one at a time, or, maybe not at all". One folder has:

    FolxNetscapePlugIn.plugin and



    the other has:











    Everything seems to be working fine so thought I would pass this along.

  • flason Level 1 (5 points)



    Mountain Lion 10.8.2 with Java RTE / JTRE disabled. 


    This plugin may be removed to the desktop and then re-launching Mail showed the attachments and not "Missing Plug-in"



    WHERE username is YOUR account login name (your username)


    Open a Finder window

    Use the key combination Command Shift G

    to open the Go To File window and copy the path above into the window,

    change username to your user account leaving the / marks


    drag file to the desktop and relaunch Mail


    Or the long way to do the same thing:

    Open a Finder window and >Go (hold down Option key) > Library

    in that window Command F to search (select Library)

    paste the filename above into the search box in the Finder window, >Return

    Right-Click (Command Click) and select Open Enclosing Folder from the menu

    Drag the file to the desktop and relaunch Mail.

  • ErikMathlener Level 1 (0 points)

    Thanks Flason!!


    I have been puzzling for hours to fix this problem with non showing images in my e-mails. Everybody is talking about a Java-problem, but that wasn't the cause in my case.


    In the directory "/Library/Internet Plug-ins" I found several plugins. I moved all of them to the Desktop and then my images were back in Mail! Then, I one-by-one copied the plugins back in the /Library/Internet Plug-Ins directory. The one that was giving me the trouble was JavaPluginCocoa.bundle.


    Thank you so much!!

  • victorhencken Level 1 (10 points)

    Flason's fix worked for me also... thanks

  • 23david23 Level 1 (0 points)

    This also worked for me... thanks!!... but now what do I do with the file, "com.oracle.java.JavaAppletPlugin"? 

    Can I trash it?

  • flason Level 1 (5 points)

    Yes. But to be doubly cautious, on this or any such file - right (control) click on the file icon and from the list select Compress < filename >


    This will make a .zip file of the suspicious file (in case you actually need it back after the following - just double click a .zip to open it)


    Trash the file from your desktop (keeping the .zip file if you made one)

    Empty the Trash

    See what happens over a few days and a restart, if all is well

    Trash the .zip file, too.


    Like I said - this is the very cautious approach.

  • camjross Level 1 (10 points)

    Same problem here - but the 'flason fix' mentioned did not work for me - I had no plugins in my USER Library folder. I did however have qute a few plugins in the top level Library folder (Macintosh HD -> Library -> Internet Plug-Ins). Having Mac Mail quit first, then deleting all these (authentication required) and opening mac mail again - all images now show, so the probelm was one of them. I kept a backup of those plugins in a folder just in case.


    Interestingly, there was only one Java related plugin in there - and it was an alias "JavaAppletPlugin.plugin". That plugin resided in the folder 'Macintosh HD -> System -> Library -> Java -> Support -> CoreDeploy.bundle -> Contents -> JavaAppletPlugin.plugin'. So it seems different people have it located in different areas - but it all points to Java being the culprit.


    Thanks to flason for pointing in the right direction!

  • rodgerfromgbr Level 1 (0 points)

    I had the same problem, and the 2nd para in 'camjross' solution worked for me, once I had stopped mail, and located the file "JavaAppletPlugin.plugin" - it was located in 'Macintosh HD -> System -> Library -> Internet Plug-Ins"


    I then deleted the plugin and restarted mail, and "hey presto", all the images were vieable once again.


    Many thanks to all for pointing the way.

  • rhon260 Level 1 (0 points)

    i try to watch a youtube video and it says "missing plug-in" so i click on that and go to "more information" and i installed flash player. but it still won't let me watch the video. please help!

  • lindafromnzl Level 1 (0 points)

    Thank you for your help...worked fine for me too! Cheers Linda