6 Replies Latest reply: Apr 4, 2013 12:11 AM by sdive
JerryK1 Level 1 Level 1

I have a 'document' that starts up automatically when I boot my MBA.  The file name it opens is "Audio Dynamics Processor.trak".


I am using this to compress audio output so that the sound volume is less dynamic.


The problem is that there is no sound when I start up. To hear the sound, I have to open the "Studio" tab, and change the Output Settings from Soundflower (2ch) to Built-in Output.  I save the document again under the same name (and I've verifed that the new version is getting save), but for some reason when it next starts up the Output Settings are once again set to Soundflower.


Any help as to how to make this change persist would be appreciated.





  • cheekypaul Level 2 Level 2

    can you link to the software that compresses the audio output?

    also, operating system and versions of all the software you're using.

    sounds mad, but it will help with anyone thinking about an answer...

  • JerryK1 Level 1 Level 1

    Cheekypaul -


    Thanks for the advice.


    I believe that AU Lab is a built in program from Apple.


    The URL given in the Help menu selection is:




    OS is:


    OS X 10.8.2 (12C3012)


    AU Lab is Version is: 2.2.2 (2.2.1)  Copyright 2010 Apple, Inc.


    Any advice appreciated.

  • cheekypaul Level 2 Level 2

    aah, your title is AV lab not AU Lab.


    when you say 'document', what is the document?


    when you say audio output/sound volume,audio/ sound volume of what?


    very interesting. isn't this for the development/practice of the audio side of apps?


    a quick short cut might be to find the preference for your setting (plist) and try and lock it so it doesn't change.


    and share the setting when you get it to work, whatever it is you're doing...!

  • JerryK1 Level 1 Level 1

    Thanks sdive - perfect.


    Perhaps you also have a solution to the 'next' problem?


    I have AU Labs starting up when I boot my Macbook Air. Under settings, I have selected "Open a specific Document" below "When Launching AU Lab:". There is a specific document 'chosen'. However, it does not appear to be opening this document automatically. I still have to go to "Open Recent" from the file menu and select the file each time I boot up.


    This feels like some sort of pilot error to me, but perhaps you have a magic solution to this issue as well.





  • sdive Level 1 Level 1

    I don't know. It works for me. Maybe you can try moving the file somewhere else and retry?