Previous 1 2 Next 16 Replies Latest reply: Sep 21, 2013 9:19 AM by MaverickFZ6 Go to original post
  • WizeWun Level 1 Level 1 (0 points)

    Unfortunate my suggestions was unable to resolve your issues. For testing purposes you can also temporarily eliminate your router by connecting your Apple TV direct into your cable modem via ethernet cable. This would also let you know if the issue lies within your router. Good luck

  • MaverickFZ6 Level 1 Level 1 (0 points)

    Thanks; I too, need to now be on the same local network.







    I too have 3rd Gen Apple TV which worked fine then randomly began having this issue. I do not have any firewall or alike software and normally a simple reboot usually help; in this case failed! I configured DHCP reservations for Apple Ethernet & WiFi connections via my wireless router, manually assigned the addresses in Apple TV Network preferences, restarted the Apple TV device, I'm now able to use home sharing via WiFi but ethernet not ethernet. To troubleshoot the home sharing via ethernet connection, I disabled my IMBP WiFi Card, connected both MBP and Apple TV to my router using ethernet cables then confirmed home sharing worked. Additionally, based on the Apple's TCP/UPD chart and using Terminal, Activity Monitor, and Network Utility I was able to verify daap uses 3689 (iTunes Sharing) and not as 5353 (Bonjour, AirPlay, Home Sharing, Printer Discovery, Back to My Mac) as the chart recommends.


    Being on different networks in the past I had no issues or who knows, perhaps overlooked. What caused it? OSX update? iTunes bug? not sure.


    Conclusion: Both devices (Apple TV + iPhone, iPad, MacBook) should be on the same netowrk (Wired or Wirelessly) and should work just fine.



    Network Utility


    Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)  

    tcp4       0      0  machinename..daap     ESTABLISHED

    tcp4       0 303104  machinename..daap     ESTABLISHED

    tcp4       0      0  machinename..daap     ESTABLISHED

    tcp4       0      0  machinename..daap     ESTABLISHED

    tcp4       0      0  machinename..daap     ESTABLISHED


    Activity Monitor









    Listen/Show for connections via terminal


    machinename:~ username$ sudo lsof -i -P | grep -i "listen"

    launchd      1           root   28u  IPv6 0x57aeb7c59531c517      0t0  TCP localhost:631 (LISTEN)

    launchd      1           root   29u  IPv4 0x57aeb7c5953224ff      0t0  TCP localhost:631 (LISTEN)

    vpnagentd   60           root   14u  IPv4 0x57aeb7c595321dc7      0t0  TCP localhost:29754 (LISTEN)

    iTunes     952          username   25u  IPv4 0x57aeb7c59a6ddf57      0t0  TCP *:3689(LISTEN)

    iTunes     952          username   26u  IPv6 0x57aeb7c59531c137      0t0  TCP *:3689(LISTEN)


    Message was edited by: WizeWun

Previous 1 2 Next