4 Replies Latest reply: Jan 29, 2013 5:48 PM by mcharek
mcharek Level 1 (0 points)

I just let the Software Update do its thing on my Mac, and now my Designjet T610 is behaving strangely. It won't print part of the sheet border on my drawings. Even stranger, it only does this on the first of multiple copies of a sheet that I print. Print one copy, no border. Print two or three copies, no border on the first, the second and third print normally.


Anyone else seeing something like this? Any ideas on how to fix, other than wasting a lot of paper printing one extra copy of everything?


Early 2008 Mac Pro, 2 x 2.8 GHz Quad-Core Intel Xeon, memory 10 GB. OSX 10.8.2. Printing with PowerCADD 9. All was working fine before this software update.

iCal, Mac OS X (10.7.4)
  • GarlandM Level 2 (195 points)

    Hi Mcharek,


    Which driver version did you download?

  • mcharek Level 1 (0 points)

    I just clicked on Update in the Software Update window, which just said HP Printer Software Update, no specific drivers. The HP Designjet T610 24 inch printer package version which appears in the Printers folder in the Library folder is 7.1, with a creation date of 8/4/11. Interestingly enough, Time Machine shows the same version and date going all the way back to the earliest instance in November 2011.


    I was getting all ready to do some multi-step Terminal thing listed elsewhere in the forum for restoring a printer driver from Time Machine, but now I don't know if that is even the issue.

  • mcharek Level 1 (0 points)

    I fixed it by doing the following:


    Deleted the printers in the System Preferences: Print & Scan window.

    Deleted the hp folder in my hard drive root directory: Library: Printers folder

    Deleted all the HP PPDs in hard drive root directory: Library: Printers: PPDs: Contents: Resources folder


    I then downloaded the latest HP printer software update from the Apple site, ran its installer, and installed my HP printers again in System Preference: Print & Scan.


    Success! I will need to recreate some custom page sizes in the DesignJet driver, but at least printing works properly.


    By allowing the Apple Software Update to install itself from the App Store Software Update window, I must have allowed some sort of corruption of the printer software to occur.

  • mcharek Level 1 (0 points)

    The problem resurfaced today after I tried to set up a custom page size. Too tired to run my repair routine, but hopefully that's a clue to someone who may or may not be paying attention here and is in a position to fix it...