2 Replies Latest reply: Jan 24, 2013 2:39 PM by Matthew Palm
Matthew Palm Level 1 (40 points)

I was listening to music on iTunes this evening, streaming to my an Airport Express via AirPlay, to play on my stereo.


After about an hour, the sound became distorted, and all of a sudden the computer restarted.


Upon restart there was a message saying I had experienced a kernel panic.


The log is attached below.


All I can decipher is "Word" (yes, Miscoroft Word was running at the time).


Is this something I can fix? Is it possibly a more systemic problem?


Thanks for any help or advice.


Here's the log:


Wed Jan 23 19:51:27 2013

Panic(CPU 0): NMIPI for spinlock acquisition timeout, spinlock: 0xffffff801bf60b20, spinlock owner: 0xffffff8019c55000, current_thread: 0xffffff8019c55000, spinlock_owner_cpu: 0x0

RAX: 0x00000000000000fe, RBX: 0xffffff8019a83800, RCX: 0x3c2389fa00000000, RDX: 0xffffff80f83cb000

RSP: 0xffffff80e8e88ec0, RBP: 0xffffff80e8e88f40, RSI: 0xffffff80e8e88ef8, RDI: 0xffffff8019a83800

R8:  0x0000000000000001, R9:  0x00000000000003ff, R10: 0xffffffffffffffff, R11: 0x00000000ffffffff

R12: 0xffffff80e8e88ef8, R13: 0xffffff801978ac40, R14: 0xffffff80193ea000, R15: 0xffffff80e8e88f08

RFL: 0x0000000000000087, RIP: 0xffffff7f87495046, CS:  0x0000000000000008, SS:  0x0000000000000010

Backtrace (CPU 0), Frame : Return Address

0xffffff80e8e88d40 : 0xffffff8005ebd371

0xffffff80e8e88d70 : 0xffffff8005eb7203

0xffffff80e8e88dc0 : 0xffffff8005ece81b

0xffffff80e8e88f40 : 0xffffff7f86451825

0xffffff80e8e88f50 : 0xffffff7f87ad362d

0xffffff80e8e88f60 : 0xffffff7f87adab5b

0xffffff80e8e88f80 : 0xffffff8005eb720f

0xffffff80e8e88fd0 : 0xffffff8005ece6a8

0xffffff80f80c3f00 : 0xffffff8005e27c2c

0xffffff80f80c3f60 : 0xffffff8005e3dcde

0xffffff80f80c3fb0 : 0xffffff8005eb26b7

      Kernel Extensions in backtrace:

         com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f86450000->0xffffff7f86474fff

         com.apple.driver.AppleACPIPlatform(1.6)[4F08531B-7E5A-3604-924A-8769CF53458B]@0 xffffff7f87acd000->0xffffff7f87b23fff

            dependency: com.apple.iokit.IOACPIFamily(1.4)[A35915E8-C1B0-3C0F-81DF-5515BC9002FC]@0xfffff f7f868dc000

            dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f86450000

      Kernel Extensions in backtrace:

         com.apple.kext.AMD6000Controller(8.0)[B8119AB9-CAB3-374E-917D-294D7365F60A]@0xf fffff7f87493000->0xffffff7f874d8fff

            dependency: com.apple.iokit.IOACPIFamily(1.4)[A35915E8-C1B0-3C0F-81DF-5515BC9002FC]@0xfffff f7f868dc000

            dependency: com.apple.iokit.IOPCIFamily(2.7.2)[B1B77B26-7984-302F-BA8E-544DD3D75E73]@0xffff ff7f86450000

            dependency: com.apple.kext.AMDSupport(8.0.0)[7B2EC6D1-101A-3928-919E-337D6724752A]@0xffffff 7f8728e000

            dependency: com.apple.iokit.IOGraphicsFamily(2.3.5)[803496D0-ADAD-3ADB-B071-8A0A197DA53D]@0 xffffff7f8696d000



BSD process name corresponding to current thread: kernel_task



Mac OS version:




Kernel version:

Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

Kernel slide:     0x0000000005c00000

Kernel text base: 0xffffff8005e00000

System model name: iMac12,2 (Mac-942B59F58194171B)



System uptime in nanoseconds: 4878291272795

last loaded kext at 3662890564202: com.apple.filesystems.afpfs          10.0 (addr 0xffffff7f880a2000, size 348160)

last unloaded kext at 190082074554: com.apple.driver.AppleUSBUHCI          5.2.5 (addr 0xffffff7f86717000, size 65536)

loaded kexts:

com.apple.filesystems.afpfs          10.0

com.apple.nke.asp_tcp          7.0.0

com.apple.driver.AppleBluetoothMultitouch          75.15

com.apple.driver.AppleHWSensor          1.9.5d0

com.apple.driver.AudioAUUC          1.60

com.apple.filesystems.autofs          3.0

com.apple.driver.AGPM          100.12.69

com.apple.iokit.IOBluetoothSerialManager          4.0.9f33

com.apple.driver.AppleMikeyHIDDriver          122

com.apple.driver.AppleHDA          2.3.1f2

com.apple.iokit.IOUserEthernet          1.0.0d1

com.apple.driver.AppleUpstreamUserClient          3.5.10

com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport          4.0.9f33

com.apple.driver.AppleMikeyDriver          2.3.1f2

com.apple.driver.AppleBacklight          170.2.3

com.apple.kext.AMDFramebuffer          8.0.0

com.apple.driver.AppleSMCPDRC          1.0.0

com.apple.driver.AppleLPC          1.6.0

com.apple.driver.ACPI_SMC_PlatformPlugin          1.0.0

com.apple.driver.AppleMCCSControl          1.0.33

com.apple.driver.AppleIntelHD3000Graphics          8.0.0

com.apple.Dont_Steal_Mac_OS_X          7.0.0

com.apple.driver.ApplePolicyControl          3.2.11

com.apple.AMDRadeonAccelerator          1.0.0

com.apple.driver.AppleSMCLMU          2.0.2d0

com.apple.driver.AppleIntelSNBGraphicsFB          8.0.0

com.apple.driver.AppleIRController          320.15

com.apple.iokit.SCSITaskUserClient          3.5.1

com.apple.driver.AppleUSBCardReader          3.1.0

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless          1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

com.apple.BootCache          34

com.apple.driver.XsanFilter          404

com.apple.iokit.IOAHCIBlockStorage          2.2.2

com.apple.driver.AppleUSBHub          5.2.5

com.apple.driver.AirPort.Atheros40          600.70.23

com.apple.iokit.AppleBCM5701Ethernet          3.2.5b3

com.apple.driver.AppleFWOHCI          4.9.6

com.apple.driver.AppleAHCIPort          2.4.1

com.apple.driver.AppleUSBEHCI          5.4.0

com.apple.driver.AppleEFINVRAM          1.6.1

com.apple.driver.AppleRTC          1.5

com.apple.driver.AppleACPIButtons          1.6

com.apple.driver.AppleHPET          1.7

com.apple.driver.AppleSMBIOS          1.9

com.apple.driver.AppleACPIEC          1.6

com.apple.driver.AppleAPIC          1.6

com.apple.driver.AppleIntelCPUPowerManagementClient          196.0.0

com.apple.nke.applicationfirewall          4.0.39

com.apple.security.quarantine          2

com.apple.driver.AppleIntelCPUPowerManagement          196.0.0

com.apple.security.SecureRemotePassword          1.0

com.apple.driver.IOBluetoothHIDDriver          4.0.9f33

com.apple.driver.AppleMultitouchDriver          235.28

com.apple.kext.triggers          1.0

com.apple.iokit.IOSerialFamily          10.0.6

com.apple.driver.DspFuncLib          2.3.1f2

com.apple.iokit.IOAudioFamily          1.8.9fc10

com.apple.kext.OSvKernDSPLib          1.6

com.apple.iokit.IOSurface          86.0.3

com.apple.iokit.AppleBluetoothHCIControllerUSBTransport          4.0.9f33

com.apple.driver.AppleBacklightExpert          1.0.4

com.apple.driver.IOPlatformPluginLegacy          1.0.0

com.apple.driver.IOPlatformPluginFamily          5.2.0d16

com.apple.driver.AppleSMBusController          1.0.10d0

com.apple.driver.AppleSMBusPCI          1.0.10d0

com.apple.driver.AppleThunderboltEDMSink          1.1.8

com.apple.driver.AppleThunderboltEDMSource          1.1.8

com.apple.iokit.IOFireWireIP          2.2.5

com.apple.driver.AppleHDAController          2.3.1f2

com.apple.iokit.IOHDAFamily          2.3.1f2

com.apple.iokit.IOBluetoothFamily          4.0.9f33

com.apple.driver.AppleGraphicsControl          3.2.11

com.apple.iokit.IOAcceleratorFamily          19.0.26

com.apple.kext.AMD6000Controller          8.0.0

com.apple.kext.AMDSupport          8.0.0

com.apple.iokit.IONDRVSupport          2.3.5

com.apple.iokit.IOGraphicsFamily          2.3.5

com.apple.driver.AppleSMC          3.1.4d2

com.apple.driver.AppleUSBHIDKeyboard          165.5

com.apple.driver.AppleHIDKeyboard          165.5

com.apple.driver.AppleThunderboltDPOutAdapter          1.8.5

com.apple.driver.AppleThunderboltDPInAdapter          1.8.5

com.apple.driver.AppleThunderboltDPAdapterFamily          1.8.5

com.apple.driver.AppleThunderboltPCIDownAdapter          1.2.5

com.apple.iokit.IOSCSIMultimediaCommandsDevice          3.5.1

com.apple.iokit.IOBDStorageFamily          1.7

com.apple.iokit.IODVDStorageFamily          1.7.1

com.apple.iokit.IOCDStorageFamily          1.7.1

com.apple.iokit.IOUSBHIDDriver          5.2.5

com.apple.iokit.IOAHCISerialATAPI          2.5.0

com.apple.iokit.IOSCSIBlockCommandsDevice          3.5.1

com.apple.iokit.IOUSBMassStorageClass          3.5.0

com.apple.iokit.IOSCSIArchitectureModelFamily          3.5.1

com.apple.driver.AppleUSBMergeNub          5.2.5

com.apple.driver.AppleUSBComposite          5.2.5

com.apple.iokit.IOUSBUserClient          5.2.5

com.apple.driver.AppleThunderboltNHI          1.6.0

com.apple.iokit.IOThunderboltFamily          2.1.1

com.apple.iokit.IO80211Family          500.15

com.apple.iokit.IOEthernetAVBController          1.0.2b1

com.apple.iokit.IONetworkingFamily          3.0

com.apple.iokit.IOFireWireFamily          4.5.5

com.apple.iokit.IOAHCIFamily          2.2.1

com.apple.iokit.IOUSBFamily          5.4.0

com.apple.driver.AppleEFIRuntime          1.6.1

com.apple.iokit.IOHIDFamily          1.8.0

com.apple.iokit.IOSMBusFamily          1.1

com.apple.security.sandbox          220

com.apple.kext.AppleMatch          1.0.0d1

com.apple.security.TMSafetyNet          7

com.apple.driver.DiskImages          344

com.apple.iokit.IOStorageFamily          1.8

com.apple.driver.AppleKeyStore          28.21

com.apple.driver.AppleACPIPlatform          1.6

com.apple.iokit.IOPCIFamily          2.7.2

com.apple.iokit.IOACPIFamily          1.4

com.apple.kec.corecrypto          1.0

panic(cpu 5 caller 0xffffff8005e27e07): "Spinlock acquisition timed out: lock=0xffffff801bf60b20, lock owner thread=0xffffff8019c55000, current_thread: 0xffffff801b32baa0, lock owner active on CPU 0x0, current owner: 0xffffff8019c55000"@/SourceCache/xnu/xnu-2050.18.24/osfmk/i386/locks_i386.c:363

Backtrace (CPU 5), Frame : Return Address

0xffffff80f80abe60 : 0xffffff8005e1d626

0xffffff80f80abed0 : 0xffffff8005e27e07

0xffffff80f80abf00 : 0xffffff8005ea59be

0xffffff80f80abfb0 : 0xffffff8005eceafe



BSD process name corresponding to current thread: Microsoft Word

iMac, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 (192,922 points)

    That panic was not caused by third-party software. If it's happened only once, and is not repeated in at least a few thousand hours of use, a reasonable choice would be to ignore it. Machines don't work perfectly. They never will.


    If the problem is recurrent, the possibilities are (1) a damaged OS X installation; (2) a fault in a peripheral device, if any; (3) an internal hardware fault; and (4) an obscure bug in OS X.


    You can rule out the first two possibilities by reinstalling the OS and testing with non-essential peripherals disconnected and aftermarket expansion cards removed, if applicable. Sometimes a clean reinstallation (after erasing the startup volume) may solve a problem that isn't solved by reinstalling in place, without erasing.


    If you've recently upgraded the memory, reinstall the original memory and see whether there's any improvement. Be careful not to touch the gold contacts on the memory modules when handling them. If necessary, clean them with a mild solvent such as rubbing alcohol.


    The Apple Hardware Test, though generally unreliable, will sometimes detect a fault. A negative test can't be depended on. Run the extended version of the test.


    In the category of obscure bugs, reports suggest that FileVault may trigger kernel traps under some unknown conditions. Most, if not all, of these reports seem to involve booting from an aftermarket SSD. If those conditions apply to you, try deactivating FileVault.


    Otherwise, make a "Genius" appointment at an Apple Store to have the machine tested. You may have to leave it there for several days. There isn't much point in doing this unless you can reproduce the panic, or if you can't, it happens often enough that it's likely to be repeated at the store. Otherwise you may be told that nothing is wrong.


    Print the first page of the panic report and bring it with you.


    Back up all data on the internal drive(s) before you hand over your computer to anyone. If privacy is a concern, erase the data partition(s) with the option to write zeros* (do this only if you know how to restore, and you have at least  two independent backups.) Don’t erase the recovery partition, if present.


    *An SSD doesn't need to be zeroed.

  • Matthew Palm Level 1 (40 points)

    Thanks, Linc.


    The kernel panic occurred again about 2 hours later (both last night).


    To answer some o your questions:


    -I did a re-install (clean erase and install) back in November.

    -I only have an Apple keyboard and an iPhone cable attached to the iMac (plus a BT Trackpad).

    -I haven't upgdared memory.

    -I ran the Hardware Test, which found nothing wrong.

    -I don't use File Vault.


    The good news is that I am covered by Apple Care, and I opened a case with them. We'll see what they say.


    Thanks for your help!