Previous 1 8 9 10 11 12 Next 196 Replies Latest reply: Jun 1, 2015 1:11 AM by sarcastor Go to original post
  • Roy_xc3 Level 1 Level 1 (0 points)

    i am hoping Apple will fix this  Soon

    Oh Juz to update i can't access my Purchased Either lol,No Choice but got to manual Search and Update

  • dickbrass Level 1 Level 1 (0 points)

    Alas, turning off wifi doesn't solve the problem for wifi-only models like mine.

     

    When I turn it back on the update screen is still blank.

     

    So scrolling through the Purchased list remains the kludge of choice if you don't have a cell enabled device.

  • healthguru Level 1 Level 1 (0 points)

    I too have a blank screen in App Store -> Updates.  Started occuring last night on 3/13/13.

    Have tried: reboot, language change, time zone change, signing out of App Store/iTunes.  NOTHING has worked.

    Apple - please fix.

     

    iPhone 4S, iOS 6.1.2

  • dickbrass Level 1 Level 1 (0 points)

    Heathguru,

     

    Out of curiosity, does your Purchased screen work?  Or is it also blank?

  • BB1818 Level 1 Level 1 (0 points)

    For wifi-only models, perhaps resetting network connections would do it?

  • Sk8Dreams Level 3 Level 3 (855 points)

    I'm convinced this is an Apple server problem.  This is the second time it's hit me.  It went away the first time, on two different devices.  The first time, I could see Purchased, but not this time on my phone.  I have a bit of interesting data regarding the issue.  Thinking maybe I could jog a stuck switch loose, I downloaded a new app.  That went fine, but when I checked my mail later, I had this message from Apple: 

     

    "Your Apple ID, xxx, was just used to download Flow Free from the App Store on a computer or device that had not previously been associated with that Apple ID."

     

    So, I think the problem may have to so with some program component at Apple temporarily being unable to associate a registered device to the Apple ID.  I plan to take a look in iTunes later, when I have time.

     

    (FWIW, signing out and then in again on the phone did nothing.)

  • Krazihanz Level 1 Level 1 (0 points)

    I got a iP5 and Im having the same issue as well. I tried all the tips that's posted and nothing works. This is a little ridiculous.

  • sacornwell Level 1 Level 1 (0 points)

    Turning off the wifi also worked for me!

  • WickedFred Level 1 Level 1 (0 points)

    Same issue here... I turned off my wifi and then rebooted App Store and was able to update, but using 4G data. Hopefully this gets fixed since my carrier limits download sizes and some can only be done over wifi!

  • Krazihanz Level 1 Level 1 (0 points)

    I just tried turning my wifi off, rebooting the phone, and still it's a No Go

  • mclim Level 1 Level 1 (15 points)

    My iPhone 5 is showing 3 ghost updates while my iPod Touch 4th gen is showing 4 ghost updates in the App Store icon, tried all the suggestions but unable to update.  Since so many people are having the same issues, it's more likely a problem from the Apple server, perhaps it's overloaded.

  • drbroom Level 1 Level 1 (5 points)

    The interesting item I am finding is that is seems to be iOS device specific... I have 3 iPhone 5 's and 2 iPads (an original and a 2) and only my 5 (running 6.1) is having the problem.

     

    My wife's who is running 6.1.2 is fine my daughter's that is running 6.1 is fine and the iPads are fine. So the real question is why?

     

    We all share the same apple ID for apps and music, but the apps that I have loaded are more "utility" based and a bit higher end (meaning cost) then my wife and daughters.

     

    In the end this just a real pain and I agree with who ever said it's an Apple server issue. I just think it might be the server and a specific app issue. Meaning there may be an App that is looking for iOS 6.1.2 and I'm running 6.1.

     

    My thinking revolves around sometime back when I didn't upgrade my iPhone 4 for a while and I kept getting a notice that 'xyz' app needed to be updated. However, when I tried to update said app I would get an alert that I couldn't because my phone wasn't running the right version of iOS. It would have been nice if the server was 'smart' enough to see what version I was running in the first place and not even offer me the update, but Apple these days doesn't seem to think of that kind of thing. (Aww for those days of yesteryear)...

  • deadringer28 Level 1 Level 1 (0 points)

    My three iPhone that it is happening on all have different iOS versions.

  • Sk8Dreams Level 3 Level 3 (855 points)

    It is not device based.  If you read the 9 preceeding pages, you will see that, but I can tell you so from my own experience with my iPhone 5, iPad 2, and iPad Mini, all of which have experienced the problem in one form or another.

     

    It also has nothing to do with apps requiring a particular OS.  I just sent a trouble report in to Apple and hope to get some kind of answer in the next day or two.

     

    Meanwhile, I connected to iTunes and found my phone was recognized as usual, but when I looked at my account info, only 2 of my 4 iDevices were listed as registered to my Apple ID.  However, of the two devices not listed, my iPad mini and my iPhone 5, only the iPhone 5 has the problem.

     

    I'm done trying to figure it out.  Will wait for it to go away, as it did previously.

  • Scott523 Level 1 Level 1 (35 points)

    Finally I managed to fix the blank update page in the App Store by signing out of the store, shutting down the app, then going to the update page of the App Store. Miraculously the apps appear in the update page without the need to be signed in. Then tapping install/update would make me enter my password to install the app.

Previous 1 8 9 10 11 12 Next